Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The small arrows showing that I replied or forwarded a message disappear as soon as I move to an inbox of another email address

  • 4 replies
  • 1 has this problem
  • 3006 views
  • Last reply by Toad-Hall

more options

If I reply to an e-mail or forward an e-mail, an arrow appears next to the message which indicates that I replied or forwarded the e-mail, which is what you expect to happen. However, if I leave that inbox and move to another e-mail, when I return to the original inbox, the arrow disappears almost immediately from that e-mail. At that point, I cannot tell if I replied or forwarded the e-mail. I have to go to the sent box and look for a reply e-mail. Obviously, this is not how this should work!

This never used to happen when I was using pop3. The only difference is that I am now using a IMAP server.

Chosen solution

It is also possible that after synchronising with server, your server does not support those arrow flags, so the arrow flags are in effect not stored on server.

Read this answer in context 👍 0

All Replies (4)

more options

To help understand what is going on could you clarify a few things.

Do you keep copies of messages in thunderbird profile or are you only downloading headers? Imap sees a remote view of what is on server. Usually only headers are downloaded and when you select to view an email it is retrieved from server and stored in a temp folder on computer to facilitate viewing. In your profile name folder you would only see *.msf index files. You would not be able to read emails if in offline mode.

If you have set that imap mail account to keep messages for this account on this computer and synchronise all messages locally, then you will be able to view those emails in offline mode. In your profile name folder you would see mbox files (files showing same name as folder with no extension) which contain emails and also *.msf index files.


Please confirm whether emails are fully downloaded.


Please try the following and report back on results.

  • Right click on folder and select 'Properties'
  • click on 'Repair Folder' button.
  • click on OK
more options

Chosen Solution

It is also possible that after synchronising with server, your server does not support those arrow flags, so the arrow flags are in effect not stored on server.

more options

I called my e-mail/webhosting service. They confirmed that an IMAP server synchronizes all devices you use, so the flags can't be supported. I would have to go back to POP3 for that to work again. The other advantages of keeping everything in sync across all devices outweighs the utility of the flags. Thanks for your assistance.

more options

A few ideas on how to work with imap system. Maybe you could use any of these to suit your working method.

Create a folder and call it 'Forwarded', then when you forward an email, move email to 'Forwarded' folder. Do the same for 'Replied'. At least this would keep track of what was 'Replied' and what was 'Forwarded' etc.

The trouble with threaded emails is they only show the responses in that thread.

For a quick uncluttered view, you could use:

  • right click on email and select 'Open Message in Conversation'

This opens in a new tab showing everything, both received and what you sent all in one view.

Another option would be to put all responses in the same folder. But I would recommend sorting emails into more defined folders before using this as it would then include all sent as well, thus increasing file size and it could seem muddled if loads of conversations.

  • Right click on mail account and select 'Settings'
  • Select : Copies & Folders
  • select checkbox 'Place replies in the folder of the message being replied to'
  • click on OK

Test this one and see if it works: Immediately after 'Forwarding' whilst a flag is set, try right click and 'Copy to' a 'Local Folders' folder. Does a copy with 'forwarded' flag appear in Local Folders ? This is now on your computer, so flag should stay.