X
Tap here to go to the mobile version of the site.

Support Forum

Can you actually disable automatic updates or is the setting just there to taunt us?

Posted

I have spent some time reading the forums and this seems to be a problem many people have. Unfortunately I have not read a post where an actual solution was offered. I get no sound in Firefox version 57 or 58. Version 56 would work except for I am forced to uninstall the latest version every couple days and reinstall Firefox at version 56. Every time I do this, I disable automatic updates. Firefox still automatically updates. WTF man. I see on these forums that many people need a previous version of Firefox for whatever reason and we all get the updates that break our specific machine's compatability forced on us EVEN THO WE HAVE SELECTED TO DISABLE THE AUTOMATIC UPDATES!!! Is there a way to check disable automatic updates and have it actually disable updating automatically? Or should I look for another browser?

I have spent some time reading the forums and this seems to be a problem many people have. Unfortunately I have not read a post where an actual solution was offered. I get no sound in Firefox version 57 or 58. Version 56 would work except for I am forced to uninstall the latest version every couple days and reinstall Firefox at version 56. Every time I do this, I disable automatic updates. Firefox still automatically updates. WTF man. I see on these forums that many people need a previous version of Firefox for whatever reason and we all get the updates that break our specific machine's compatability forced on us EVEN THO WE HAVE SELECTED TO DISABLE THE AUTOMATIC UPDATES!!! Is there a way to check disable automatic updates and have it actually disable updating automatically? Or should I look for another browser?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Linux; Android 5.0; SAMSUNG-SM-N900A Build/LRX21V) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.137 Mobile Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v56+] Type about:preferences#general<enter> in the address bar. Select Update.

Select Never Check For Updates.

Also turn off Use a background service to install updates <Windows Only>


Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

First, Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced, ''' Select '''Update. ''' [v56+] Type '''about:preferences#general'''<enter> in the address bar. Select '''Update. ''' Select '''Never Check For Updates.''' Also turn off '''Use a background service to install updates''' <Windows Only> --------------- [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

Question owner

You apparently missed the part where I said I'd already disabled automatic updates. So I will say it again in more detail. I already disabled automatic updates, told it to not check for updates, and not use the background service using the preferences you are trying to direct me to.

You apparently missed the part where I said I'd already disabled automatic updates. So I will say it again in more detail. I already disabled automatic updates, told it to not check for updates, and not use the background service using the preferences you are trying to direct me to.

Question owner

You apparently missed the part where I said I'd already disabled automatic updates. So I will say it again in more detail. I already disabled automatic updates, told it to not check for updates, and not use the background service to install updates. I did this using the preferences you are trying to direct me to. They aren't exactly hidden. Maybe before you answer a question with the first most obvious thing someone would do you should read enough of the question to know if that has already been tried

You apparently missed the part where I said I'd already disabled automatic updates. So I will say it again in more detail. I already disabled automatic updates, told it to not check for updates, and not use the background service to install updates. I did this using the preferences you are trying to direct me to. They aren't exactly hidden. Maybe before you answer a question with the first most obvious thing someone would do you should read enough of the question to know if that has already been tried
WestEnd
  • Top 25 Contributor
60 solutions 5379 answers

I will a test even with the changes it still does it's business. There is a way to stop but FF management will disavow such requests.

I will a test even with the changes it still does it's business. There is a way to stop but FF management will disavow such requests.