Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Web site wants to allow adds by clicking on "Adblock Plus icon" which isn't on FireFox. How do I allow adds on specific web sites?

  • 3 replies
  • 5 have this problem
  • 30 views
  • Last reply by Joyseppie

more options

Web Site “https://www.accuweather.com/” requests me to allow ads, which I wish to do. It requests that I click on "Adblock Plus icon" in the browser extension area of your browser. That option isn't in the browser on FireFox. Is there another way to allow the ads? James

Chosen solution

hi omole, adblock is an extra addon that users would have to separately download to use in the first place. it isn't present in your configuration as it seems. perhaps the firefox tracking protection is interfering with the advertising networks that are used on that page. you could for a shield symbol on the top left of your firefox address bar where you could disable that protection momentarily for the site: What happened to Tracking Protection?

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

hi omole, adblock is an extra addon that users would have to separately download to use in the first place. it isn't present in your configuration as it seems. perhaps the firefox tracking protection is interfering with the advertising networks that are used on that page. you could for a shield symbol on the top left of your firefox address bar where you could disable that protection momentarily for the site: What happened to Tracking Protection?

more options

I have the same problem. There are some sites I want to use that won't display unless they can place ads which is fine with me. But Firefox won't allow them. It's no good saying to disable the shield on the top left of the address bar as there is now shield. I am having to use Chrome to get the sites I want. This is a bit of overkill on Mozilla's part.

more options

The above post should read "no shield symbol" not "now shield".