X
Tap here to go to the mobile version of the site.

Support Forum

How do I control where a new tab opens?

Posted

I have two Macs running the same MacOS and same version of FF (57.0.3). When I open a link in a new tab on Machine1 the tab opens next to the source tab (one tab over, on the right). When I open a link in a new tab on Machine2 the tab opens at the extreme right end of the tab list.

Why the difference? More importantly, how do I get Machine2 to behave like Machine1?

FYI, I use "open link in a new tab" about 200 times a day, and I hate it when the tab opens at the end of the string of tabs. So I'd really like to fix Machine2!

I have two Macs running the same MacOS and same version of FF (57.0.3). When I open a link in a new tab on Machine1 the tab opens next to the source tab (one tab over, on the right). When I open a link in a new tab on Machine2 the tab opens at the extreme right end of the tab list. Why the difference? More importantly, how do I get Machine2 to behave like Machine1? FYI, I use "open link in a new tab" about 200 times a day, and I hate it when the tab opens at the end of the string of tabs. So I'd really like to fix Machine2!

Chosen solution

Could you check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste relat and pause while the list is filtered

(3) If the browser.tabs.insertRelatedAfterCurrent preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 24.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

jscher2000
  • Top 10 Contributor
7447 solutions 60790 answers

Chosen Solution

Could you check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste relat and pause while the list is filtered

(3) If the browser.tabs.insertRelatedAfterCurrent preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Could you check this setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''relat''' and pause while the list is filtered (3) If the '''browser.tabs.insertRelatedAfterCurrent''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Question owner

That fixed it!

That fixed it!