X
Tap here to go to the mobile version of the site.
Top Contributor Feature will be unavailable for a short amount of time today until further notice.

Support Forum

Even though my computer's time and date settings are correct, all websites are showing that I am 8 hours ahead of where I actually am. Issue is only on Firefox.

Posted

I know it's not an issue with my computer's time/date settings, because the same issue doesn't crop up in Opera or Chrome. And I'm certain it's not an issue with one website, as it happens with ESPN, Todoist and Gmail.

I'm using Firefox on Linux Mint.

I know it's not an issue with my computer's time/date settings, because the same issue doesn't crop up in Opera or Chrome. And I'm certain it's not an issue with one website, as it happens with ESPN, Todoist and Gmail. I'm using Firefox on Linux Mint.

Chosen solution

Sorry, your browser's user agent reported:

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

Are you using privacy.resistFingerprinting to show that?

If so, could you check the time with that preference set to its default value of false to see whether that makes any difference?

Read this answer in context 2
jscher2000
  • Top 10 Contributor
7772 solutions 63321 answers

Could you check the time Firefox thinks it is, without the filter of any particular website. To do that, you can run a snippet of code in the Web Console.

Either:

  • Ctrl+Shift+k
  • menu button > Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console

This is the snippet of script to paste in the bottom area and press Enter/Return to run it. Your first time, Firefox may ask you to confirm your understanding that it's dangerous to run scripts from strangers.

new Date().toString()

That should return something like:

"Fri Jan 05 2018 17:11:58 GMT-0800 (Pacific Standard Time)"

Does yours look sensible for your location?

Could you check the time Firefox thinks it is, without the filter of any particular website. To do that, you can run a snippet of code in the Web Console. Either: * Ctrl+Shift+k * menu button > Developer > Web Console * (menu bar) Tools > Web Developer > Web Console This is the snippet of script to paste in the bottom area and press Enter/Return to run it. Your first time, Firefox may ask you to confirm your understanding that it's dangerous to run scripts from strangers. new Date().toString() That should return something like: "Fri Jan 05 2018 17:11:58 GMT-0800 (Pacific Standard Time)" Does yours look sensible for your location?

Question owner

jscher2000 said

Could you check the time Firefox thinks it is, without the filter of any particular website. To do that, you can run a snippet of code in the Web Console. Either:
  • Ctrl+Shift+k
  • menu button > Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
This is the snippet of script to paste in the bottom area and press Enter/Return to run it. Your first time, Firefox may ask you to confirm your understanding that it's dangerous to run scripts from strangers. new Date().toString() That should return something like: "Fri Jan 05 2018 17:11:58 GMT-0800 (Pacific Standard Time)" Does yours look sensible for your location?

I ran this snippet in the Web Console and it returns GMT+0000 (which is what time the sites are showing as well). I'm in the Pacific Time Zone.

Now what should I try to fix this?

''jscher2000 [[#answer-1060426|said]]'' <blockquote> Could you check the time Firefox thinks it is, without the filter of any particular website. To do that, you can run a snippet of code in the Web Console. Either: * Ctrl+Shift+k * menu button > Developer > Web Console * (menu bar) Tools > Web Developer > Web Console This is the snippet of script to paste in the bottom area and press Enter/Return to run it. Your first time, Firefox may ask you to confirm your understanding that it's dangerous to run scripts from strangers. new Date().toString() That should return something like: "Fri Jan 05 2018 17:11:58 GMT-0800 (Pacific Standard Time)" Does yours look sensible for your location? </blockquote> I ran this snippet in the Web Console and it returns GMT+0000 (which is what time the sites are showing as well). I'm in the Pacific Time Zone. Now what should I try to fix this?
jscher2000
  • Top 10 Contributor
7772 solutions 63321 answers

Hmm, unless you run Firefox in a special way, such as using VirtualBox, or have a time shifting add-on of some kind, Firefox should be able to accurately read the time zone setting from Windows. Can you double-check? I think on Vista you would click the date/time on the Windows Task bar, then click into settings to call up the Date and Time dialog and that should show your time zone and, if necessary, allow you to fix it.

Hmm, unless you run Firefox in a special way, such as using VirtualBox, or have a time shifting add-on of some kind, Firefox should be able to accurately read the time zone setting from Windows. Can you double-check? I think on Vista you would click the date/time on the Windows Task bar, then click into settings to call up the Date and Time dialog and that should show your time zone and, if necessary, allow you to fix it.

Question owner

jscher2000 said

Hmm, unless you run Firefox in a special way, such as using VirtualBox, or have a time shifting add-on of some kind, Firefox should be able to accurately read the time zone setting from Windows. Can you double-check? I think on Vista you would click the date/time on the Windows Task bar, then click into settings to call up the Date and Time dialog and that should show your time zone and, if necessary, allow you to fix it.

I'm not using Windows, I'm using Linux Mint. Other than that, there's nothing special about my installation (no virtual box or time-shifting add-on). My computer is showing the correct local time and other applications seem to be able to read it.

Thanks for your help

''jscher2000 [[#answer-1061800|said]]'' <blockquote> Hmm, unless you run Firefox in a special way, such as using VirtualBox, or have a time shifting add-on of some kind, Firefox should be able to accurately read the time zone setting from Windows. Can you double-check? I think on Vista you would click the date/time on the Windows Task bar, then click into settings to call up the Date and Time dialog and that should show your time zone and, if necessary, allow you to fix it. </blockquote> I'm not using Windows, I'm using Linux Mint. Other than that, there's nothing special about my installation (no virtual box or time-shifting add-on). My computer is showing the correct local time and other applications seem to be able to read it. Thanks for your help
jscher2000
  • Top 10 Contributor
7772 solutions 63321 answers

Chosen Solution

Sorry, your browser's user agent reported:

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

Are you using privacy.resistFingerprinting to show that?

If so, could you check the time with that preference set to its default value of false to see whether that makes any difference?

Sorry, your browser's user agent reported: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 Are you using '''privacy.resistFingerprinting''' to show that? If so, could you check the time with that preference set to its default value of false to see whether that makes any difference?
cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149946 answers

Note that when privacy.resistFingerprinting is enabled you are in the UTC time zone. Screen/window sizes are spoofed as well and site specific zoom is disabled and the user agent is spoofed to the current ESR release among other changes.

Note that when privacy.resistFingerprinting is enabled you are in the UTC time zone. Screen/window sizes are spoofed as well and site specific zoom is disabled and the user agent is spoofed to the current ESR release among other changes.

Question owner

Yep, turning off privacy.resistfingerprinting did the trick (note for those dealing with the same issue in the future: I had to restart Firefox for the change to have an effect).

Makes perfect sense in hindsight. Thanks guys!

Yep, turning off privacy.resistfingerprinting did the trick (note for those dealing with the same issue in the future: I had to restart Firefox for the change to have an effect). Makes perfect sense in hindsight. Thanks guys!