Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox freezing

  • 4 replies
  • 4 have this problem
  • 6 views
  • Last reply by JibiDeh

more options

I've used FF happily without trouble for years, until 2 days ago it suddenly started freezing as soon as I open. I usually can't open any new tabs, menus are unresponsive, and I certainly can't open any web pages. CPU usage seems high (30% on my Lenovo X1 Carbon), and other browsers are working fine.

I've tried a complete uninstall (including deleting the folder in Program Files (x86)), and am now running a fresh installation with no add-ons or plug-ins. It still freezes.

I've followed all the steps on the following articles to no avail: https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

What can I try next?

I've used FF happily without trouble for years, until 2 days ago it suddenly started freezing as soon as I open. I usually can't open any new tabs, menus are unresponsive, and I certainly can't open any web pages. CPU usage seems high (30% on my Lenovo X1 Carbon), and other browsers are working fine. I've tried a complete uninstall (including deleting the folder in Program Files (x86)), and am now running a fresh installation with no add-ons or plug-ins. It still freezes. I've followed all the steps on the following articles to no avail: https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix What can I try next?

All Replies (4)

more options

Please : Go to the Firefox 3 Bar Menu --> Help ? --> Troubleshooting Information Page and take a look in the Accessibility section if accessibility is set to "true" there. if yes, go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to.

Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance.

more options

I already tried these first steps regarding accessibility. I just tried again, but no difference.

Memory usage tops out at about 300 MB, so not too unusual.

more options

That is wonderful. I run at just under 2gigs. I have ram to spare though. But the expected is around 1500 I think with multiple tabs open, each Extension uses give or take 20megs which is included in Task Manager Firefox Icons. Go to some heavy HTML5 audio or video or other and it will climb. https://www.howtogeek.com/334594/stop-complaining-that-your-browser-uses-lots-of-ram-its-a-good-thing/

Please let us know if this solved your issue or if need further assistance.

more options

Well, everything seems to be working normally this morning. The only thing that changed is that Windows 10 installed the following updates overnight: KB4053577 KB4058043 KB4054517 I suppose it must have been some incompatibility that was addressed by those updates. Thanks for your efforts Pkshadow.