Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prevent ctrl+q from closing the browser

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by Tonnes

more options

I have tried every single trick that I found to disable the key combination ctrl+q from closing Firefox. The config option that should make a confirmation dialog be shown on ctrl+q does not work. Apparently, I'm not the only one bothered by this bug. There was a neat add-on, which does not work anymore with the recent Firefox.

I have tried every single trick that I found to disable the key combination ctrl+q from closing Firefox. The config option that should make a confirmation dialog be shown on ctrl+q does not work. Apparently, I'm not the only one bothered by this bug. There was a neat add-on, which does not work anymore with the recent Firefox.

Chosen solution

A first question would be why you want to disable the shortcut, but I assume there will be a reason, such as because you want to use it for some other application. If so, you could consider changing that application’s shortcut, but of course we respect your choice.

Second, if the confirmation dialog "apparently doesn’t work", chances are you have set Firefox to behave in a way your tabs wil be restored anyway at startup which can or will overrule the dialog, given the number of support questions ending with that conclusion. More info about these conditions and how to restore them can be found in this support article.

If that does not help, it may also be good to name the add-on that does no longer work or have a look at one using the Extension finder page in order to find a replacement for it.

Last, if nothing helps, you could consider editing the file(s) containing the strings and shortcuts for Firefox and repacking them, so you would be able to change the q to another key. Please let us know if you need help for that.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

A first question would be why you want to disable the shortcut, but I assume there will be a reason, such as because you want to use it for some other application. If so, you could consider changing that application’s shortcut, but of course we respect your choice.

Second, if the confirmation dialog "apparently doesn’t work", chances are you have set Firefox to behave in a way your tabs wil be restored anyway at startup which can or will overrule the dialog, given the number of support questions ending with that conclusion. More info about these conditions and how to restore them can be found in this support article.

If that does not help, it may also be good to name the add-on that does no longer work or have a look at one using the Extension finder page in order to find a replacement for it.

Last, if nothing helps, you could consider editing the file(s) containing the strings and shortcuts for Firefox and repacking them, so you would be able to change the q to another key. Please let us know if you need help for that.