Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to make Firefox to not use /tmp directory for saving *part files during downloads?

  • 2 replies
  • 5 have this problem
  • 4641 views
  • Last reply by LMA73

more options

Firefox: 52.5.2 (64-bit) OS: 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux

/etc/fstab entry: tmpfs /tmp tmpfs nodev,nosuid,size=100M 0 0

Firefox saves *part files in /tmp directory no matter what settings of file destination are chosen. User might configure FF so it should ask where to save file or choose a specific directory but it doesn't matter to FF during saving of *part file. There are no entries in about:config related to /tmp directory.

FF wrongly assumes that *part files should be saved in /tmp directory. FF wrongly assumes that /tmp is the place with enough disk space so all downloads of files larger than /tmp fail.

How to change or prevent this behaviour?

Chosen solution

All Replies (2)

more options

Chosen Solution

Try to set the TMPDIR environment variable to a folder in your home directory.

Modified by cor-el

more options

Thank you for your answer. It was a pleasure to look at nicely coded FF :)

I did some more testing: with new user account a freshly started FF behaves correctly. So it must be somewhere in configuration of my account :(

Well, it also works in my account properly. Maybe reconfiguring and restarting FF helped.

Thank you for your help.