X
Tap here to go to the mobile version of the site.

Support Forum

No toolbar for Roboform for Mac in latest Firefox on MAC

Posted

I cannot find any help for Mac users to sort out the lack of a Roboform for Mac Toolbar in the latest version of Firefox Quantum on my Mac.(Sierra) I installed it, and the Roboform toolbar disappeared. The new dropdown Roboform button appeared, on the right, but it will no longer auto-fill, and this is unacceptable. So I reverted to Firefox v.54, which is supposed to still allow the toolbar. But it is still not there. I have read ( in this Support question thread - Roboform 8.3.7.7 in Firefox no longer has toolbar - ) that this is because installing Quantum alters the Extensions/Add-ons settings in some way, and reverting to an older version of Firefox does not replace these changes with the original settings.

So please can someone tell me how to get Firefox 54 to recognise the Roboform Toolbar Add-on/Extension.

Thanks ps I am taliking about my iMac, not the machine I am writing this from, so any data details captured by this communication will not be valid.

I cannot find any help for Mac users to sort out the lack of a Roboform for Mac Toolbar in the latest version of Firefox Quantum on my Mac.(Sierra) I installed it, and the Roboform toolbar disappeared. The new dropdown Roboform button appeared, on the right, but it will no longer auto-fill, and this is unacceptable. So I reverted to Firefox v.54, which is supposed to still allow the toolbar. But it is still not there. I have read ( in this Support question thread - Roboform 8.3.7.7 in Firefox no longer has toolbar - ) that this is because installing Quantum alters the Extensions/Add-ons settings in some way, and reverting to an older version of Firefox does not replace these changes with the original settings. So please can someone tell me how to get Firefox 54 to recognise the Roboform Toolbar Add-on/Extension. Thanks ps I am taliking about my iMac, not the machine I am writing this from, so any data details captured by this communication will not be valid.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

Pkshadow
  • Top 10 Contributor
916 solutions 11939 answers

Helpful Reply

Is this what your looking for ? https://addons.mozilla.org/en-US/firefox/addon/roboform/ Check the links at page bottom if not as this shows Extensions still being coded.

All versions of Firefox are being force Updated to 57+

Going back : unfortunately 56.0.2 and below is no longer safe to use for every day use do to secuity issues, but 52.5.0 ESR is. It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018.

You should make a backup of your Profile before going back and just because: https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Please let us know if this solved your issue or if need further assistance.

Is this what your looking for ? https://addons.mozilla.org/en-US/firefox/addon/roboform/ Check the links at page bottom if not as this shows Extensions still being coded. All versions of Firefox are being force Updated to 57+ Going back : unfortunately 56.0.2 and below is no longer safe to use for every day use do to secuity issues, but 52.5.0 ESR is. It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ <b>Note : Legacy Extensions will be deleted or removed in any version update after May 2018</b>. You should make a backup of your Profile before going back and just because: https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Please let us know if this solved your issue or if need further assistance.
jscher2000
  • Top 10 Contributor
7438 solutions 60716 answers

The older Roboform extension that created a new bar in Firefox's toolbar area (unlike its newer extension that can create a lower toolbar) is not available on the "All versions" page of the Add-ons site. I don't know if there is a publicly accessible source for it.

Lower toolbar info from the Summer, see attached screenshot.

The older Roboform extension that created a new bar in Firefox's toolbar area (unlike its newer extension that can create a lower toolbar) is not available on the "All versions" page of the Add-ons site. I don't know if there is a publicly accessible source for it. Lower toolbar info from the Summer, see attached screenshot.

Question owner

Pkshadow said

Going back : unfortunately 56.0.2 and below is no longer safe to use for every day use do to secuity issues, but 52.5.0 ESR is. It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018.

Hi, thank you. I have downloaded the legacy Firefox version 52.5.0 and will take care to follow your warnings about profile back-up. Do I have to uninstall Firefox Quantum before installing 52.5.0 ? And will I also need to delete and then re-install Roboform for Mac as well? Just to remind you, I am on Mac OS X 10.10.5 .

''Pkshadow [[#answer-1044655|said]]'' Going back : unfortunately 56.0.2 and below is no longer safe to use for every day use do to secuity issues, but 52.5.0 ESR is. It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ <b>Note : Legacy Extensions will be deleted or removed in any version update after May 2018</b>. Hi, thank you. I have downloaded the legacy Firefox version 52.5.0 and will take care to follow your warnings about profile back-up. Do I have to uninstall Firefox Quantum before installing 52.5.0 ? And will I also need to delete and then re-install Roboform for Mac as well? Just to remind you, I am on Mac OS X 10.10.5 .

Question owner

jscher2000 said

The older Roboform extension that created a new bar in Firefox's toolbar area (unlike its newer extension that can create a lower toolbar) is not available on the "All versions" page of the Add-ons site. I don't know if there is a publicly accessible source for it. Lower toolbar info from the Summer, see attached screenshot.

Hi jscher2000, This question is specifically about Mac. The new Firefox for Mac does not give a toolbar at the bottom, nor any where. AFAIK, you only get the lower toolbar on a Windows machine.

''jscher2000 [[#answer-1044671|said]]'' <blockquote> The older Roboform extension that created a new bar in Firefox's toolbar area (unlike its newer extension that can create a lower toolbar) is not available on the "All versions" page of the Add-ons site. I don't know if there is a publicly accessible source for it. Lower toolbar info from the Summer, see attached screenshot. </blockquote> Hi jscher2000, This question is specifically about Mac. The new Firefox for Mac does not give a toolbar at the bottom, nor any where. AFAIK, you only get the lower toolbar on a Windows machine.
jscher2000
  • Top 10 Contributor
7438 solutions 60716 answers

If you are limited to the current version of Roboform, you should submit a support ticket to them about its seeming inability to autofill logins.

If you are limited to the current version of Roboform, you should submit a support ticket to them about its seeming inability to autofill logins.