Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I jump to spot clicked in scroll bar? Do I need to reinstall previous version?

  • 4 replies
  • 3 have this problem
  • 69 views
  • Last reply by GimpyDuck

more options

Mac os has a global scroll bar behavior option that Firefox used to respect, which is that a click in the scrollbar would cause the display to jump to the proportionate location in the page. In the new version 57.0 clicking in the scrollbar merely advances the page in tiny increments. I see no option or preference in Firefox to restore my preferred behavior (and I shouldn't have to—Firefox ought to respect my global system setting). The previous version of Firefox respected my system preference. Is there a way to make version 57.0 comply? or do I have to revert to an older version?

Mac os has a global scroll bar behavior option that Firefox used to respect, which is that a click in the scrollbar would cause the display to jump to the proportionate location in the page. In the new version 57.0 clicking in the scrollbar merely advances the page in tiny increments. I see no option or preference in Firefox to restore my preferred behavior (and I shouldn't have to—Firefox ought to respect my global system setting). The previous version of Firefox respected my system preference. Is there a way to make version 57.0 comply? or do I have to revert to an older version?

Chosen solution

Update: The behavior I reported above has ceased and Firefox does now work as you said above and as I wish it to work. So I am marking this problem as "solved" even though I don't understand why it was behaving differently yesterday. I am now assuming there was some problem in the installation of the new version that repaired itself on re-launch of the program. I don't know. In any event, it is now a moot point. Thank you for your help.

Read this answer in context 👍 0

All Replies (4)

more options

Ver 57 still does this and has nothing to do with system settings. It just goes to where you click on the scroll bar.

Suggest removing any rules for that you have created for Firefox as that maybe what is stopping it.

If thinking about going back this is where you go : Going back : unfortunately 56.0.2 and below is no longer safe to use for every day use do to security issues, but 52.5.0 ESR is. It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018.

Please let us know if this solved your issue or if need further assistance.

more options

Thanks for your response.

I have no rules set up for Firefox, I have always simply used the program as is. I don't even know how to set up rules for it. But I am willing to check this if you can tell me how to do it.

Of course, if you open a page that is barely longer than the display, you can make the jump by clicking at top or bottom, but I typically load very long pages, and clicking the scroll bar does not do what you say it does.

Now, since you tell me that v. 57 is supposed to do this, I am more interested in finding out why mine does not and fixing the problem, and less interested in reverting to a former incarnation. So any further help along those lines would be greatly appreciated.

more options

Chosen Solution

Update: The behavior I reported above has ceased and Firefox does now work as you said above and as I wish it to work. So I am marking this problem as "solved" even though I don't understand why it was behaving differently yesterday. I am now assuming there was some problem in the installation of the new version that repaired itself on re-launch of the program. I don't know. In any event, it is now a moot point. Thank you for your help.

more options

Today I was able to confirm my hypothesis that this is an installation bug. I upgraded to the latest version on prompting from Mozilla and the problem behavior returned. I immediately re-launched Firefox and the problem disappeared. Process: 1. download update 2. quite browser 3. launch browser —the problem appears 4. close and re-launch browser —the problem disappears.