Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Quantum - very disappointed

  • 6 replies
  • 6 have this problem
  • 20 views
  • Last reply by WestEnd

more options

I installed your new Firefox Quantum. After two weeks, i decide to uninstall it. Too much slow and freeze. Very bad Unfortunately I have to return to Chrome .

Chosen solution

Performance in Chrome and FF are the same on my computer. Human can't perceive ns difference that are to small to notice-that is a myth that people like to use and has been debunked already. What would be different is if this was a clean or upgrade install that would be where to start.

Read this answer in context 👍 0

All Replies (6)

more options

hi, thanks for reporting this. could you go to the firefox menu ≡ > help ? > troubleshooting information page and take a look in the Accessibility section if accessibility is set to "true" there.

if yes, can you please copy & paste this whole section into a reply in the forum and see if the following fixes the performance problem: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

more options

Hello, Here the information : Accessibility Activated true Prevent Accessibility 0 Accessible Handler Used true Accessibility Instantiator UNKNOWN|

I flag the setting "prevent accessibility services from accessing your browser"

I will test some days and come back for a status. So I'll quit Chrome for some days :-)

Best regards

more options

For information The new values

Accessibility Activated false Prevent Accessibility 1 Accessible Handler Used true Accessibility Instantiator

more options

thanks for reporting back, i'd expect your firefox may get a bit of a speed boost now :))

more options

Hi, Here my returns after a fee weeks of tests with the release of Firefox. The set of "prevent accessibility services from accessing your browser" have solved my initial issue. However Firefox remains in my test conditions lower in performance compared to Chrome. But other elements force in to return to Chrome. An example : During a PayPal transaction I got a "time out" Same time, same site and transaction, no problem with Chrome.

Regards

more options

Chosen Solution

Performance in Chrome and FF are the same on my computer. Human can't perceive ns difference that are to small to notice-that is a myth that people like to use and has been debunked already. What would be different is if this was a clean or upgrade install that would be where to start.