Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dropdown selects not showing all options and positioned oddly in version 57.

  • 14 replies
  • 1 has this problem
  • 1 view
  • Last reply by jtphelan

more options

Select elements in version 57 don't show all the option in a select when there are many and you have to scroll. I can select them by clicking the down arrow but I can see what I'm selecting. Also sometimes the option box appears 200ish pixels above the select element. I've tried clearing all cache and cookies and tested an safe mode and it does it still in both. I've also tried disabling all css styles and it still does it.

Attached screenshots

All Replies (14)

more options

Hi jtphelan, could you give a link to a page exhibiting this problem? I got a Mac recently, so I can compare with Windows 7.

more options

I can't see past South Carolina on this page. https://www.dbqfoundation.org/donors-ways-give/give-now

more options

That's really strange.

I notice you have the Stylish extension. Do you have any user styles that could be affecting forms?

More generally, have you tested in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, it's the Shift key instead of option/alt.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

Yes, it works correctly in safe mode and oddly correctly after I restart out of safe mode. I had tried it a couple weeks ago and it made no difference. I'll see if I can narrow down and find an extension that is causing it.

more options

I'm still having this issue and I'm having it in safe mode as well. As you can see the scrollbar goes down past the bottom and there are options I can't see. I've tried disabling all extensions but it still happens and restarting in safe mode again still has the same issue. I tried reinstalling everything and that worked initially but the issue came back a few hours later.

more options

Here are two videos of it not working on this very website one with extensions disabled and one with Firefox in safe mode. No extensions: https://cl.ly/1l0e14242f46 Safe Mode: https://cl.ly/1A0j3j09153y

more options

Hi jtphelan, thank you for the videos, I watched the second one.

It's very odd how the popups are nowhere near the corresponding field, and also that the Safe Mode/Refresh dialog was somewhere else and you had to drag it into frame.

Do you use multiple or combined displays?

more options

Yes, I'm on an iMac (Retina 5K, 27-inch, Late 2015) running 10.13.2. I have three monitors.

more options

Hmm, I assume the three monitors do not have identical resolution. If you keep all Firefox windows on the monitor where Firefox initially loads, does the positioning work correctly?

In recent versions, changes have been made to how the select control options are drawn. There's some kind of message passing between the "parent" UI process and the "content" process that has been evolving since around Firefox 50 to address the balance between OS native styling and what web developers want (complete control). It's certainly an error where bugs are likely to appear, especially with hardware that might not be common among the bleeding edge testing population (Nightly users).

more options

Yes, so it's absolutely the monitors. I just tested and I typically have firefox on the left monitor (Dell) but if I drag it to the center (iMac) or right (Asus) it works fine. https://cl.ly/3M3R0h3E3W3M

more options

Well, hmm, you could file a bug and see whether they can give you a patch to test out. Otherwise, I'm not sure how they will get around to solving it.

https://bugzilla.mozilla.org/

Does that affect the other issue of not being able to scroll options, or is that still broken on the other displays?

more options

It fixes both issues it seems.

more options

@jtphelan - this may be due to the display port on your mac. I have my additional monitor connected via the display port but two co-workers use HDMI instead (same monitor) and they do not have this issue. I'm still trying to get ahold of an HDMI/lightning cable to confirm with, once I do I'll update.

more options

Interesting. I have one going display port to DVI that has the issue and one going from display port to HDMI and it does not have the issue.