X
Tap here to go to the mobile version of the site.

Support Forum

why is the new Firefox slow?

Posted

I would like the "old Coke" back.

I upgraded Firefox on both of my computers and now it is slow. Just typing this is taking longer than it should. I'm typing along and it falls behind at least 3-4 words before it catches up. Changing pages on a website is very slow. I found the suggestion to 'refresh', did that and no difference. Firefox was my favorite and go to browser. I'd like to add some images but I can't capture how slow it is typing this or trying to navigate thru some of my favorite sites. Trying to check my email on Buckeye Express.com took so long, as it took so much longer to load each email and then waiting to save it or trash it. Navigating your own support pages is frustrating waiting for it to change pages.

I want the 'old Coke' back.

I would like the "old Coke" back. I upgraded Firefox on both of my computers and now it is slow. Just typing this is taking longer than it should. I'm typing along and it falls behind at least 3-4 words before it catches up. Changing pages on a website is very slow. I found the suggestion to 'refresh', did that and no difference. Firefox was my favorite and go to browser. I'd like to add some images but I can't capture how slow it is typing this or trying to navigate thru some of my favorite sites. Trying to check my email on Buckeye Express.com took so long, as it took so much longer to load each email and then waiting to save it or trash it. Navigating your own support pages is frustrating waiting for it to change pages. I want the 'old Coke' back.

Chosen solution

hi, thanks for reporting this. could you go to the firefox menu ≡ > help ? > troubleshooting information page and take a look in the Accessibility section if accessibility is set to "true" there.

if yes, can you please copy & paste this whole section into a reply in the forum and see if the following fixes the performance problem: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

Read this answer in context 85
philipp
  • Top 25 Contributor
  • Moderator
5080 solutions 22519 answers

Chosen Solution

hi, thanks for reporting this. could you go to the firefox menu ≡ > help ? > troubleshooting information page and take a look in the Accessibility section if accessibility is set to "true" there.

if yes, can you please copy & paste this whole section into a reply in the forum and see if the following fixes the performance problem: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

hi, thanks for reporting this. could you go to the firefox ''menu ≡ > help ? > troubleshooting information'' page and take a look in the ''Accessibility'' section if accessibility is set to "true" there. if yes, can you please copy & paste this whole section into a reply in the forum and see if the following fixes the performance problem: go to the firefox ''menu ≡ > options > privacy & security'' panel and under permissions check the setting to '''prevent accessibility services from accessing your browser'''.

Question owner

Thank you Phillip!!!!! Everything works as before. I wasn't looking forward to the slow process of moving everything to Chrome. Again thank you :)

Thank you Phillip!!!!! Everything works as before. I wasn't looking forward to the slow process of moving everything to Chrome. Again thank you :)
cesckysan 1 solutions 7 answers

My hero, Philip! Seems firefox is back to the old self ... I was soooo disappointed ... tired of having to use Edge and Chrome :))))))

Thanks!

My hero, Philip! Seems firefox is back to the old self ... I was soooo disappointed ... tired of having to use Edge and Chrome :)))))) Thanks!
Chelmite 1 solutions 18 answers

Mine says: Accessibility Activated false Prevent Accessibility 1

Firefox 57.0.1 for Ubuntu canonical.

Mine says: '''Accessibility''' Activated false Prevent Accessibility 1 Firefox 57.0.1 for Ubuntu canonical.
wa2mzf 0 solutions 2 answers

Helpful Reply

Firefox with updates have really slowed me down also.

been with them for years but updates killing me, also add ons used no longer available. time to deep six it and move to chrome.

sorry fellows, i have tried.

Firefox with updates have really slowed me down also. been with them for years but updates killing me, also add ons used no longer available. time to deep six it and move to chrome. sorry fellows, i have tried.
Juanaquena 2 solutions 10 answers

I have FF57 and yesterday and earlier today I experienced extreme slowness. I switched to Private Browsing this afternoon and no longer experience the slowness problem. I suspect there may be much more tracking on many web sites. I will be using Private Browsing most of the time now.

I have FF57 and yesterday and earlier today I experienced extreme slowness. I switched to Private Browsing this afternoon and no longer experience the slowness problem. I suspect there may be much more tracking on many web sites. I will be using Private Browsing most of the time now.
xcr678 0 solutions 2 answers

I had this problem and it was driving me nuts. I tried everyone fix to no avail. Then for some reason, I wonder if I had the 64-bit version and I did NOT. That's all it took loading the 64 bit and uninstalling the 32 bit I wanted to blame the new firefox quantum. So before you pull all your hair out make sure you look what you are using.

I had this problem and it was driving me nuts. I tried everyone fix to no avail. Then for some reason, I wonder if I had the 64-bit version and I did NOT. That's all it took loading the 64 bit and uninstalling the 32 bit I wanted to blame the new firefox quantum. So before you pull all your hair out make sure you look what you are using.
Chelmite 1 solutions 18 answers

I'm running 58.0 (64-bit).

The problem seems to be with the prefs.js file's permissions. Somehow it ends up not writable, so then Firefox creates prefs-1.js, prefs-2.js, ... prefs-9999.js! I have no idea how to fix this.

I'm running 58.0 (64-bit). The problem seems to be with the prefs.js file's permissions. Somehow it ends up not writable, so then Firefox creates prefs-1.js, prefs-2.js, ... prefs-9999.js! I have no idea how to fix this.
xcr678 0 solutions 2 answers

I feel for you, I tried about 25 different things but the one that worked for me was going to ( 64-bit). I had downgraded to pre firefox 56 so many times I lost track of what I was running and possibly changed something in my firefox profile or my windows registry I should not have. As of now, I have it fixed the last thing I did was to change to 64 bit. I wish you good luck with fixing you're I do know what a pain it is.

I feel for you, I tried about 25 different things but the one that worked for me was going to ( 64-bit). I had downgraded to pre firefox 56 so many times I lost track of what I was running and possibly changed something in my firefox profile or my windows registry I should not have. As of now, I have it fixed the last thing I did was to change to 64 bit. I wish you good luck with fixing you're I do know what a pain it is.
thubleau 0 solutions 7 answers

The correct fix my friends is this. Options Network Proxy Use system proxy settings. I believe that by using auto Firefox is doing some sort of search which is slowing the pages down in my humble opinion.

The correct fix my friends is this. Options Network Proxy Use system proxy settings. I believe that by using auto Firefox is doing some sort of search which is slowing the pages down in my humble opinion.
lmaille 0 solutions 1 answers

I've tried all of the above solutions and none really work. I find Firefox is really slowing down in the afternoon, it's like being on dial-up. If I switch over to Microsoft Edge I don't have the same problem. In addition, I also find my email account turns off randomly and when I try to sign back in I get an error message that says the account is in maintenance mode. Again, I don't get these errors when using edge. This may be a separate problem with Firefox.

I've tried all of the above solutions and none really work. I find Firefox is really slowing down in the afternoon, it's like being on dial-up. If I switch over to Microsoft Edge I don't have the same problem. In addition, I also find my email account turns off randomly and when I try to sign back in I get an error message that says the account is in maintenance mode. Again, I don't get these errors when using edge. This may be a separate problem with Firefox.
ffw62 6 solutions 85 answers

Helpful Reply

Actually... I have to admit ... I shouldn't be posting here as I am a 'chased away to Chrome'-user. I have been a happy FF user ever since somewhere in 2004, but in the end I was almost spending more time on trying to solve FF problems than using it. Error this, website contents not displayed that.

I have to say: the new FF really looks nice, it is fairly fast, can't deny all that. Thumbs up! Definitely so.

However, I have still not returned to FF because the Android version is soooo terribly slow. As I prefer to use 1 browser for both Windows and on my Android tablet, I am still 'forced' to use Chrome. Chrome outperforms FF many times, 'out of the box'. No special tricks required. I have a decent tablet and a (very) fast Internet/WiFi.

I wish and really hope that one day Firefox on Android will get some major 'update', so it will perform equally (or better) to Chrome, or match the Samsung Internet browser, which is in fact even very decent and faster than Chrome (but is missing a built in password manager, if it had one, then I would have been using that browser, i.e. the Samsung browser).

Well, just my 2 cents.

Actually... I have to admit ... I shouldn't be posting here as I am a 'chased away to Chrome'-user. I have been a happy FF user ever since somewhere in 2004, but in the end I was almost spending more time on trying to solve FF problems than using it. Error this, website contents not displayed that. I have to say: the new FF really looks nice, it is fairly fast, can't deny all that. Thumbs up! Definitely so. However, I have still not returned to FF because the Android version is soooo terribly slow. As I prefer to use 1 browser for both Windows and on my Android tablet, I am still 'forced' to use Chrome. Chrome outperforms FF many times, 'out of the box'. No special tricks required. I have a decent tablet and a (very) fast Internet/WiFi. I wish and really hope that one day Firefox on Android will get some major 'update', so it will perform equally (or better) to Chrome, or match the Samsung Internet browser, which is in fact even very decent and faster than Chrome (but is missing a built in password manager, if it had one, then I would have been using that browser, i.e. the Samsung browser). Well, just my 2 cents.