X
Tap here to go to the mobile version of the site.

Support Forum

new ui is slow and hangs

Posted

After the update yesterday to Firefox Quantum, I can no longer use Firefox on my desktop. It is slow, it hangs and then freezes. I've tried everything in the troubleshooting section (profiles, drivers, refresh, fresh install, everything.) I am posting this message from...gasp...Microsoft Edge. I really hope there is someone who can help me, I really don't want to have to leave Firefox!

After the update yesterday to Firefox Quantum, I can no longer use Firefox on my desktop. It is slow, it hangs and then freezes. I've tried everything in the troubleshooting section (profiles, drivers, refresh, fresh install, everything.) I am posting this message from...gasp...Microsoft Edge. I really hope there is someone who can help me, I really don't want to have to leave Firefox!

Chosen solution

great, please try the following which should hopefully take care of this lag: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

Read this answer in context 81
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

More Information

Pkshadow
  • Top 10 Contributor
547 solutions 6053 answers

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved.

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration TRY NO HARDWARE ACCELERATION Most issues are caused by out dated and corrupted drivers. If do not know what your card is : GPU-Z will tell you this https://www.techpowerup.com/gpuz/

FIREFOX TO SLOW

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

Please let us know if this solved your issue or if need further assistance.

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/ https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration TRY NO HARDWARE ACCELERATION Most issues are caused by out dated and corrupted drivers. If do not know what your card is : GPU-Z will tell you this https://www.techpowerup.com/gpuz/ FIREFOX TO SLOW Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there? https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding Please let us know if this solved your issue or if need further assistance.

Modified by Pkshadow

Was this helpful to you? 1
Quote

Question owner

I did all of the above. Still hangs and freezes.

I did all of the above. Still hangs and freezes.
Was this helpful to you? 13
Quote
philipp
  • Top 25 Contributor
  • Moderator
4916 solutions 21827 answers

thanks for reporting this. could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum (or if it's to long through a site like https://pastebin.mozilla.org/ and provide the link here)?

this might give us a clue what is going on. thank you!

thanks for reporting this. could you go to the firefox ''menu ≡ > help ? > troubleshooting information'', copy the contents of that page and paste them here into a reply on the forum (or if it's to long through a site like [https://pastebin.mozilla.org/] and provide the link here)? this might give us a clue what is going on. thank you!
Was this helpful to you? 1
Quote

Question owner

https://pastebin.mozilla.org/9073018
Was this helpful to you? 1
Quote
philipp
  • Top 25 Contributor
  • Moderator
4916 solutions 21827 answers

Chosen Solution

great, please try the following which should hopefully take care of this lag: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

great, please try the following which should hopefully take care of this lag: go to the firefox ''menu ≡ > options > privacy & security'' panel and under permissions check the setting to '''prevent accessibility services from accessing your browser'''.
Was this helpful to you? 81
Quote

Helpful Reply

That did it I think! Oh my gosh, I'm so appreciative. I'll see if it is still working tomorrow and thene "solved the problem" click. Already it is amazing I can type this to you in Firefox!

That did it I think! Oh my gosh, I'm so appreciative. I'll see if it is still working tomorrow and thene "solved the problem" click. Already it is amazing I can type this to you in Firefox!
Was this helpful to you? 21
Quote
gfieldsr 0 solutions 8 answers

TwinsMomVA said

After the update yesterday to Firefox Quantum, I can no longer use Firefox on my desktop. It is slow, it hangs and then freezes. I've tried everything in the troubleshooting section (profiles, drivers, refresh, fresh install, everything.) I am posting this message from...gasp...Microsoft Edge. I really hope there is someone who can help me, I really don't want to have to leave Firefox!

TwinsMomVA said

After the update yesterday to Firefox Quantum, I can no longer use Firefox on my desktop. It is slow, it hangs and then freezes. I've tried everything in the troubleshooting section (profiles, drivers, refresh, fresh install, everything.) I am posting this message from...gasp...Microsoft Edge. I really hope there is someone who can help me, I really don't want to have to leave Firefox!

great, please try the following which should hopefully take care of this lag: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

This worked for me! Thank you!

''TwinsMomVA [[#question-1187110|said]]'' <blockquote> After the update yesterday to Firefox Quantum, I can no longer use Firefox on my desktop. It is slow, it hangs and then freezes. I've tried everything in the troubleshooting section (profiles, drivers, refresh, fresh install, everything.) I am posting this message from...gasp...Microsoft Edge. I really hope there is someone who can help me, I really don't want to have to leave Firefox! </blockquote> ''TwinsMomVA [[#question-1187110|said]]'' <blockquote> After the update yesterday to Firefox Quantum, I can no longer use Firefox on my desktop. It is slow, it hangs and then freezes. I've tried everything in the troubleshooting section (profiles, drivers, refresh, fresh install, everything.) I am posting this message from...gasp...Microsoft Edge. I really hope there is someone who can help me, I really don't want to have to leave Firefox! </blockquote> great, please try the following which should hopefully take care of this lag: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser. This worked for me! Thank you!
Was this helpful to you? 28
Quote
titaob 0 solutions 1 answers

can't find where this box to check is on windows 8.

can't find where this box to check is on windows 8.
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.