Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I Remove Unified Complete and Useless Search engine choice in Quantum?

more options

As Firefox Quantum removed support for XUL-related user styles, and also browser.urlbar.unifiedcomplete is no longer available, is there a way to remove "Unified Complete" line of URL bar suggestions?

Also, when I allow only a single search engine, the choice at the bottom of suggestions is useless and unnecessary - can it be removed?

Firefox 57.0 64bit, Windows 7 (not that it plays a role in this case)

Attached screenshots

Chosen solution

For the search buttons at the bottom, there is this preference (at least for the time being):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.oneOffSearches preference to switch the value from true to false

The "blue bar" is a little more difficult. You can hide it using a custom style rule, but it will still be the selection while you're typing in the address bar and you'll need to arrow down to or click the item you want.

To hide that bar, you can use a custom style rule in a userChrome.css file. More info:

Read this answer in context 👍 1

All Replies (6)

more options

Under the options you are given a choice as to what shows up in that, you can uncheck whatever you don't want, for example, I only have bookmarks checked and nothing like history or other stuff show up. Give that a try and see if it works for you.

more options

I don't mind the actual results and i have that set up to my liking. It is the first line with the magnifying glass that is annoying and the bottom grey area with a single icon.

more options

That is meant for those who want to search for the term they are typing, I find it redundant too but you can disable search from URL bar and that should remove that line. Do you have suggest search checked?

more options

Chosen Solution

For the search buttons at the bottom, there is this preference (at least for the time being):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.oneOffSearches preference to switch the value from true to false

The "blue bar" is a little more difficult. You can hide it using a custom style rule, but it will still be the selection while you're typing in the address bar and you'll need to arrow down to or click the item you want.

To hide that bar, you can use a custom style rule in a userChrome.css file. More info:

more options

Thank you a thousand times! That actually worked and I don't even have to arrow down two times.

more options

neldorling said

Thank you a thousand times! That actually worked and I don't even have to arrow down two times.
Glad you got it worked out the way you like, but from what you had said, I was thinking you were referring to
It is the first line with the magnifying glass that is annoying
but I am glad you got it worked out.