X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 56.02 keeps iMac with Mavericks OS 10.9.5 from sleeping. Why?

Posted

When Firefox 56.02 is open, my iMac running Mavericks OS 10.9.5 will not automatically go into a sleep mode. When Firefox 56.02 is closed, the computer automatically sleeps when it is supposed to. Why is this happening? How do I fix the problem?

When Firefox 56.02 is open, my iMac running Mavericks OS 10.9.5 will not automatically go into a sleep mode. When Firefox 56.02 is closed, the computer automatically sleeps when it is supposed to. Why is this happening? How do I fix the problem?

Additional System Details

Installed Plug-ins

  • Version 5.41.3.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:48.0) Gecko/20100101 Firefox/48.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157402 answers

You can try to modify multi-process settings to see if this has effect.

  • set dom.ipc.processCount to 1 if it is currently set to a higher value (4)
  • disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can try to modify multi-process settings to see if this has effect. *set dom.ipc.processCount to 1 if it is currently set to a higher value (4) *disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting these prefs to false on the <b>about:config</b> page. *browser.tabs.remote.autostart = false *browser.tabs.remote.autostart.2 = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config *http://www.ghacks.net/2016/07/22/multi-process-firefox/