Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I search certain Korean words on Google using FireFox, those Korean words show up broken on the search result. How to fix?

more options

When I search certain Korean words on Google on FireFox, those Korean words show up broken on the search result. How to fix?

Other Korean words show up fine. I have attached a screenshot that show what's going on.

Please help!!!

Chosen solution

We have seen cases where a box with all '?' or all 'A' is displayed that might be related to using a Last Resort font that displays all the glyphs with one same character.

You can try to set this pref to 1 on the about:config page.

  • security.sandbox.content.level = 1

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 👍 1

All Replies (14)

more options

Here's the screenshot!

more options

It is not showing up as that is done by HTML from the Google Indexed web pages. If just looking for words use https://translate.google.ca/ or .com If looking for a website the translated word you get from the above would be better to search with.


Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow said

It is not showing up as that is done by HTML from the Google Indexed web pages. If just looking for words use https://translate.google.ca/ or .com If looking for a website the translated word you get from the above would be better to search with. Please let us know if this solved your issue or if need further assistance.

Hi Pkshadow!

Thanks for the response!

But, it's not about translating the words or translation.

I guess I phrased my question very poorly.

Here is my best effort to explain the problem (^^') :

What I want is to look at how Korean phrases are used on (Korean) web pages.

So, I search Korean phrases on Google.

When I do that (on Google) on Safari or Chrome, everything on the search result displays fine.

But if I search Korean phrases (on Google) on FireFox, that specific Korean phrases that I just typed in in the search field show up broken.

Please view the screenshot I have attached.

Those broken words on the search result? They are the words I typed in in the search field at the top.

Thanks for your patience.

more options

That is possibly a font issue where the used (bold?) font doesn't include these glyphs and thus a '?' is shown.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

more options

I've locked the other thread. Please only use one thread for a question.

  • [/questions/1178730] When I search Korean words (on Google) on FireFox, those Korean words show up broken on the search result. How to fix?

Modified by cor-el

more options

cor-el said

That is possibly a font issue where the used (bold?) font doesn't include these glyphs and thus a '?' is shown. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Thanks for the reply!!

I did the select the (broken) words and right-clicked -> selected Inspect Element to check the font used for selected text in the Font tab.

The screenshot I have attached is the result.

My guess is that "Hiragino Kaku Gothic" is used (by Google) to display Korean languages (on Google search result) on FireFox.

"Hiragino Kaku Gothic" is a Japanese font. My guess is that "Hiragino Kaku Gothic" do not have a bold for Korean language.

So, can I change "Hiragino Kaku Gothic" to a Korean font - meaning can I set up Google on FireFox to use a Korean font (instead of "Hiragino Kaku Gothic") for Google search result page?

It's strange because if I search Korean words (on Google) on Safari or Chrome, this whole "searched (Korean) words show up broken thing" does not happen. ^^'

Thanks a ton in advance.

more options

cor-el said

I've locked the other thread. Please only use one thread for a question.
  • [/questions/1178730 When I search Korean words (on Google) on FireFox, those Korean words show up broken on the search result. How to fix?

Thanks!!

I thought my first question was poorly worded. That's why I posted the second questions with a better attempt of wording. ^^'

more options

cor-el said

That is possibly a font issue where the used (bold?) font doesn't include these glyphs and thus a '?' is shown. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.


Another thing I would like to mention is that:

Everything was fine before - when I search Korean words, the search results show up without any broken (Korean) words.

Then, 2 Days ago, I clicked a link on a suspected mail. (I know my bad -_-') Then a 404 page opened up on FireFox, and at that moment I realized me clicking the link was a mistake.

I immediately closed FireFox . And changed my Google passwords (using Chrome) and FireFox passwords after redownloading + reinstalling + refreshing FireFox.

Then, this whole "searched (Korean) words show up broken thing" started happening.

-_-'

Modified by jsd_vancouver

more options

Chosen Solution

We have seen cases where a box with all '?' or all 'A' is displayed that might be related to using a Last Resort font that displays all the glyphs with one same character.

You can try to set this pref to 1 on the about:config page.

  • security.sandbox.content.level = 1

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

cor-el said

We have seen cases where a box with all '?' or all 'A' is displayed that might be related to using a Last Resort font that displays all the glyphs with one same character. You can try to set this pref to 1 on the about:config page.
  • security.sandbox.content.level = 1
You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Thanks a ton for following up with this issue!

I did what you are explaining (please see the attached screenshot), but the problem is still occurring. -_-'

Thing is: I can use other browsers when I need to search Korean phrases. But my real worry is that since I clicked the link from the suspected email, somehow the security on FireFox I am using has been compromised (or the FireFox has been infected with some malware.) -_-'

more options

jsd_vancouver said

You can try to set this pref to 1 on the about:config page.
  • security.sandbox.content.level = 1
I did what you are explaining (please see the attached screenshot), but the problem is still occurring. -_-'

After you changed the value of that preference : did you close and then restart Firefox  ?

more options

Enigma said

jsd_vancouver said
You can try to set this pref to 1 on the about:config page.
  • security.sandbox.content.level = 1
I did what you are explaining (please see the attached screenshot), but the problem is still occurring. -_-'

After you changed the value of that preference : did you close and then restart Firefox  ?

OMG how stupid of me!! It works!!

Thank you so much!! ^^

more options

jsd_vancouver said

OMG how stupid of me!! It works!! Thank you so much!! ^^

Not stupid at all - you just didn't know.

more options

Enigma said

jsd_vancouver said
OMG how stupid of me!! It works!! Thank you so much!! ^^

Not stupid at all - you just didn't know.

Thanks for the kind words!! ^^