X
Tap here to go to the mobile version of the site.

Support Forum

advertisement blockers are not working

Posted

I have a ptoblem with my firefox 55.0.2. Advertisement blockers are not working. I tried Adblock plus and Ublock. They install, but do not work. I cannot see the settings option. They both have it and I know where it should be, but it's unseen. I had no problems with them when I had previous firefox version. Other add-ons which i have seem to work properly. Please, help me.

I have a ptoblem with my firefox 55.0.2. Advertisement blockers are not working. I tried Adblock plus and Ublock. They install, but do not work. I cannot see the settings option. They both have it and I know where it should be, but it's unseen. I had no problems with them when I had previous firefox version. Other add-ons which i have seem to work properly. Please, help me.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 4.2.2; Tablet; rv:55.0) Gecko/55.0 Firefox/55.0

More Information

Josh Ross 12 solutions 143 answers

Helpful Reply

Legacy plugins and new Firefox API is causing the issues. You can try finding workarounds for Firefox on legacy plugins, but they still might have some issues. Matter of the fact is until the add-on is not written in their new framework, such issues will keep happening.

Legacy plugins and new Firefox API is causing the issues. You can try finding workarounds for Firefox on legacy plugins, but they still might have some issues. Matter of the fact is until the add-on is not written in their new framework, such issues will keep happening.

Question owner

Thanks for the answer. It is a pity that the problem has not been solved yet. Could you please explain what to do with legacy plugins or give a link. I could not find a solution myself.

Thanks for the answer. It is a pity that the problem has not been solved yet. Could you please explain what to do with legacy plugins or give a link. I could not find a solution myself.
Josh Ross 12 solutions 143 answers

Update: As far as I am aware, uBlock has been rewritten to the proper API. I would recommend to completely remove the extension, make sure you update your FF browser to the latest version and re-download the extension. Should solve the issue.

Update: As far as I am aware, uBlock has been rewritten to the proper API. I would recommend to completely remove the extension, make sure you update your FF browser to the latest version and re-download the extension. Should solve the issue.