X
Tap here to go to the mobile version of the site.

Support Forum

Your connection is not secure - SEC_ERROR_UNKNOWN_ISSUER

Posted

Yeah, one of these topics again.

Seeing how often this gets posted making a new thread was a last resort, but I'm at my wits end here. Two days ago Firefox (actually Waterfox, but after testing Fire I seem to have the problem on both browsers) started returning a "Your connection is not secure" error on what seems to be every single https URL and I can't even add exceptions. This happened once before two weeks ago, but it fixed itself after a few hours. No idea what caused it or what fixed it. It does not affect other browsers, but strangely it does affect the Blizzard Battle.net app and does not allow it to connect to the internet (so I can't play anything).

I've spent the last two days digging through support threads trying every solution I could find. I'm not using Kaspersky (turned off all protection features in AVG and Windows just to be sure, didn't work and have since turned them back on), I've tried importing certificates from other browsers, I've reset my network settings, I've tried disabling all of my addons, I've tried changing Firefox proxy settings, I've tried a new Firefox profile, I've run system scans and registry fixes, I've tried safe mode, I've deleted Firefox's cert file, I've reset my system countless times, I've reset my router, I've even confirmed my date/time settings were correct. Nothing has worked so far. Is there anything I haven't tried?


https://www.google.com/

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIC4zCCAcugAwIBAgIRAKm8ETiNySk9HA4+VJnjuUMwDQYJKoZIhvcNAQELBQAw KjELMAkGA1UEBhMCRU4xGzAZBgNVBAMMEjE5MGM4MmMxOWFiNDZhNDAgMjAeFw0x NzA4MTUxNjA0MDBaFw0xNzExMDcxNjA0MDBaMGgxCzAJBgNVBAYTAlVTMRMwEQYD VQQIDApDYWxpZm9ybmlhMRYwFAYDVQQHDA1Nb3VudGFpbiBWaWV3MRMwEQYDVQQK DApHb29nbGUgSW5jMRcwFQYDVQQDDA53d3cuZ29vZ2xlLmNvbTCBnzANBgkqhkiG 9w0BAQEFAAOBjQAwgYkCgYEAwWhyT4acv2vC2P8a57MRH0LyAD1zltYPzHFQtvK6 xwxwO61aLb8itMXQQSx8aW4nH3F1ab0UquNrgyDD4IZtR9U2Vm4CoCVUuhzZRvqI Rzb3UrCVasYgCirBnK4NevDKe2rfT4XUL6eFmy8L6Oklx9qjL/5n4qTnCWtW10Wj Og0CAwEAAaNKMEgwGQYDVR0RBBIwEIIOd3d3Lmdvb2dsZS5jb20wDAYDVR0TAQH/ BAIwADAdBgNVHSUEFjAUBggrBgEFBQcDAQYIKwYBBQUHAwIwDQYJKoZIhvcNAQEL BQADggEBAKGs/qQ5Pbb0+BL7nPF+EMFGH/6qVteQ8DcMaXJ1c7RKqdNxnel7F3oP T+bz9ma0Pf7yCrhjhVRZWJytazsbSHDVizltwdMA7+HzmNv5z113khJW7RdPKFAj 2t9RWV5PhXBGTTn5PvroVp888lPMtRtvMJS5udle3cjcFWlKsBSAoEKTH4eCra1o hbS6kmVYbWBFXaXa7RaGzLale6N/4qI/CUoJoRJAXKnoMMGhA2JwkRBrt+pI+wVq n2GYfbOA72k2N4LG/fdndZTwugSfUYbKnLnx9BDbe4twG3njNrl26acNZ4ikVEuj YGdt9h6q+ZLUfhwXk6e7YsAEtkXr4So=


END CERTIFICATE-----


https://www.mozilla.org/

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: false HTTP Public Key Pinning: false

Certificate chain:


BEGIN CERTIFICATE-----

MIIDjTCCAnWgAwIBAgIRAMqhxAyYotgVaDQJGzzOpBUwDQYJKoZIhvcNAQELBQAw KjELMAkGA1UEBhMCRU4xGzAZBgNVBAMMEjE5MGM4MmMxOWFiNDZhNDAgMjAeFw0x NjExMDkwMDAwMDBaFw0xODExMTQxMjAwMDBaMIIBAjEdMBsGA1UEDwwUUHJpdmF0 ZSBPcmdhbml6YXRpb24xEzARBgsrBgEEAYI3PAIBAxMCVVMxGzAZBgsrBgEEAYI3 PAIBAhMKQ2FsaWZvcm5pYTERMA8GA1UEBRMIQzI3NTkyMDgxHjAcBgNVBAkTFTY1 MCBDYXN0cm8gU3QgU3RlIDMwMDEOMAwGA1UEERMFOTQwNDExCzAJBgNVBAYTAlVT MRMwEQYDVQQIEwpDYWxpZm9ybmlhMRYwFAYDVQQHEw1Nb3VudGFpbiBWaWV3MRww GgYDVQQKExNNb3ppbGxhIENvcnBvcmF0aW9uMRQwEgYDVQQDEwttb3ppbGxhLm9y ZzCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEA1+ZJvmO2xcMjNDoz/BT5jOuc 53HsRHhw1kNlE3MzHWvCQTKjaBW0uvm5P8ge6NnU1YdEvNXLZRLnVTClz5ZxdNMA /G9CTw2Y665My/BLVqrUWVhWg0oC4txGIGWFM36OdSnFOsTZ2GWkdoG3RKT/qRO8 EukAHjRWF/j5ZZgn8YUCAwEAAaNYMFYwJwYDVR0RBCAwHoILbW96aWxsYS5vcmeC D3d3dy5tb3ppbGxhLm9yZzAMBgNVHRMBAf8EAjAAMB0GA1UdJQQWMBQGCCsGAQUF BwMBBggrBgEFBQcDAjANBgkqhkiG9w0BAQsFAAOCAQEAyu7s3kwFqIHFWTTN9sVv c1RHaKCCi000M9n8fxuAg8s3QumPEpuW28vT0Qa1/yIG2zKhGlM5pQeqSuFoaT0d vUXm6ypXXvLpLe7vDEfmrgyzo+nH4sNk+rdp2sujOCwLwgPYUI+BtQA3ldeH7FR9 XzTnVJaveWzZ5N9OqFYkfvL0Kbl34HH6F6esMD22zXrfEtP/aKYnLDhIkcN3d1Wz vbl6RPlC2ObM/dOiiVXYdmjUIGTJbQt2486klYHXse4mpDFlj8UVafFOJwfMEBNm QPWzJZwR2UrGTKRKgM1G+m3gV4dN9GSBAwTXfatey/xI+LzyZo7luPuyLe2J07LO bw==


END CERTIFICATE-----


https://tweetdeck.twitter.com/

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: true HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIDpTCCAo2gAwIBAgIRAJ3Y95mfyPRGAhjp4VURxgkwDQYJKoZIhvcNAQELBQAw KjELMAkGA1UEBhMCRU4xGzAZBgNVBAMMEjE5MGM4MmMxOWFiNDZhNDAgMjAeFw0x NTA1MjAwMDAwMDBaFw0xODA1MjQxMjAwMDBaMIGFMQswCQYDVQQGEwJVUzELMAkG A1UECBMCQ0ExFjAUBgNVBAcTDVNhbiBGcmFuY2lzY28xFjAUBgNVBAoTDVR3aXR0 ZXIsIEluYy4xGTAXBgNVBAsTEFR3aXR0ZXIgU2VjdXJpdHkxHjAcBgNVBAMTFXR3 ZWV0ZGVjay50d2l0dGVyLmNvbTCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEA yviGfBEk5QwMrKWRjeT4/bkUg+nwRXj2WhyIMEujDnVLTLG8raY9gyygyvFcpo9z i6t6+BncW+2bIhQde5PMnSLkFyk3qdOLlX5ZZVxsZCB10XndYGbCkOAyLw2/13I+ jOEB6YFxhnrUGx2RhvgrmMCzuTk7FvbRzAiJrmf12GMCAwEAAaOB7TCB6jCBugYD VR0RBIGyMIGvghV0d2VldGRlY2sudHdpdHRlci5jb22CDXR3ZWV0ZGVjay5jb22C EXd3dy50d2VldGRlY2suY29tghF3ZWIudHdlZXRkZWNrLmNvbYIRYXBpLnR3ZWV0 ZGVjay5jb22CF2Rvd25sb2Fkcy50d2VldGRlY2suY29tghF0ZGFwaS50d2l0dGVy LmNvbYIOdGQudHdpdHRlci5jb22CEmJsb2cudHdlZXRkZWNrLmNvbTAMBgNVHRMB Af8EAjAAMB0GA1UdJQQWMBQGCCsGAQUFBwMBBggrBgEFBQcDAjANBgkqhkiG9w0B AQsFAAOCAQEAJBZPSGGy1MVwJAQmYkX/nCkkbhHMxNI0c9Hf20PnPaHErEPQwbVJ obdeGaT06BfXKBqyIwn0wgGWPlyQkc6JI4Tilb/Sw1k74W3gl8ips6yCbaoouVFC T9XwL1cB25TedHzqCMBzr7JpLaT3HxFmE8SNJpel8/HuZwDygl3bmcxvkcTophiE qgDBcTAlvukgQOWlF5ihBs3sdw6j9gjDc/MaediuNr2MZQk5ZmwTMS50S8F4giGd aJr9sUF5z6hOh1BaqKFGvBgsGr8u8iX7xNkCqGZR/PQikAgbnYre8gtg+ek8JcPW WGRXkpIv/9Vd6POiSW/l9fX9v/HNP63b/A==


END CERTIFICATE-----
Yeah, one of these topics again. Seeing how often this gets posted making a new thread was a last resort, but I'm at my wits end here. Two days ago Firefox (actually Waterfox, but after testing Fire I seem to have the problem on both browsers) started returning a "Your connection is not secure" error on what seems to be every single https URL and I can't even add exceptions. This happened once before two weeks ago, but it fixed itself after a few hours. No idea what caused it or what fixed it. It does not affect other browsers, but strangely it does affect the Blizzard Battle.net app and does not allow it to connect to the internet (so I can't play anything). I've spent the last two days digging through support threads trying every solution I could find. I'm not using Kaspersky (turned off all protection features in AVG and Windows just to be sure, didn't work and have since turned them back on), I've tried importing certificates from other browsers, I've reset my network settings, I've tried disabling all of my addons, I've tried changing Firefox proxy settings, I've tried a new Firefox profile, I've run system scans and registry fixes, I've tried safe mode, I've deleted Firefox's cert file, I've reset my system countless times, I've reset my router, I've even confirmed my date/time settings were correct. Nothing has worked so far. Is there anything I haven't tried? https://www.google.com/ Peer’s Certificate issuer is not recognized. HTTP Strict Transport Security: false HTTP Public Key Pinning: true Certificate chain: -----BEGIN CERTIFICATE----- MIIC4zCCAcugAwIBAgIRAKm8ETiNySk9HA4+VJnjuUMwDQYJKoZIhvcNAQELBQAw KjELMAkGA1UEBhMCRU4xGzAZBgNVBAMMEjE5MGM4MmMxOWFiNDZhNDAgMjAeFw0x NzA4MTUxNjA0MDBaFw0xNzExMDcxNjA0MDBaMGgxCzAJBgNVBAYTAlVTMRMwEQYD VQQIDApDYWxpZm9ybmlhMRYwFAYDVQQHDA1Nb3VudGFpbiBWaWV3MRMwEQYDVQQK DApHb29nbGUgSW5jMRcwFQYDVQQDDA53d3cuZ29vZ2xlLmNvbTCBnzANBgkqhkiG 9w0BAQEFAAOBjQAwgYkCgYEAwWhyT4acv2vC2P8a57MRH0LyAD1zltYPzHFQtvK6 xwxwO61aLb8itMXQQSx8aW4nH3F1ab0UquNrgyDD4IZtR9U2Vm4CoCVUuhzZRvqI Rzb3UrCVasYgCirBnK4NevDKe2rfT4XUL6eFmy8L6Oklx9qjL/5n4qTnCWtW10Wj Og0CAwEAAaNKMEgwGQYDVR0RBBIwEIIOd3d3Lmdvb2dsZS5jb20wDAYDVR0TAQH/ BAIwADAdBgNVHSUEFjAUBggrBgEFBQcDAQYIKwYBBQUHAwIwDQYJKoZIhvcNAQEL BQADggEBAKGs/qQ5Pbb0+BL7nPF+EMFGH/6qVteQ8DcMaXJ1c7RKqdNxnel7F3oP T+bz9ma0Pf7yCrhjhVRZWJytazsbSHDVizltwdMA7+HzmNv5z113khJW7RdPKFAj 2t9RWV5PhXBGTTn5PvroVp888lPMtRtvMJS5udle3cjcFWlKsBSAoEKTH4eCra1o hbS6kmVYbWBFXaXa7RaGzLale6N/4qI/CUoJoRJAXKnoMMGhA2JwkRBrt+pI+wVq n2GYfbOA72k2N4LG/fdndZTwugSfUYbKnLnx9BDbe4twG3njNrl26acNZ4ikVEuj YGdt9h6q+ZLUfhwXk6e7YsAEtkXr4So= -----END CERTIFICATE----- https://www.mozilla.org/ Peer’s Certificate issuer is not recognized. HTTP Strict Transport Security: false HTTP Public Key Pinning: false Certificate chain: -----BEGIN CERTIFICATE----- MIIDjTCCAnWgAwIBAgIRAMqhxAyYotgVaDQJGzzOpBUwDQYJKoZIhvcNAQELBQAw KjELMAkGA1UEBhMCRU4xGzAZBgNVBAMMEjE5MGM4MmMxOWFiNDZhNDAgMjAeFw0x NjExMDkwMDAwMDBaFw0xODExMTQxMjAwMDBaMIIBAjEdMBsGA1UEDwwUUHJpdmF0 ZSBPcmdhbml6YXRpb24xEzARBgsrBgEEAYI3PAIBAxMCVVMxGzAZBgsrBgEEAYI3 PAIBAhMKQ2FsaWZvcm5pYTERMA8GA1UEBRMIQzI3NTkyMDgxHjAcBgNVBAkTFTY1 MCBDYXN0cm8gU3QgU3RlIDMwMDEOMAwGA1UEERMFOTQwNDExCzAJBgNVBAYTAlVT MRMwEQYDVQQIEwpDYWxpZm9ybmlhMRYwFAYDVQQHEw1Nb3VudGFpbiBWaWV3MRww GgYDVQQKExNNb3ppbGxhIENvcnBvcmF0aW9uMRQwEgYDVQQDEwttb3ppbGxhLm9y ZzCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEA1+ZJvmO2xcMjNDoz/BT5jOuc 53HsRHhw1kNlE3MzHWvCQTKjaBW0uvm5P8ge6NnU1YdEvNXLZRLnVTClz5ZxdNMA /G9CTw2Y665My/BLVqrUWVhWg0oC4txGIGWFM36OdSnFOsTZ2GWkdoG3RKT/qRO8 EukAHjRWF/j5ZZgn8YUCAwEAAaNYMFYwJwYDVR0RBCAwHoILbW96aWxsYS5vcmeC D3d3dy5tb3ppbGxhLm9yZzAMBgNVHRMBAf8EAjAAMB0GA1UdJQQWMBQGCCsGAQUF BwMBBggrBgEFBQcDAjANBgkqhkiG9w0BAQsFAAOCAQEAyu7s3kwFqIHFWTTN9sVv c1RHaKCCi000M9n8fxuAg8s3QumPEpuW28vT0Qa1/yIG2zKhGlM5pQeqSuFoaT0d vUXm6ypXXvLpLe7vDEfmrgyzo+nH4sNk+rdp2sujOCwLwgPYUI+BtQA3ldeH7FR9 XzTnVJaveWzZ5N9OqFYkfvL0Kbl34HH6F6esMD22zXrfEtP/aKYnLDhIkcN3d1Wz vbl6RPlC2ObM/dOiiVXYdmjUIGTJbQt2486klYHXse4mpDFlj8UVafFOJwfMEBNm QPWzJZwR2UrGTKRKgM1G+m3gV4dN9GSBAwTXfatey/xI+LzyZo7luPuyLe2J07LO bw== -----END CERTIFICATE----- https://tweetdeck.twitter.com/ Peer’s Certificate issuer is not recognized. HTTP Strict Transport Security: true HTTP Public Key Pinning: true Certificate chain: -----BEGIN CERTIFICATE----- MIIDpTCCAo2gAwIBAgIRAJ3Y95mfyPRGAhjp4VURxgkwDQYJKoZIhvcNAQELBQAw KjELMAkGA1UEBhMCRU4xGzAZBgNVBAMMEjE5MGM4MmMxOWFiNDZhNDAgMjAeFw0x NTA1MjAwMDAwMDBaFw0xODA1MjQxMjAwMDBaMIGFMQswCQYDVQQGEwJVUzELMAkG A1UECBMCQ0ExFjAUBgNVBAcTDVNhbiBGcmFuY2lzY28xFjAUBgNVBAoTDVR3aXR0 ZXIsIEluYy4xGTAXBgNVBAsTEFR3aXR0ZXIgU2VjdXJpdHkxHjAcBgNVBAMTFXR3 ZWV0ZGVjay50d2l0dGVyLmNvbTCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEA yviGfBEk5QwMrKWRjeT4/bkUg+nwRXj2WhyIMEujDnVLTLG8raY9gyygyvFcpo9z i6t6+BncW+2bIhQde5PMnSLkFyk3qdOLlX5ZZVxsZCB10XndYGbCkOAyLw2/13I+ jOEB6YFxhnrUGx2RhvgrmMCzuTk7FvbRzAiJrmf12GMCAwEAAaOB7TCB6jCBugYD VR0RBIGyMIGvghV0d2VldGRlY2sudHdpdHRlci5jb22CDXR3ZWV0ZGVjay5jb22C EXd3dy50d2VldGRlY2suY29tghF3ZWIudHdlZXRkZWNrLmNvbYIRYXBpLnR3ZWV0 ZGVjay5jb22CF2Rvd25sb2Fkcy50d2VldGRlY2suY29tghF0ZGFwaS50d2l0dGVy LmNvbYIOdGQudHdpdHRlci5jb22CEmJsb2cudHdlZXRkZWNrLmNvbTAMBgNVHRMB Af8EAjAAMB0GA1UdJQQWMBQGCCsGAQUFBwMBBggrBgEFBQcDAjANBgkqhkiG9w0B AQsFAAOCAQEAJBZPSGGy1MVwJAQmYkX/nCkkbhHMxNI0c9Hf20PnPaHErEPQwbVJ obdeGaT06BfXKBqyIwn0wgGWPlyQkc6JI4Tilb/Sw1k74W3gl8ips6yCbaoouVFC T9XwL1cB25TedHzqCMBzr7JpLaT3HxFmE8SNJpel8/HuZwDygl3bmcxvkcTophiE qgDBcTAlvukgQOWlF5ihBs3sdw6j9gjDc/MaediuNr2MZQk5ZmwTMS50S8F4giGd aJr9sUF5z6hOh1BaqKFGvBgsGr8u8iX7xNkCqGZR/PQikAgbnYre8gtg+ek8JcPW WGRXkpIv/9Vd6POiSW/l9fX9v/HNP63b/A== -----END CERTIFICATE-----

Chosen solution

Ran out of options in the Mozilla threads so I thought what the hell, I'll see if anyone on the Blizzard forums has had the issue, since this affects the battle.net app as well. I was rewarded with a fix and thought I should share here and hope it helps someone in the future.

1. Press Windows Key+R. 2. Type msconfig and press Enter. 3. Select Selective startup and uncheck Load startup items. 4. Select the Services tab. 5. Check Hide all Microsoft services. 6. Click Disable all. 7. Click Apply then click OK. 8. Click Restart.

As to why this worked, everything disabled for me is completely normal (Adobe, Mozilla, Logitech, Steam, etc.) with the exception of one ~mystery service~ called "dd9372d8e56b853c082840028b8c2b48" from manufacturer "Unknown". That I can use Firefox again is great, but not knowing what this service is or how to remove it is pretty concerning. Nothing comes up after an AVG scan and I don't have any information on it other than the scrambled name and unlisted manufacturer. Assuming it is what was causing my connection issues, does anyone have any idea what it could be?

Read this answer in context 4

Chosen Solution

Ran out of options in the Mozilla threads so I thought what the hell, I'll see if anyone on the Blizzard forums has had the issue, since this affects the battle.net app as well. I was rewarded with a fix and thought I should share here and hope it helps someone in the future.

1. Press Windows Key+R. 2. Type msconfig and press Enter. 3. Select Selective startup and uncheck Load startup items. 4. Select the Services tab. 5. Check Hide all Microsoft services. 6. Click Disable all. 7. Click Apply then click OK. 8. Click Restart.

As to why this worked, everything disabled for me is completely normal (Adobe, Mozilla, Logitech, Steam, etc.) with the exception of one ~mystery service~ called "dd9372d8e56b853c082840028b8c2b48" from manufacturer "Unknown". That I can use Firefox again is great, but not knowing what this service is or how to remove it is pretty concerning. Nothing comes up after an AVG scan and I don't have any information on it other than the scrambled name and unlisted manufacturer. Assuming it is what was causing my connection issues, does anyone have any idea what it could be?

Ran out of options in the Mozilla threads so I thought what the hell, I'll see if anyone on the Blizzard forums has had the issue, since this affects the battle.net app as well. I was rewarded with a fix and thought I should share here and hope it helps someone in the future. 1. Press Windows Key+R. 2. Type msconfig and press Enter. 3. Select Selective startup and uncheck Load startup items. 4. Select the Services tab. 5. Check Hide all Microsoft services. 6. Click Disable all. 7. Click Apply then click OK. 8. Click Restart. As to why this worked, everything disabled for me is completely normal (Adobe, Mozilla, Logitech, Steam, etc.) with the exception of one ~mystery service~ called "dd9372d8e56b853c082840028b8c2b48" from manufacturer "Unknown". That I can use Firefox again is great, but not knowing what this service is or how to remove it is pretty concerning. Nothing comes up after an AVG scan and I don't have any information on it other than the scrambled name and unlisted manufacturer. Assuming it is what was causing my connection issues, does anyone have any idea what it could be?
FredMcD
  • Top 10 Contributor
3669 solutions 50330 answers

That was very good work. Well done.

That was very good work. Well done.
cor-el
  • Top 10 Contributor
  • Moderator
16406 solutions 148003 answers

Note that all the certificates have the same rather weird issuer:

  • Issuer C=EN, CN=190c82c19ab46a40 2

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Note that all the certificates have the same rather weird issuer: *Issuer C=EN, CN=190c82c19ab46a40 2 ---- Do a malware check with several malware scanning programs on the Windows computer. *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked