Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How do you turn off the 1 click all text select please?

  • 4 replies
  • 4 have this problem
  • 2393 views
  • Last reply by kryten

more options

Just had to reset FF and I'd forgotten how annoying this default option is. I don't want clicking in the location bar to select all the text.

Chosen solution

There are some prefs about selecting text in the location bar that you can look at:

  • browser.urlbar.clickSelectsAll
  • browser.urlbar.doubleClickSelectsAll

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 👍 2

All Replies (4)

more options

Chosen Solution

There are some prefs about selecting text in the location bar that you can look at:

  • browser.urlbar.clickSelectsAll
  • browser.urlbar.doubleClickSelectsAll

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Thanks Cor-el. Unfortunately this hasn't worked, strangely. One click in the URL bar still selects all text. When I had this problem years ago I seem to remember a different command in the about:config setup, but I could be wrong. Thanks again.

[EDIT]: Sorry I didn't realise you also had to double click the Oneclick option to get a false value, so it works now, you may stand down Sir.

Modified by kryten

more options

Hi kryten,

Would you be a dear and mark cor-el's post as   'Chosen Solution'   ? That way others, with the same problem, will know and might benefit from it.

Thank you in advance   !

more options

Consider it done dear lady!