Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox suddenly refusing all secure connections?

  • 4 replies
  • 8 have this problem
  • 4 views
  • Last reply by cor-el

more options

Firefox 54.0.1 (32-bit), Windows 7. Error messages, since about 12:00 GMT today: "The owner of www.nytimes.com has configured their web site improperly. To protect your information from being stolen, Firefox has not connected to this web site." "The owner of www.w3.org has configured their web site improperly...." "The owner of google.com has configured their web site improperly. This site uses HSTS to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate." The connection to mozilla.org goes through with no problem (although earlier today it connected to pages with no styling because the css files were on secure servers).

Attached screenshots

All Replies (4)

more options

hi, a solution will depend on the individual circumstances: please give us more information about the error by clicking on the error code, copying the text to the clipboard and then pasting it here into a reply in the forum like shown in the screenshot.

thank you!

more options

Oh no, looks like it's 'Kaspersky Internet Security, which updated itself today. Firefox says the the certificate, e.g. for the New York Times, has not been issued by a trusted authority and the issuing authority is... "AO Kaspersky Lab" (see pic). How do put an end to this??

more options

philipp said

hi, a solution will depend on the individual circumstances: please give us more information about the error by clicking on the error code, copying the text to the clipboard and then pasting it here into a reply in the forum like shown in the screenshot. thank you!

Modified by FxFxx

more options