X
Tap here to go to the mobile version of the site.

Support Forum

Turn off pop-up messages for new email notification on a Mac

Posted

Since I installed the latest TB update, I am getting a pop-up in the upper right corner of my Mac everytime a new email message arrives. How do I stop this?

Thanks for your help.

Since I installed the latest TB update, I am getting a pop-up in the upper right corner of my Mac everytime a new email message arrives. How do I stop this? Thanks for your help.

Chosen solution

Thunderbird > Preferences > General When new messages arrive: uncheck: 'Show an alert' click on OK


However, I note that you are using MAC OS and I have heard of something similar before. When you go into Thunderbird > Preferences > General

Maybe that section says: Alerts and default sounds can be stopped by the notification field in system installation.

I found this info in a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=981769

This means: Since OS X 10.8, display of notifications - alert banners/dialogs, badges, and notification sounds - are now the responsibility of the operating system, not the application. The simple fix for this bug then, is to disable and remove all notification sound options from Thunderbird, on OS X 10.8 and above, and let Notification Center deal with it. For the majority of users, and according to Apple, that is the correct solution.

So Apple have decided this has to be done via the OS notification of sounds and not via Thunderbird.

Read this answer in context 4

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

More Information

Toad-Hall
  • Top 10 Contributor
1683 solutions 11186 answers

Chosen Solution

Thunderbird > Preferences > General When new messages arrive: uncheck: 'Show an alert' click on OK


However, I note that you are using MAC OS and I have heard of something similar before. When you go into Thunderbird > Preferences > General

Maybe that section says: Alerts and default sounds can be stopped by the notification field in system installation.

I found this info in a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=981769

This means: Since OS X 10.8, display of notifications - alert banners/dialogs, badges, and notification sounds - are now the responsibility of the operating system, not the application. The simple fix for this bug then, is to disable and remove all notification sound options from Thunderbird, on OS X 10.8 and above, and let Notification Center deal with it. For the majority of users, and according to Apple, that is the correct solution.

So Apple have decided this has to be done via the OS notification of sounds and not via Thunderbird.

Thunderbird > Preferences > General When new messages arrive: uncheck: 'Show an alert' click on OK However, I note that you are using MAC OS and I have heard of something similar before. When you go into Thunderbird > Preferences > General Maybe that section says: Alerts and default sounds can be stopped by the notification field in system installation. I found this info in a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=981769 This means: Since OS X 10.8, display of notifications - alert banners/dialogs, badges, and notification sounds - '''are now the responsibility of the operating system''', not the application. The simple fix for this bug then, is to disable and remove all notification sound options from Thunderbird, on OS X 10.8 and above, and let Notification Center deal with it. For the majority of users, and according to Apple, that is the correct solution. So Apple have decided this has to be done via the OS notification of sounds and not via Thunderbird.

Helpful Reply

Wow, that worked! I found that setting is System Preferences-Notifications. I never would have found it without your help. Thanks.

Wow, that worked! I found that setting is System Preferences-Notifications. I never would have found it without your help. Thanks.