Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't access e-mail from Spectrum server via Thunderbird. Spectrum contacted, said I need to contact you to resolve the problem

  • 4 replies
  • 5 have this problem
  • 316 views
  • Last reply by balpert1

more options

Am able to access e-mails with no problem by going directly to the Spectrum (formerly Time Warner) server (twc.com/support), and entering my username and password. When I go to Thunderbird and click on "Get Messages", I receive a drop down which says that "Mail server mail.twc.com responded: invalid user name or password". I called Spectrum who checked things out and verified that from their end everything is set up correctly, and advised that I contact Mozilla. Tried finding an answer on line, but was unsuccessful. Thanks in advance for your help!

All Replies (4)

more options

Thunderbird connects to providers servers if you have the correct server settings. Email providers configure their servers. If your provider is not smart enough to give you the correct settings, find another one.

more options

What do you have for the incoming and outgoing server settings? They should be mail.twc.com for both the incoming (IMAP port 143 or POP port 110) and outgoing (port 587) servers, with Connection security = None, authentication = password, transmitted insecurely and User name = email address.

If you still have problems, it may be helpful to reset the password. Also, disable any security program from scanning email if it's in place.

more options

I did find this page with Spectrum settings. http://www.spectrum.net/support/internet/email-settings/

more options

Thanks sfhowes. I starting having this problem about a month ago. I could still receive my e-mails with Thunderbird but could no longer send using Thunderbird. I called Spectrum and they knew about the problem and said they were working on it. The next time I called they said they had a work around since they changed the outgoing server to mail.twc.com unfortunately they told me to change my setting for connection security. After reading your answer I noticed your setting for connection security to None was what I had for the receiving server. I went back and changed it to none for the outgoing mail server and all is now well.