Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Automatic mail filters stopped working after Thunderbird 52.1.1 upgrade

  • 21 replies
  • 20 have this problem
  • 166 views
  • Last reply by dkcrotty

more options

After the automatic update to 52.1.1 all my filters stopped running on new mail.

All my filters: - have check marks at "Manually Run" and "Getting New Mail: Filter before Junk Classification", - are of type "From contains ..." and - the actions are "Move Message to ... (certain IMAP folder)" and "Mark As Unread"

Manually running them works as expected.

When new (filterable) mail arrives, the filters log isn't recording anything but when I manually run them the expected action is logged.

All Replies (20)

more options

To diagnose problems with Thunderbird, try the following:

Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.

more options

Thank you for your message. I have tried this and unfortunately I got the same behavior in safe mode too.

more options

I've seen this happen occasionally myself, and it is frustrating. I've never had them quit working entirely, though.

I suggest that you backup the Profile folder, so you will not lose anything.

Try adding a new filter, or change a filter, for the same e-mail account. The change will cause the file on the hard drive that contains the filters to be re-saved. That may be the kick that Thunderbird needs to get the filters working again.

If that doesn't work, there are other things we can try. I will wait to see how this first thing goes before getting into them.

more options

Sorry for the delay - I was out of town for a couple of days.

I did what you suggested (changing a filter or adding a new one) and nothing changed.

I could add more information: I use Thunderbird on several computers. The work computer is always on (24/7) and Thunderbird is always active - it's supposed to do the filtering as soon as the mail arrives (sorting mail in their IMAP folders). At home I have another Thunderbird that I occasionally use to check the mail - this version has no filters because I expect the mail to be already sorted by the other (always active) Thunderbird.

Both Thunderbirds are now version 52.1.1 and, after closing the @work Thunderbird, I tried to define a filter in the @home Thunderbird and then I sent myself (from a different account) a filterable message. Nothing happened. I even tried two cases: - Thunderbird opened and fresh mail arrives in Inbox or - Thunderbird closed, new filterable mail arrives and then I open Thunderbird In both cases filters failed to start automatically but ran OK when invoked manually.

more options

Since the same thing happens with two different computers, and this is not happening to other people, there is something about your particular setups that is different.

To better help you, please post here a screenshot showing us the details of one of these filters. Edit the screenshot to blur out personal details. See: How do I create a screenshot of my problem?

more options

This is how my filters list as well as one of the filters (the first one) are looking. In fact the first one is the only filter that is moving mail to local folders, all the other are moving messages to IMAP folders (I don't care about comics at home but I'd like to see the other in their folders). The incoming mail server runs a rather recent Zimbra version and is hosted on my local network (this is why I have the @192.168.0.1 thing).

Nothing that I could associate with the filters problem changed recently, just Thunderbird upgraded itself to 52.1.1.

more options

I gave-up trying to understand. First I made a clean install @home (simpler configuration) and filters started working, so I just lost 45 minutes and did a clean install and reconfiguration @work and now everything works fine. Thank you a lot for your efforts!

more options

For our information, when you reinstalled Thunderbird, did you create a new Profile, or reuse the old one?

more options

It's a bit more complicated. I prefer storing the mailboxes in a custom directory on a different drive (Server Settings -> Local Directory -> D:/Mail/..something..) My intention was to do a (very) clean install so I moved everything out of D:/Mail leaving it empty but for the first experiment, @home, I forgot to delete the profile in C:/.../AppData/Roaming/... so after reinstalling Thunderbird I was surprised to see that is already starting to download messages in the empty D:/Mail folder (without having to define the accounts). In this half-clean configuration new defined filters started to work. The second time, @work, I removed everything prior to reinstalling.

more options

I've seen many problems with changing the location of the "Local directory".

I always recommend to people that they create the entire Thunderbird Profile on the other hard drive instead. Fewer problems.

more options

Thanks, good idea! I'll move the whole profile in the same place.

more options

I have seen this problem too. I see a message in the Inbox, which should be sorted in a folder, but it isn't. If I run the filter manually, it will get sorted.

Have several computers and filters are not the same. I suspect that if one of the computer without the filter accesses the mail, the status somehow gets changed, so that the computer with the filter does not run the filter. I moved the filter data base to the new computer and has not seen the problem since.

more options

We have some reports like this one here: https://bugzilla.mozilla.org/show_bug.cgi?id=1367438

The problem goes away when people start with a fresh profile. Sadly we haven't worked out so far what it is in old profiles that causes this problem.

more options

same problem. It was working until fairly recently and I assume there was a version update. 52.2.1 (32-bit)

The only thing extra that I have running id Lightning extension.

Tried the add new filter, change old one. NO help.

Guess Ill have to do the reinstall. I have an IP camera and the mail is stuffed with mail messages from that. Very irritating.

more options

Sorry to hear that. All other reporters got going again by creating a new profile.

Do you have any errors in the error console? Tools > Developer Tools > Error Console. There are many, but something that looks like it's related to filters?

Or something in the filter log: Tools > Message Filters, Filter Log.

more options

Hi I just did a reinstall, so I am not sure if the logs still exist. My first try, it didn't fix it, but the, I still am using the original profile I opened the debugger

 have console selected, but here are only 2 entries there,, nothing to help

Thanks, by the way. I will have to see if it has started working. I'm thinking of deleting all the filters and re-creating them

more options

Reinstall Thunderbird? That won't help since the problem sits somewhere in the profile. I think that even recreating the filters won't help. Have you switched on the filter log? Anything in there?

more options
-)

I agree. Reinstall did not seem to help.

Some where, I read a guy say he fixed it that way But then he probably just started over completely.

I'm glad you asked that. I had missed the Filter log option. I checked and it was turned on. Now, I will clear it and then watch to see if I can find an error message. I did a quick look, but then there are so many entries from when I ran it manually, who knows. There at many entries. I need a clean slate.

Ill get back to you if I find something. Or even if not.

I really appreciate the response.

more options

Hi

I'm not sure what happened, but I just started Thunderbird and the filter worked. The only(new) thing I did was turn on that filter log option as you suggested and cleared the logs.

Crossing my fingers that it keeps working, but I wanted to let you know.

more options

dkcrotty said

Hi I'm not sure what happened, but I just started Thunderbird and the filter worked. The only(new) thing I did was turn on that filter log option as you suggested and cleared the logs. Crossing my fingers that it keeps working, but I wanted to let you know.

Very strange.

And if you turn logging off, does the problem return?

  1. 1
  2. 2