Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using GTK+ 2.x and GTK+ 3 in the same process is not supported . . .

  • 1 reply
  • 1 has this problem
  • 481 views
  • Last reply by cor-el

more options

I had been using firefox just fine, until I started to get the error message:

   $ ./firefox -safe-mode &
   [3] 4499
   $ 
   (firefox:4499): Gtk-WARNING **: GTK+ module libgail.so cannot be loaded.
   GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.
   close failed in file object destructor:
   sys.excepthook is missing
   lost sys.stderr
   [3]+  Exit 1                  ./firefox -safe-mode
   $ 
How should I troubleshoot such error?
lbrtchx

All Replies (1)

more options

It is likely that you have an old version of libgail.so that is part of GTK+ 2. You will have to check your software update to see if you can install a GTK+ 3 version.