X
Tap here to go to the mobile version of the site.

Support Forum

How to set Thunderbird Calendar to 24h format ?

Posted

My system config is already in 24h format.

Already restart Thunderbird and my computer.

Also date format in Thunderbird is mm/dd/yyyy but my system format is dd/mm/yyyy.

Fedora 23, Thunderbird 45.4.0

My system config is already in 24h format. Already restart Thunderbird and my computer. Also date format in Thunderbird is mm/dd/yyyy but my system format is dd/mm/yyyy. Fedora 23, Thunderbird 45.4.0

Modified by Islandil

Chosen solution

Did you check the KB article, specifically Configuring the date/time system settings on your computer ? By starting Thunderbird with the variable LC_TIME set to fr it should use French date/time, as I understand it.

Try the following command to start TB: (export LC_TIME=fr; thunderbird)

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0

More Information

Matt
  • Top 10 Contributor
  • Moderator
2478 solutions 16619 answers

check the TZ environment variable in your distribution. Thunderbird will use whatever that is set to. After it restarts to read the value that is.

check the TZ environment variable in your distribution. Thunderbird will use whatever that is set to. After it restarts to read the value that is.

Question owner

Timezone is set to CET Europe Paris. This timezone should use 24h format and dd/mm/yyyy I think.

This is a fresh install, so no sneaky configuration manipulation has been done.

Timezone is set to CET Europe Paris. This timezone should use 24h format and dd/mm/yyyy I think. This is a fresh install, so no sneaky configuration manipulation has been done.

Question owner

So obviously, Thunderbird is not fetching date format from my OS or the wrong one, or displaying the hardcoded default one. Reminder : this is a fresh install with no configuration done, it is stock Fedora 23.

So obviously, Thunderbird is not fetching date format from my OS or the wrong one, or displaying the hardcoded default one. Reminder : this is a fresh install with no configuration done, it is stock Fedora 23.

Question owner

[islandil@localhost ~]$ timedatectl

     Local time: Wed 2017-01-25 14:49:16 CET
 Universal time: Wed 2017-01-25 13:49:16 UTC
       RTC time: Wed 2017-01-25 13:49:16
      Time zone: Europe/Paris (CET, +0100)
Network time on: yes

NTP synchronized: yes

RTC in local TZ: no
[islandil@localhost ~]$ timedatectl Local time: Wed 2017-01-25 14:49:16 CET Universal time: Wed 2017-01-25 13:49:16 UTC RTC time: Wed 2017-01-25 13:49:16 Time zone: Europe/Paris (CET, +0100) Network time on: yes NTP synchronized: yes RTC in local TZ: no
Onno Ekker 95 solutions 318 answers

There are some preferences that TB uses to choose the time and date format. Do you have a French TB? If that's the case, it should probably have set the prefs to the right value.

See this Mozillazine kb for more info about the settings.

I think that maybe the setting of your locale might also matter. Check the pref intl.locale.matchOS if it is set to true. If yes, TB follows the OS, if not, it checks general.useragent.locale.

There are some preferences that TB uses to choose the time and date format. Do you have a French TB? If that's the case, it should probably have set the prefs to the right value. See [http://kb.mozillazine.org/Date_display_format this Mozillazine kb] for more info about the settings. I think that maybe the setting of your locale might also matter. Check the pref intl.locale.matchOS if it is set to true. If yes, TB follows the OS, if not, it checks general.useragent.locale.

Question owner

intl.locale.matchOS is set to true general.useragent.locale is set to en-US

If I understand correctly I cannot have a Thunderbird in English and date/time format following Paris time zone ?

My OS is set to have English language but French format for date and time : 24h and dd/mm/yyyy

intl.locale.matchOS is set to true general.useragent.locale is set to en-US If I understand correctly I cannot have a Thunderbird in English and date/time format following Paris time zone ? My OS is set to have English language but French format for date and time : 24h and dd/mm/yyyy
Onno Ekker 95 solutions 318 answers

Thunderbird can do that, but I'm not sure about the Calendar…

Do you have the built-in Calendar that was shipped with Thunderbird, or did you install Lightning by yourself?

The built-in one only has English locale as it was shipped with English Thunderbird. It *might* help to de-install that and to install Lightning from the Add-ons manager.

Thunderbird can do that, but I'm not sure about the Calendar… Do you have the built-in Calendar that was shipped with Thunderbird, or did you install Lightning by yourself? The built-in one only has English locale as it was shipped with English Thunderbird. It *might* help to de-install that and to install Lightning from the Add-ons manager.

Question owner

I have the built-in Calendar. I don't think it is a problem from Calendar/Lightning. Because emails are also showing mm/dd/yyyy and am/pm format.

I have the built-in Calendar. I don't think it is a problem from Calendar/Lightning. Because emails are also showing mm/dd/yyyy and am/pm format.
Onno Ekker 95 solutions 318 answers

Chosen Solution

Did you check the KB article, specifically Configuring the date/time system settings on your computer ? By starting Thunderbird with the variable LC_TIME set to fr it should use French date/time, as I understand it.

Try the following command to start TB: (export LC_TIME=fr; thunderbird)

Did you check the KB article, specifically [http://kb.mozillazine.org/Date_display_format#Configuring_the_date.2Ftime_system_settings_on_your_computer Configuring the date/time system settings on your computer ]? By starting Thunderbird with the variable LC_TIME set to fr it should use French date/time, as I understand it. Try the following command to start TB: (export LC_TIME=fr; thunderbird)

Question owner

Sorry I missed it. It solve my issue. Just need to launch Thunderbird from a script with this export beforehand. (used fr_FR for LC_TIME value) Thank you for your help

Sorry I missed it. It solve my issue. Just need to launch Thunderbird from a script with this export beforehand. (used fr_FR for LC_TIME value) Thank you for your help
Onno Ekker 95 solutions 318 answers

Great, I'm glad your issue is solved!

Great, I'm glad your issue is solved!