Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"unsupported browser..please upgrade... to latest version of..Firefox, Explorer (NEVER), etc

  • 5 replies
  • 2 have this problem
  • 6443 views
  • Last reply by Paletteer

more options

I am running Firefox 50.1.0. Your educated guess about my Firefox version says 3.5.9, which means you can't read it either.

Flickr and many sites say something like "You seem to be using an unsupported browser. To get the most out of Flickr please upgrade to the latest version of Chrome, Safari, Firefox, or Internet Explorer." I tried everything online to make Norton firewall let in friendly sites to no avail. I know my OS is old, so is my CPU, and memory's small.

Chosen solution

See https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

Your useragent appears to be Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729) FBSMTWB

Firefox useragents since 4.0 should not be affected like this.

Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

See https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

Your useragent appears to be Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729) FBSMTWB

Firefox useragents since 4.0 should not be affected like this.

Modified by James

more options

All Firefox versions support general.useragent.override to set a specific user agent. Only support for general.useragent.extra.* prefs to append a specific text has been removed in Firefox 4+.

Modified by cor-el

more options

Something called Fast Browser Search (FBSMTWB) got installed on your PC all the way back in the days of Firefox 3.5 and it corrupted your UserAgent. Firefox 4.0 and later versions aren't susceptible to that exploit.

Easily fixed by following the instructions in the support article that James hyperlinked. https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

more options

(create a new String pref: general.useragent.override = Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729) FBSMTWB) :wink:

more options

Thank You, Thank You, the-edmeister. Finally fixed. Thanks to the other 3 also, but the-edmeister solution was easiest for me to follow...