Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

T'bird remembers imaps and pop3s passwords too well - won't change

  • 13 replies
  • 1 has this problem
  • 21 views
  • Last reply by christ1

more options

(Windows 7 64 bits install) Thunderbird remembers imaps and pop3s passwords too well. I changed the passwords on the servers for security reasons. Thunderbird attempts to connect and silently fails. I've looked in options->security->saved passwords. I find that "imap://", "pop3://", and "smtp://" account passwords are visibly saved. But the "imaps://" and "pop3s://" are not shown so I cannot delete them. Deleting all saved passwords fails as well.

I can access using pop3 and imap without security for awhile. But this cannot last more than a few weeks before I need to use it from off the local network.

Is there a file I can delete that will smash ALL saved passwords without screwing up my whole profile and all my saved email?

Thanks {^_^}

(Windows 7 64 bits install) Thunderbird remembers imaps and pop3s passwords too well. I changed the passwords on the servers for security reasons. Thunderbird attempts to connect and silently fails. I've looked in options->security->saved passwords. I find that "imap://", "pop3://", and "smtp://" account passwords are visibly saved. But the "imaps://" and "pop3s://" are not shown so I cannot delete them. Deleting all saved passwords fails as well. I can access using pop3 and imap without security for awhile. But this cannot last more than a few weeks before I need to use it from off the local network. Is there a file I can delete that will smash ALL saved passwords without screwing up my whole profile and all my saved email? Thanks {^_^}

Chosen solution

Good. When your problem is fixed, can you then mark the thread as 'Solved' please? Thank you.

Read this answer in context 👍 0

All Replies (13)

more options
But the "imaps://" and "pop3s://" are not shown so I cannot delete them.

I don't understand what that means. Can you post a screenshot? https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem

Deleting all saved passwords fails as well.

In which way? What exactly are you doing? More details, please.

I can access using pop3 and imap without security for awhile.

What does this mean?

more options

OK, it means exactly what it says. You can see three accounts for smtp, one for imap (which is a touch confusing), and one for mailbox (apparently pop3).

There are also saved passwords for imaps and pop3s connecting to the local internal mail server. (I use fetchmail to pull mail from several accounts, aggregate it, feed it through spamassassin, and toss it into a mail spool for dovecot to serve up to T'bird.)

The way pressing the "Remove All" button is the invisible imaps and pop3s passwords are missed. They are still saved.

Since they are wrong the attempts to pull mail down through imaps and pop3s on this machine fail silently. Plain old imap and pop3 are working fine on the internal network. The imaps and pop3s are encrypted links I use while traveling. (ports 993 and 995 instead of 143 and 110 and SSL/TLS encryption.)

T'bird seems to have passwords for imaps and pop3s saved, somewhere. They are wrong. I cannot get my mail if I step off this private unrouted network in the 192.168.x.x realm. While I am here I can go direct on the internal network. While outside I choose to come in on encrypted links over the external facing part of the machine.

What I am doing is migrating from one machine for firewall, dhcp, dns, and incoming email filtering to another. So they have different names on the internet at the moment and probably for the rest of the machines' lives. The configuration has been working for a VERY long time now with the old server. Now with password changes on the servers - it's questionable whether I can communicate when off campus.

Now, I note a problem with the password memory for the servers that the imap and mailbox entries report. They deal with the account's outgoing address rather than the address and protocol for the pop3(s) or imap(s) connections. That may be how things got all fubared.

And for some reason the image jpg file I built is not uploading. Ah, it took a gif almost instantly. Ah well.

{^_^}

Modified by J.B.D.

more options
You can see three accounts for smtp

Why 3 for SMTP, when there are only two accounts in the first place (one POP and one IMAP)?

one for imap (which is a touch confusing),

How is that confusing?

There are also saved passwords for imaps and pop3s connecting to the local internal mail server.

I don't see any of those in your screenshot. Why do you think they are there?

The way pressing the "Remove All" button is the invisible imaps and pop3s passwords are missed. They are still saved.

I don't understand what you're trying to say.

Since they are wrong

What is wrong?

the attempts to pull mail down through imaps and pop3s on this machine fail silently.

If there is no remembered password, Thunderbird will prompt you for the password when it's needed. Do you get a password prompt?

Note, if Thunderbird cannot reach the server (for whatever reason) you won't see a password prompt.

more options

christ1 said

You can see three accounts for smtp

Why 3 for SMTP, when there are only two accounts in the first place (one POP and one IMAP)?

Outgoing and incoming are two different things in this configuration. All incoming goes to one single account on the local machine. For incoming I use the ISP based email services with names like "jdowspamjunk" as well as the more normal one. (The jdowspamjunk gets less spam, of course. {^_-}) The machine running the spam filter sucks down email from all the accounts and mushes them into one using fetchmail. So incoming mail always comes from one account on a local machine. This is the direction with password problems for invisible pop3s and imaps protocols but not pop3 and imap, without the s, protocols.

I use T'bird facilities to select which of several outgoing servers at two different ISPs. These are the smtp passwords that show up.

one for imap (which is a touch confusing),

How is that confusing?

Why does the outgoing pop3 (mailbox) outgoing server appear to be "assigned" to the main incoming account when they are at vastly different locations? (T'bird has excellent facilities to allow this dichotomy. But it seems there is a LONG standing bug which affects only pop3s and imaps (secure pop3 and imap respectively). The first encountered and worked around the bug around 2010 time frame. That workaround is used up on another computer so I'm rather stuck.

There are also saved passwords for imaps and pop3s connecting to the local internal mail server.

I don't see any of those in your screenshot. Why do you think they are there?

Because it has been working for the greater part of a decade and the imaps:// and pop3:// password entries are not appearing, and never have, in the saved passwords list even though they are manifestly there. Otherwise I'd not have been able to use this email configuration for many years now. {o.o} I figure that is a strong hint. SOMETHING is remembering that infernal password.

And why does communications fail SILENTLY? The status bar shows "connecting", sometimes "connected", and then quits after retrieving any mail. "tcpdump" shows a small number of short packets such as would be expected for a password failure with no exchanges about email waiting to be retrieved. So this is a combination of at least two bugs related to imaps and pop3s.

The way pressing the "Remove All" button is the invisible imaps and pop3s passwords are missed. They are still saved.

I don't understand what you're trying to say.

For a period of years this configuration has been working. It even has saved passwords from times I pulled pop3 (mailbox) email direct from the ISPs as an emergency measure. It has NEVER showed the imaps and pop3s passwords that had to be stored there. This is evidenced by the simple fact that pulling in email over pop3s and managing spam training folders using imap3s has been working for years.

So, 1) there is a password present in T'bird's storage somewhere for the imaps and pop3s accounts, 2) these passwords do not appear in the saved passwords list, 3) they are persistent when all passwords are removed with the "Remove all" button, and 4) fetching mail via pop3s and imaps do not work now, without error messages of any kind, since I changed passwords.

Since they are wrong

What is wrong?

The saved passwords that supposedly are not there according to the security passwords manager.

1) Passwords for imaps and pop3s have been present for years. They have been successfully used for pulling down email THROUGH a firewall that blocks imap and pop3 but not imaps and pop3s.

2) These passwords do not appear in the password manager even though they have been used for years. (I never have to respond to a local password request.)

3) The passwords that are there but not there are now wrong because of a change on the imaps/pop3s server. I changed account passwords .

4) I know this because behavior when fetching email via pop3 and pop3s work differently. Pop3 works. Pop3s does not even when I can verify the server has new mail to pull down.

5) (second bug probably related) This failure to pull down mail is not accompanied by any error message. Monitoring the packet exchange is consistent with opening a connection, exchanging username and password, and getting an authentication error. (Which happens to agree with internal logs on that mail server machine.) Again, T'bird fails silently without bringing up a password prompt or anything else.

the attempts to pull mail down through imaps and pop3s on this machine fail silently.

If there is no remembered password, Thunderbird will prompt you for the password when it's needed. Do you get a password prompt?

no

Note, if Thunderbird cannot reach the server (for whatever reason) you won't see a password prompt.

</blockquote>

It reaches. Authentication fails. Same address using pop3 works that fails with pop3s. However, I will reexamine this hypothesis. as a test. The firewall was rewritten recently so there might be an error. That would not resolve the password manager issue, however.

{^_^}

more options
more options

OK, the good news - you got me looking in the right place. I had a typo in the firewall rules. So the main problem is solved. I can now access via open internet. Thank you for pushing me the right direction. I appreciate it.

There remains the "confusion" of a now working pop3s:// password that does NOT appear in the password manager. I made a point ticking that item in the dialog that popped up.

(And I see you sent another message while I was getting the firewall back into sanity.)

This problem is now in a meta-state. It has aspects that are solved and aspects that are not solved. Had the pop3s password appeared in the password manager I'd have been able to zero in on my local problem. As it was, I was left guessing.

{^_^}

more options

Bruce A. Johnson said

Create a new profile in Thunderbird for testing

Bruce, at the moment the problem is half solved. And what remains appears clearly on two machines. The pop3 and imap passwords appear in password manager. The pop3s and imaps passwords do not. That is probably a bug that should be addressed. But it is not a show stopper. It's a show confuser. Credit to Chris1 for (perhaps accidentally) pointing me in the right direction with his comment about no error message if the server cannot be reached. That was a nice diagnostic clue I'm ashamed of myself for not figuring out. (I've slowed down since a 7 appeared in front of my age. SIGH!)

I could start another profile to spotlight imaps/pop3s not appearing. But, I suspect it's not worth it.

Thank you folks for the help.

{^_^} Joanne

more options

A new Thunderbird Profile, will have absolutely no information from the old profile at all. Any "hidden" passwords you think exist in the old profile could not possibly exist in the new profile.

It is indeed "worth it" to test your hypothesis of "hidden" passwords being saved in Thunderbird.

If you continue to have the same problem with the new profile, then the issue is elsewhere other than Thunderbird.

If the issue is solved with the new profile, then you can import your stuff from the old profile.

more options

It is working with this existing profile. The passwords shown are exactly what is shown in the image. There is no change even though I was prompted for a password when I made the connection to the account.

I'll make a quicky account and see if I can duplicate the issue without messing up the mail server contents. Give me a few hours for it. I have some other things to do for awhile. (And I have to figure out how to do it....)

{^_^}

more options

OK the POP3S is saving as "mailbox://" - and I checked - I opened pop3 on the firewall. It seems the pop3 and pop3s both use that mailbox:// password. So I suppose that makes sense and the misbehavior from the broken firewall lead me off down the wrong path.

I believe we can consider this one resolved.

I certainly appreciate your time, especially today. Thank you very much.

{^_^}

more options

The key is a new "profile", not a new account. I give the instructions clearly here: Create a new profile in Thunderbird for testing

more options

I did create a new profile. Within that profile I had to create an account or perhaps better stated couple with the existing server account.

Regardless, it is working properly and I understand more about how T'bird works. I've cleared that new account as the old one is working the same way. Since I've just been playing creative games with iptables, which sees pop3 and pop3s as different things, having T'bird lump them together was off my radar.

I'm happy and consider this issue closed. It was confusion inducing circumstances with behavior I'd, for whatever reasons, I'd not expected.

You and christ1 "did good."

{^_^}

more options

Chosen Solution

Good. When your problem is fixed, can you then mark the thread as 'Solved' please? Thank you.