Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

DRM not working in Firefox 50.0.2 for Linux

more options

I am running Firefox 50.0.2 on Lubuntu 16.10 (32bit)

The DRM feature with Widevine does not appear to be working.

What I really want is to watch Amazon Video; however, not even the demo videos found on http://demo.castlabs.com/ work. The one without DRM does play, the others do not. It does appear to recognize widevine [DRM: com.widevine.alpha (via Common Encryption)], but the circle just spins and spins.

On Amazon, the circle spins up, then it goes to a "Video unavailable" window. One time I tried it and it played for a second or two and then went to the error window, but usually, it goes straight there.

This is supposed to be working in Firefox 49 and later, right? What's wrong with mine?

Thanks for your help.

Chosen solution

Figured it out. Needed ffmpeg.

As on this page: http://www.faqforge.com/linux/how-to-install-ffmpeg-on-ubuntu-14-04/

sudo add-apt-repository ppa:mc3man/trusty-media sudo apt-get update sudo apt-get dist-upgrade sudo apt-get install ffmpeg

Thanks!

Read this answer in context 👍 0

All Replies (4)

more options

The Web Console ("3-bar" menu button or Tools -> Web Developer) shows this error message:

  • Cannot play media. No decoders for requested formats: application/x-mpegURL, application/vnd.apple.mpegURL
more options

Yes, that is what it says on the CastLabs Page.

It does not say that on Amazon, there it says: Uncaught Exception: Undefined, then some warnings about depricated functions.

What do I do about it?

Modified by theredwagoneer

more options

Any help here?

Even if you could verify that this is supposed to work it would tell me if I should keep digging.

Thanks

more options

Chosen Solution

Figured it out. Needed ffmpeg.

As on this page: http://www.faqforge.com/linux/how-to-install-ffmpeg-on-ubuntu-14-04/

sudo add-apt-repository ppa:mc3man/trusty-media sudo apt-get update sudo apt-get dist-upgrade sudo apt-get install ffmpeg

Thanks!