Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is my FireFTP is disabled after updating to Firefox 50.0.2?

  • 6 replies
  • 1 has this problem
  • 11 views
  • Last reply by MaxSterling

more options

I went to use FireFTP and discovered it had been disabled sometime after a recent Firefox update. I'm using Firefox 50.0.2 on a Mac with OS X 10.11.6. I checked one of my other Macs and it exhibits the same issue with FireFTP disabled.

Is there a new version of FireFTP that is compatible? I haven't found it. Or is there another way to restore FireFTP?

Thanks.

All Replies (6)

more options

The latest version of the FireFTP Extension is 2.0.28

https://addons.mozilla.org/firefox/addon/fireftp/

When you check the Add-ons page, what does yours show? Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find FireFTP on the right side. Note that disabled extensions cluster at the bottom. Click the More link to check the version number. That page may also have more information about why you can't re-enable the extension (assuming you can't re-enable it).

What do find there?

more options

Took a snapshot of the info.

more options

Hmm, that's strange. Can you reinstall it, in case the extension became corrupted? Your saved login data should survive the reinstall, but if you want to make a backup:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show in Finder" button. This should launch a new window listing various files and folders. Copy the fireFTPsites.dat file to a safe location. (Your passwords are stored in Firefox's logins.json file, not in that .dat file.)

Any improvement?

more options

Reinstall behaves strangely. I can't use "choose account" or "edit" on the left side.

I can "browse" and select a source directory but nothing comes up in the window, even though there are files in the folder.

I tried importing fireFTPsites.dat from the "tools" option but that doesn't work correctly. It seems to import and I get my list but no "connect" option and "edit is greyed out.

Tried reinstall a couple times with the same results.

more options

Mine seems okay on Windows 7, but I notice some of the reviewers on the Add-ons site also are reporting various problems. Not sure if the developer is going to work on those issues.

Have you ever considered stand-alone FTP software? I have been using FileZilla for my main site because the new host didn't seem to work well with FireFTP: https://filezilla-project.org/

more options

No joy with FireFTP 2.0.28 & Firefox 50.0.2 on either of our Mac Pros.

Filezilla is working ok, thanks for the suggestion. Just need to re-enter all my FTP site information, unless there's an easy way to import the data from FireFTP.