Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't save downloads or files directly to my desktop.

  • 2 replies
  • 3 have this problem
  • 4048 views
  • Last reply by anniep16

more options

I have always been able to save downloads directly on to my desktop. I reset Firefox yesterday and now I don't have that option. When I click "browse" to choose a download place, I choose "desktop" and instead of just saving stuff on to there, it creates a folder called desktop. I don't want a folder I just want the file on there. There isn't the facility to delete what Firefox puts in the box either. I need to remove one of the desktops. Picture attached to hopefully show what I mean. I have the latest version of Firefox - 50.0.1

Attached screenshots

Chosen solution

I try not to use Windows and never really tried Vista, I went from XP to 7. I know Windows usesa bit of smoke and mirrors when it comes to paths to certain locations.

I the item need editing to remove the last \Desktop part as you have identified. I was under the impression we could edit that directly in options, but apparently not. If you use the browse option it should open the current chosen location, and all you need to do is to navigate to the next level up and choose Open and that should set it correctly. When I try in Windows 10 I actually get an option from browsing tha tjust shows an icon and the word Desktop you may be able to find a similar shortcut om Vista from the browse option.

It will also be possible to edit the pref

browser.download.dir

but I will not complicate matters at this stage by explaining how to do that.

If something is broken you may need to refer to

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

I try not to use Windows and never really tried Vista, I went from XP to 7. I know Windows usesa bit of smoke and mirrors when it comes to paths to certain locations.

I the item need editing to remove the last \Desktop part as you have identified. I was under the impression we could edit that directly in options, but apparently not. If you use the browse option it should open the current chosen location, and all you need to do is to navigate to the next level up and choose Open and that should set it correctly. When I try in Windows 10 I actually get an option from browsing tha tjust shows an icon and the word Desktop you may be able to find a similar shortcut om Vista from the browse option.

It will also be possible to edit the pref

browser.download.dir

but I will not complicate matters at this stage by explaining how to do that.

If something is broken you may need to refer to

more options

Thanks for your reply John. I've got it sorted now and I'm not sure whether or not I did what you suggested but you obviously pointed me in the right direction. I clicked on "browse" again and instead of just choosing "Desktop" from the menu shown, I clicked on my name and chose desktop from the menu shown there. All O.K. now. By the way, I'm nearly local to you - Southport.