Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox in 32 bit mode won't open even though 32 bit version is enabled

  • 3 replies
  • 2 have this problem
  • Last reply by FredMcD

more options

Dear all, I am on OS X El Capitan, and quite new to MAC OS. I need to use a web browser in 32 bit mode for a website that requires it, so I followed a thread that showed me how to allow your firefox to run in 32 bit mode ("go to Finder/Locate Firefox/Ctrl click Get information/tick "run in 32 bit mode"). Unfortunately when I quit and restart the browser it seems that I am still running in 64-bit mode. The 32 bits links won't work AND I can see in the troubleshooting panel some indications that I am still running 64 bit... I tried to block automatic updates, or to lock the version after ticking the "32 bit mode" in the finder but so far nothing worked. I even tried to restart the computer to see if it did anything.

Has anyone encountered the same issue ?


All Replies (3)

more options

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

I have no problem in changing the preferences, they just seem not to apply. However I have tried all the methods, and here is the feedback : Refreshing the browser : already tried, didn't work. Modifying the users.js file : I don't have such file in the said profile folder Unlocking prefs.js file : it was not locked

As for the other possibility (malware) I never had the impression that firefox was running oddly, nothing that suggests that a malware has been installed.

For what it is worth, I had 2 add-ons installed : Adblock and Perapera Chinese. Bur they disappeared when I re-installed firefox.

Also, I read somewhere ( that it could be due to a missing 32-bits java plugin. But this is a little outside my comfort zone... And it may only apply to the windows environment.

more options

Make sure your Java (Not JavaScript) is up to date Verify Java and Find Out-of-Date Versions {web link}

Version 8 Update 111 Release date October 18, 2016