X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Firefox window does not open, but it is on the task manager list

Posted

As the question says, Firefox does appear on the task manager as open but the window is not actually there. I tried reinstalling it, but it did not help. I also tried running as administrator and in the safe mode - still nothig. I know it did work earlier, then it began to open very slowly and now the window doesn't appear at all. I don't use this computer, my mom does, so I don't know any more details. The system is windows 10 upgraded from windows 8. Hope someone could help me with this.

As the question says, Firefox does appear on the task manager as open but the window is not actually there. I tried reinstalling it, but it did not help. I also tried running as administrator and in the safe mode - still nothig. I know it did work earlier, then it began to open very slowly and now the window doesn't appear at all. I don't use this computer, my mom does, so I don't know any more details. The system is windows 10 upgraded from windows 8. Hope someone could help me with this.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2486.0 Safari/537.36 Edge/13.10586

More Information

FredMcD
  • Top 10 Contributor
4396 solutions 61646 answers

You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/
  • Linux: *~/.mozilla/firefox/
  • Windows: %AppData%\Mozilla\Firefox\
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Locate the above files. Then rename or delete them. Restart Firefox.

You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' file. '''Close Firefox'''. Open your file browser to this hidden location: * Mac: *~/Library/Application Support/Firefox/ * Linux: *~/.mozilla/firefox/ * Windows: %AppData%\Mozilla\Firefox\ * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\ Locate the above files. Then rename or delete them. Restart Firefox.

Question owner

Thank you for the answer. I searched the whole location but these files are not there at all.

Thank you for the answer. I searched the whole location but these files are not there at all.
FredMcD
  • Top 10 Contributor
4396 solutions 61646 answers

If those files were missing, Firefox would recreate them. Did you look in the sub-directories?

If those files were missing, Firefox would recreate them. Did you look in the sub-directories?

Question owner

Here's a screenshot of all firefox files I found, the folders visible here are empty.

Here's a screenshot of all firefox files I found, the folders visible here are empty.
FredMcD
  • Top 10 Contributor
4396 solutions 61646 answers
These should be more files in that folder. Use these links to create a new profile. Use this new profile '''as is.''' Is the problem still there? '''http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder''' '''https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles''' '''https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible'''

Question owner

I tried using these instruction but the profile manager does not open.

I tried using these instruction but the profile manager does not open.
FredMcD
  • Top 10 Contributor
4396 solutions 61646 answers

Not responding? Error message?

Not responding? Error message?
Happy112 561 solutions 5694 answers

Hi   !
This worked for somebody else the other day:

1 – Head to the Control Panel and click on   'Power Options' 2 – Click the link of the left-hand side   ‘Choose what the power buttons do’ 3 – Click the   ‘Change settings currently unavailable’ link 4 – Tick the   ‘Turn on fast start-up’ box under  'Shut-down' settings

Hi &nbsp; !<BR> This worked for somebody else the other day:<BR> 1 – Head to the Control Panel and click on &nbsp; 'Power Options' 2 – Click the link of the left-hand side &nbsp; ‘Choose what the power buttons do’ 3 – Click the &nbsp; ‘Change settings currently unavailable’ link 4 – Tick the &nbsp; ‘Turn on fast start-up’ box under&nbsp; 'Shut-down' settings<BR>
philipp
  • Top 25 Contributor
  • Moderator
5348 solutions 23617 answers

hi, mozilla just released an update to firefox 49.0.2 that should fix a problem that sound pretty similar to what you've described. you can download this new version from https://www.mozilla.org/en-US/firefox/all/ to see if it works for you too.

hi, mozilla just released an update to firefox 49.0.2 [https://www.mozilla.org/en-US/firefox/49.0.2/releasenotes/ that should fix a problem] that sound pretty similar to what you've described. you can download this new version from https://www.mozilla.org/en-US/firefox/all/ to see if it works for you too.