Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox wont start after update win10

  • 7 replies
  • 2 have this problem
  • Last reply by asifbalgar

more options

Received a notification to restart firefox to apply an update, clicked on restart, it did the upgrade process, the window closed but firefox did not start. I could see firefox.exe process running in my task manager. i restarted my system, tried uninstalling and reinstalling different versions. deleted appdata/mozilla, disabled my security software (kaspersky antivirus) but nothing helped. I see the process running in task manager and Profile manager and safe mode do the same thing as well. I am not sure if this has any relevance, but i did install a "big" windows 10 update on friday. but everything worked great untill i clicked restart firefox. any help will be appreciated.

Chosen solution

hi, mozilla just released an update to firefox 49.0.2 that should fix a problem that sound pretty similar to what you've described. you can download this new version from to see if it works for you too.

Read this answer in context 👍 1

All Replies (7)

more options

Ok, now i uninstalled firefox, deleted the directory from program files, then deleted directories in appdata/local and appdata/roaming. then installed firefox 48.0.1. and that worked fine.

I re tried updating it to the latest version from the help window, and the issue reoccurred.

I have currently reverted back to 48.0.1

more options

Hi asifbalgar, do you run the standard version of Firefox for Windows (32-bit) or the 64-bit version of Firefox for Windows? You mentioned using VLC, so if that works, it must be the 32-bit version.

One of the headline changes in Firefox 48 was that some users have a new feature enabled (e10s), which separates the browser interface process from the page content process. Firefox 49 is expanding the roll-out, so this might cause issues for some users.

Could you check whether you have this feature turned on? Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If your Firefox is not performing well with e10s enabled, you could try turning it off here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Let us know if you notice any difference. (It's really a temporary workaround for diagnostic purposes, and not a solution.)

more options

Hi Jscher200, Thank you for your reply.

I run the standard 32 bit version Firefox. and if i look into the about;support of the 48.0.1 that im currently using it says: Multiprocess Windows : 0/1 (Disabled)

more options

Hmm, yes, I wonder whether that is changing for you in Firefox 49. This is a difficult problem to try to work around if that is the cause.

Does your Firefox 48 have any problem using plugin-container.exe? For example, if you load some Flash content, you should see plugin-container.exe in the Task Manager Details tab (maybe also the Processes tab, I don't have Windows 10 handy to check). e10s can't run without plugin-container.exe functioning properly.

more options

I can confirm that the plugin container does work in my current version. but i am not sure what it does in 49.

more options

Chosen Solution

hi, mozilla just released an update to firefox 49.0.2 that should fix a problem that sound pretty similar to what you've described. you can download this new version from to see if it works for you too.

more options

THank you philipp, I installed Firefox 49.0.2 and it works fine!