X
Tap here to go to the mobile version of the site.

Support Forum

How do I fix incorrectly displaying fonts?

Posted

Some fonts aren't displayin correctly on webpages. Most noteably, in code boxes and stuff. Instead of legible text, all I see are shapes of triangles, squares, and stars.

Some fonts aren't displayin correctly on webpages. Most noteably, in code boxes and stuff. Instead of legible text, all I see are shapes of triangles, squares, and stars.
Attached screenshots

Chosen solution

I solved the problem by installing two fonts on my machine: ttf-dejavu and ttf-liberation. I don't really understand though why it worked though, because in Firefox's settings, I never changed the default font. I also had that little box unchecked that says "Allow pages to choose their own fonts, instead of my selections above".

It seems like the fonts Firefox was trying to use should have remained unchanged, but I guess that's not how things work. Firefox used the newly installed fonts anyway. I don't know, I don't get it.

Read this answer in context 2

Additional System Details

Installed Plug-ins

ublock origin

Application

  • Firefox 49.0.1
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
  • Support URL: https://support.mozilla.org/1/firefox/49.0.1/Linux/en-US/

Extensions

  • Multi-process staged rollout 1.2 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • uBlock Origin 1.9.8 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • NoScript 2.9.0.14 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Sandybridge Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • crashGuards: []
  • driverDate:
  • driverVersion: 3.0 Mesa 12.0.3
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}]}
  • info: {u'ApzWheelInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'cairo'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Chosen Solution

I solved the problem by installing two fonts on my machine: ttf-dejavu and ttf-liberation. I don't really understand though why it worked though, because in Firefox's settings, I never changed the default font. I also had that little box unchecked that says "Allow pages to choose their own fonts, instead of my selections above".

It seems like the fonts Firefox was trying to use should have remained unchanged, but I guess that's not how things work. Firefox used the newly installed fonts anyway. I don't know, I don't get it.

I solved the problem by installing two fonts on my machine: ttf-dejavu and ttf-liberation. I don't really understand though why it worked though, because in Firefox's settings, I never changed the default font. I also had that little box unchecked that says "Allow pages to choose their own fonts, instead of my selections above". It seems like the fonts Firefox was trying to use should have remained unchanged, but I guess that's not how things work. Firefox used the newly installed fonts anyway. I don't know, I don't get it.
FredMcD
  • Top 10 Contributor
4269 solutions 59875 answers

Helpful Reply

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.
Estevão Santos 9 solutions 114 answers

Hello!

I'm with issues incorrectly displaying fonts in Twitter, Outlook and anothers websites.

I don't know if it is any settings that modified in about:config.

The box in options Advanced is checked to "Allow pages to choose their own fonts".

Follow print of screen below!

(Sorry by English, it is elementary!)

Thank you for a fix it.

Hello! I'm with issues incorrectly displaying fonts in Twitter, Outlook and anothers websites. I don't know if it is any settings that modified in '''about:config'''. The box in options Advanced is checked to '''"Allow pages to choose their own fonts"'''. Follow print of screen below! (Sorry by English, it is elementary!) Thank you for a fix it.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

Hi Estevão Santos

You can check the Web Console (Firefox/Tools > Web Developer) for error messages about downloaded fonts. You can check the Network Monitor to see if content is blocked or otherwise fails to load.

You can use "Ctrl+F5" or "Ctrl+Shift+R" to reload the page and bypass the cache to generate a fresh log.

Special icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real character and not the little box with the CSS code.

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure it is set to true (if necessary double-click the line to toggle its value to true).

Firefox 41+ will allow icon fonts that use PUA code points to work with the font setting in "Options/Preferences > Content > Advanced" disabled. When unsupported code points are used then you see the little boxes with the hex code.

Hi Estevão Santos You can check the Web Console (Firefox/Tools > Web Developer) for error messages about downloaded fonts. You can check the Network Monitor to see if content is blocked or otherwise fails to load. *https://developer.mozilla.org/Tools/Web_Console *https://developer.mozilla.org/Tools/Network_Monitor You can use "Ctrl+F5" or "Ctrl+Shift+R" to reload the page and bypass the cache to generate a fresh log. Special icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real character and not the little box with the CSS code. You can check the <b>gfx.downloadable_fonts.enabled</b> pref on the <b>about:config</b> page and make sure it is set to true (if necessary double-click the line to toggle its value to true). Firefox 41+ will allow icon fonts that use PUA code points to work with the font setting in "Options/Preferences > Content > Advanced" disabled. When unsupported code points are used then you see the little boxes with the hex code. *http://www.ghacks.net/2015/07/21/firefox-41-mozilla-modifies-how-icon-fonts-are-handled-by-the-browser/

Modified by cor-el

Estevão Santos 9 solutions 114 answers

Hey cor-el,

I'm seeing the code hex in little boxes!

But the Preferences in about:config both are correctly set like browser.display.use_document_fonts = 1 and gfx.downloadable_fonts.enabled = true.

(ps.: In console Debugger I found the font "rosettaicons" not working and with errors for the Twitter)

FIX IT: I found what was causing the blocked of icons "rosettasicons". It was the Extension uBlock Origin. I reset the settings to default and the icons return.

Thanks!

Hey cor-el, I'm seeing the code hex in little boxes! But the Preferences in '''about:config''' both are correctly set like '''browser.display.use_document_fonts = 1''' and '''gfx.downloadable_fonts.enabled = true'''. (ps.: In console Debugger I found the font '''"rosettaicons"''' not working and with errors for the Twitter) '''FIX IT:''' I found what was causing the blocked of icons "rosettasicons". It was the Extension uBlock Origin. I reset the settings to default and the icons return. Thanks!

Modified by Estevão Santos