Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Options/Remote Content button missing. permissions.default.image reverts to 2

  • 47 replies
  • 2 have this problem
  • Last reply by Toad-Hall

more options

After recovering my email and calendar from a MozBackup file (I know, but it was all I had when the other computer s*** the bed) I have several funky things happening but missing the ability to allow (or not) remote content is the most annoying. None of the fixes I have found have worked. Is there a way to set all Configurations to default? Does anyone have a better fix?

Chosen solution

re :the Defaults - Prefs folder contains 6 .js files in addition to the channel-prefs.js file. Interesting....I was under the impression that those sort of files were put into omni.ja file to help improve performance, so I was not expecting them to be in different places. They are in the omni.ja file in my installation.

I understand that you have been installing several times, but it looks as if you have installed on top of an older one to get those files in that folder.

Please work through every stage mentioned below in the order stated. I want to be certain that you have a clean install and no local cache interfering.

  • Please close Thunderbird now.

Access this file:

  • C:\Users\<Windows user name>\AppData\Local\Thunderbird\Profiles

It will contain your profile name folder, but not the one which Thunderbird uses to contain all your profile accounts, emails, etc. Windows creates it and uses it as a cache.

  • Please delete the profile name folder usually called 'xxxxxxxx.default' where the x's are letters and numbers.

Now access :

  • C:\Users\<Windows user name>\AppData\Roaming\Thunderbird\Profiles\<Profile name>\
  • open 'prefs.js' file using Notepad and make sure there is no mention of the user_pref
  • permissions.default.image

If there is, then please carefully remove that line and save the file.

  • Delete the following files - they will be auto recreated.

- * session.json - * xulstore.json

Some time back I mentioned completely uninstalling the program Please do this again.

via Control Panel > Programs & Features.

Then check it really has gone: This should not exist..depending upon whether you use 32bit or 64bit operating system

  • C:\Program Files\Mozilla Thunderbird\


  • C:\Program Files (x86)\Mozilla Thunderbird\
  • Delete any previous program downloads, which may be in your 'Downloads' folder to prevent any confusion.

Download a completely fresh installation from here:

  • choose preferred language eg: en-GB is English British
  • download the 'Thunderbird Setup 45.3.0.exe' file

Then run that file to install Thunderbird. The windows appdata > local > Thunderbird > Profile folder will auto add a new folder for the profile name and put some cache folders in it.

Finally start Thunderbird and report back on the results.

Read this answer in context 👍 1

All Replies (20)

more options

can you change other settings? Like add a signature?

more options

I can add a signature, it was still there, even after restarting the computer.¶ If it helps, the other significant problem is with subfolders in local folders, I often (but not always) have to open them in a new tab to see the messages, but once I do the messages are visible in the usual way. Repairing the folder makes no difference.

more options

I am still stumbling along without the button to allow remote content. I really need to fix this. In the interest of completely describing all issues:

  1. Allow/disallow button missing
  2. Some sub-folders not opening properly (if I open them in a new tab, then close the tab the folder is open)
  3. Inbox of primary email account always opens with "# This Source Code Form . . ." and I can not delete it.
  4. Please HELP, I have tried all fixes I have found to no avail.
more options

Please restart Thunderbird with addons disabled.

In Thunderbird 'Help' > 'Restart with add-ons disabled.'

If it now works then it is possible one of your addons is causing a conflict. You would need to restart as normal, access the Addons and disable one at a time, restarting each time to see if it starts to work, then when you know which addon it is, see if there is an update for that addon.

Please report back on results.

more options

Also check this:

'Tools' > 'Options' > 'Advanced' > 'General' tab OR 'Menu icon' > 'Options' > 'Options' > 'Advanced' > 'General' tab

click on 'Config Editor' button - it will say to be careful :)

In search type: default.image Look for this line: permissions.default.image The Value needs to be : 1 If it is not 1 then double click on the line to get a pop up window and enter the number 1 and click on all OK's

Please report back on results.

more options

Toad-Hall; both suggestions were among the first I tried.

As the issue title says "permissions.default.image reverts to 2" The only active add-on is Lightning (calendar). Talkback is disabled and incompatible. However even with them both disabled the problem persists.

Thanks for the suggestions though.

more options

I've done a bit of reading around bugzilla and this bug was mentioned. It was also not possible to reset the value directly into the prefs.js file and so the conclusion was that something was amiss with the actual installation/program and not the profile itself.

Please uninstall all versions of Thunderbird program. Start > Settings > Control Panel > Programs & Features select Thunderbird and click on 'uninstall'.

Make sure there are no aditional versions of Thunderbird.

Then download and install from this link, choosing the prefered language and download for your OS:

Report back on results.

more options

Well, I learned a little more. After reinstalling as suggested the problem still persists. Tried changing the default.image value to 1, worked (although I saw no button, that could be the unread email available). Checking that value at every step along the way, it reset to 2 as when I closed and reopened Thunderbird.

Conclusion, yes, default.image set to 2 is the problem but something is resetting it back to 2 whenever I close the program.

Tried (again) with add-ons disabled, left them disabled this time. Still, the value reverted to 2. It appears Thunderbird itself, not an add-on is changing the value.

p.s. operating with default.image set to 1 (without restarting) also resolved the folders issues.

more options

Confirmed, the Options button is back ----- IF I set default.image to 1 each time I open Thunderbird. More a workaround than a fix, but progress.

more options

Please add the troubleshooting information to your post To find the Troubleshooting information:

  • Open Help (or click on three-line-icon and select Help)
  • Choose Troubleshooting Information
  • Use the button Copy to clipboard to select all. Do not check box "Include account names"!
  • Paste this in your post.

I doubt this will move this a lot further to a solution. But it is a step that can not be ignored.

What security / Optimization software do you have installed? Anti virus, ccleaner memory compressors etc. Check the file properties for last accessed and updated for the prefs.js file Do they update on closing and only then?

Open the prefs.js file in notepad. scroll around in it. Is there anything that looks like corruption? (not text) the file is a text file and everything should appear basically as any other Unicode text file. You do not have to understand the text to see something that looks odd in the context.

more options

Application Basics

   Name: Thunderbird
   Version: 45.2.0
   User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.2.0
   Profile Folder: Show Folder
             (Local drive)
   Application Build ID: 20160630070546
   Enabled Plugins: about:plugins
   Build Configuration: about:buildconfig
   Memory Use: about:memory
 Mail and News Accounts
     INCOMING: account1, , (pop3), plain, 0
     OUTGOING: ,, plain, passwordCleartext, true
     OUTGOING: ,, plain, passwordCleartext, false
     INCOMING: account2, , (none) Local Folders, plain, passwordCleartext
     INCOMING: account3, , (pop3), plain, 0
     OUTGOING: ,, plain, passwordCleartext, true
     INCOMING: account4, , (pop3), plain, 0
     OUTGOING: ,, alwaysSTARTTLS, passwordEncrypted, true
     INCOMING: account5, , (pop3), SSL, passwordCleartext
     OUTGOING: ,, alwaysSTARTTLS, passwordCleartext, true
     INCOMING: account6, , (pop3), SSL, passwordCleartext
     OUTGOING: ,, SSL, passwordCleartext, true
     INCOMING: account7, , (pop3), SSL, passwordCleartext
     OUTGOING: ,, SSL, passwordCleartext, true
     INCOMING: account8, , (pop3), SSL, passwordCleartext
     OUTGOING: ,, SSL, passwordCleartext, true
     INCOMING: account9, , (pop3), SSL, passwordCleartext
     OUTGOING: ,, SSL, passwordCleartext, true
     INCOMING: account10, , (pop3), SSL, passwordCleartext
     OUTGOING: ,, SSL, passwordCleartext, true
 Crash Reports
   Lightning, 4.7.2, true, {e2fda1a4-762b-4020-b5ad-a41df1933103}
   Talkback,, false,
more options

Important Modified Preferences

   Name: Value
     browser.cache.disk.capacity: 358400
     browser.cache.disk.filesystem_reported: 1
     browser.cache.disk.smart_size_cached_value: 358400
     browser.cache.disk.smart_size.first_run: false
     browser.cache.disk.smart_size.use_old_max: false
     dom.apps.reset-permissions: true
     extensions.lastAppVersion: 45.2.0 Consolas Consolas Consolas Consolas Consolas Consolas Consolas Calibri Calibri Calibri Calibri Calibri Calibri Calibri Cambria Cambria Cambria Cambria Cambria Cambria Cambria
     font.size.fixed.el: 14 14
     font.size.fixed.x-baltic: 14
     font.size.fixed.x-central-euro: 14
     font.size.fixed.x-cyrillic: 14
     font.size.fixed.x-unicode: 14
     font.size.fixed.x-western: 14
     font.size.variable.el: 17 17
     font.size.variable.x-baltic: 17
     font.size.variable.x-central-euro: 17
     font.size.variable.x-cyrillic: 17
     font.size.variable.x-unicode: 17
     font.size.variable.x-western: 17
     gfx.crash-guard.d3d11layers.appVersion: 45.2.0
     gfx.crash-guard.d3d11layers.deviceID: 0x13c0
     gfx.crash-guard.d3d11layers.feature-d2d: true
     gfx.crash-guard.d3d11layers.feature-d3d11: true
     gfx.crash-guard.glcontext.appVersion: 45.2.0
     gfx.crash-guard.glcontext.deviceID: 0x13c0
     gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true
     gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true
     gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false
     gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false
     gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true
     gfx.crash-guard.status.d3d11layers: 2
     gfx.crash-guard.status.glcontext: 2
     gfx.direct2d.disabled: false
     gfx.direct3d.last_used_feature_level_idx: 0
     layers.acceleration.disabled: false
     mail.openMessageBehavior.version: 1
     mail.winsearch.firstRunDone: true 7f572b45-9c98-421e-82de-c5bc6313053 {"threadCol":{"visible":true,"ordinal":"1"},"flaggedCol":{"visible":true,"ordinal":"3"},"attachmentCol":{"visible":false…
     network.cookie.prefsMigrated: true
     network.predictor.cleaned-up: true
     places.database.lastMaintenance: 1471799088
     places.history.expiration.transient_current_max_pages: 104858
     places.history.expiration.transient_optimal_database_size: 167772160
     plugin.importedState: true
     plugin.state.flash: 0
     print.printer_HP_DeskJet_1220C.print_bgcolor: false
     print.printer_HP_DeskJet_1220C.print_bgimages: false
     print.printer_HP_DeskJet_1220C.print_downloadfonts: false
     print.printer_HP_DeskJet_1220C.print_duplex: -437918235
     print.printer_HP_DeskJet_1220C.print_edge_bottom: 0
     print.printer_HP_DeskJet_1220C.print_edge_left: 0
     print.printer_HP_DeskJet_1220C.print_edge_right: 0
     print.printer_HP_DeskJet_1220C.print_edge_top: 0
     print.printer_HP_DeskJet_1220C.print_evenpages: true
     print.printer_HP_DeskJet_1220C.print_footerleft: &PT
     print.printer_HP_DeskJet_1220C.print_footerright: &D
     print.printer_HP_DeskJet_1220C.print_headerleft: &T
     print.printer_HP_DeskJet_1220C.print_headerright: &U
     print.printer_HP_DeskJet_1220C.print_in_color: true
     print.printer_HP_DeskJet_1220C.print_margin_bottom: 0.5
     print.printer_HP_DeskJet_1220C.print_margin_left: 0.5
     print.printer_HP_DeskJet_1220C.print_margin_right: 0.5
     print.printer_HP_DeskJet_1220C.print_margin_top: 0.5
     print.printer_HP_DeskJet_1220C.print_oddpages: true
     print.printer_HP_DeskJet_1220C.print_orientation: 0
     print.printer_HP_DeskJet_1220C.print_page_delay: 50
     print.printer_HP_DeskJet_1220C.print_paper_data: 1
     print.printer_HP_DeskJet_1220C.print_paper_height: 11.00
     print.printer_HP_DeskJet_1220C.print_paper_size_type: 0
     print.printer_HP_DeskJet_1220C.print_paper_size_unit: 0
     print.printer_HP_DeskJet_1220C.print_paper_width: 8.50
     print.printer_HP_DeskJet_1220C.print_resolution: -437918235
     print.printer_HP_DeskJet_1220C.print_reversed: false
     print.printer_HP_DeskJet_1220C.print_scaling: 1.00
     print.printer_HP_DeskJet_1220C.print_shrink_to_fit: true
     print.printer_HP_DeskJet_1220C.print_to_file: false
     print.printer_HP_DeskJet_1220C.print_unwriteable_margin_bottom: 0
     print.printer_HP_DeskJet_1220C.print_unwriteable_margin_left: 0
     print.printer_HP_DeskJet_1220C.print_unwriteable_margin_right: 0
     print.printer_HP_DeskJet_1220C.print_unwriteable_margin_top: 0
     privacy.donottrackheader.enabled: true
     Adapter Description: NVIDIA GeForce GTX 980
     Vendor ID: 0x10de
     Device ID: 0x13c0
     Adapter RAM: 4095
     Adapter Drivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b07608b795ac4102\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b07608b795ac4102\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b07608b795ac4102\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b07608b795ac4102\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b07608b795ac4102\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b07608b795ac4102\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b07608b795ac4102\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b07608b795ac4102\nvwgf2um
     Driver Version:
     Driver Date: 8-11-2016
     Direct2D Enabled: true
     DirectWrite Enabled: true (10.0.14393.0)
     ClearType Parameters: ClearType parameters not found
     WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 980 Direct3D11 vs_5_0 ps_5_0) -- OpenGL ES 2.0 (ANGLE
     GPU Accelerated Windows: 1/1 Direct3D 11
     AzureCanvasBackend: direct2d 1.1
     AzureSkiaAccelerated: 0
     AzureFallbackCanvasBackend: cairo
     AzureContentBackend: direct2d 1.1
 Incremental GC: 1
   Activated: 0
   Prevent Accessibility: 0
 Library Versions
     Expected minimum version
     Version in use
     3.21.1 Basic ECC
     3.21.1 Basic ECC
     NSS Util
     NSS SSL
     3.21.1 Basic ECC
     3.21.1 Basic ECC
more options

I had to split Troubleshooting information into 2 posts, too long for 1.

I use Norton Antivirus. "Allow antivirus clients to Quarantine . . ." is not checked.

prefs.js took a few minutes to find and a while longer to figure out how to open. Scanned through it a couple of times but I see nothing out of the ordinary for a text document.

more options

OH, and yes, Date modified for prefs.js updates each time.

more options

Do you also have a user.js file?

more options

Zenos, no user.js for Thunderbird, there is one for Firefox

more options

Could you try this: 'Tools' > 'Options' > 'Advanced' > 'General' tab OR 'Menu icon' > 'Options' > 'Options' > 'Advanced' > 'General' tab

uncheck 'Use hardware acceleration when available'

click on OK

Restart Thunderbird.

Report back on results.

more options

That improved things some. default.image was still set to 2 but the options button showed up for most emails. Interestingly the email where I had to set default.image to 1 to see the remote content was the one from mozilla support notifying me of your post. I had no problem opening folders with this mornings mail but that could just be luck.

more options

okay, it appears the folder problem is not fixed. default.image problem appears to have taken another step toward a fix, if only default.image would stick at 1

more options

Addon extension 'TalkBack' is what used to be the crash reporter (used to diagnose crashes) back in thunderbird2 - apparently it's not used anymore. So let's remove it.

Please uninstall Talkback. 'Tools' > 'Addons' OR 'Menu icon' > 'Addons'

I'm presuming you have permissions.default.image set as 1 Restart Thunderbird

Report back on results.

  1. 1
  2. 2
  3. 3