Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop browser from opening a new tab when restarting last session

  • 7 replies
  • 1 has this problem
  • 1 view
  • Last reply by FredMcD

more options

When restarting firefox the browser automatically opens a new (unwanted) tab as well as the previous session. How do I stop this?

Chosen solution

Spybot managed to find a single registry entry for firefox, internet explorer & edge. Deleted them & so far so good, seems to have corrected the problem.

Thanks

Read this answer in context 👍 0

All Replies (7)

more options

What is in the new tab?

more options

any random web page

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.

more options

No the path is clean

more options

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Chosen Solution

Spybot managed to find a single registry entry for firefox, internet explorer & edge. Deleted them & so far so good, seems to have corrected the problem.

Thanks

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.