Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not open, despite clicking on the icon many times.

  • 6 replies
  • 1 has this problem
  • 4275 views
  • Last reply by FredMcD

more options

As the title says, Firefox is not opening. I was working perfectly fine last night, and then suddenly it didn't today morning. I have restarted my laptop many times, and have also tried reinstalling it 3 times, to no avail. As per https://support.mozilla.org/en-US/kb/firefox-wont-start-find-solutions#w_firefox-previously-worked, I tried creating a new profile in Profile Manager, which, again, amounted to nothing. I click the icon, get the hourglass thing for two or three seconds, and nothing apparent happens, but Firefox still appears in the Task Manager. Other than reinstalling, restarting laptop and creating a new profile, I have no idea what to do. Thanks in advance.

Chosen solution

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link} Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder.
https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac Linux: Check your user manual.

Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.


If there is a problem, start your Computer in safe mode and try again.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Read this answer in context 👍 1

All Replies (6)

more options

Does the Firefox icon show on the taskbar is if it is opened? It could be that the window has opened where you can't see it.

Right click on the icon and select Open New Window. Sometimes this works. If it opens, close it by Menu > File > Exit.


You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/
  • Linux: *~/.mozilla/firefox/
  • Windows: %AppData%\Mozilla\Firefox\
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Locate the above files. Then rename or delete them. Restart Firefox.

more options

The icon doesn't show on the taskbar, but Firefox does appear on the Task Manager when I click on it. It probably is as you say, that the window has opened but I can't see it. Clicking "Open New Window" again leads to the same thing. There is no change. I also deleted the two files, but nothing seems to have happened. I have no idea why I can't see the window. Are there any other files that may also have been corrupted? Thanks again.

more options

To add, I mean that when I click on Firefox, I can see it in the "Background Processes" list in Task Manager, not in the list of apps that are active.

more options

Chosen Solution

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link} Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder.
https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac Linux: Check your user manual.

Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.


If there is a problem, start your Computer in safe mode and try again.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

It works, thank you very much. I really appreciate it. :)

more options

Glad to help. Safe Surfing.