Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

cache disable developer

  • 7 replies
  • 1 has this problem
  • 38 views
  • Last reply by John99

more options

When I have the developer tools open and have checked "Disable Cache When tools are open" I expect the cache to be disabled for requests. However, I behavior I see is that the cache is not disabled. hard refreshes don't help either. How can I disable the cache?

When I have the developer tools open and have checked "Disable Cache When tools are open" I expect the cache to be disabled for requests. However, I behavior I see is that the cache is not disabled. hard refreshes don't help either. How can I disable the cache?

Chosen solution

If you use as Private Browsing Window you will not need to clear the cache. If you do need to overide the cache for an individual site reload with Keyboard Shortcut Ctrl+F5

Read this answer in context 👍 1

All Replies (7)

more options

Keep in mind that some extension might overwrite your configuration. Have you tried this https://support.mozilla.org/en-US/questions/905902 ?

more options

So, I thought you might be right and since I'm not willing to give up my password manager, I just abandoned firefox. However, I just installed firefox nightly and with a fresh laptop and fresh installation, disabling of the cache still doesn't work.

more options

It seems to work ok for me on Fx48 Release in Windows 10

Have you tried in Firefox's safemode with all plugins disabled, possibly even in a new profile.

more options

Here is a screenshot with firefox nightly. I've restarted in safe mode, disabled cache when toolbox is open, opened the tools, refreshed google.com and as you can see there the second request returns 302, which is a cache hit.

Changing the address to www.linkedin.com with the tools open I get more cache hits, which I've also included in the images.

more options

it seemed to work as expected before my last post, but when I test again on this forum I see 302s for secure.gravitar.com When I have []Disable Cache unticked I get 302s & many 304s So it does seem to have a very noticeaable effect.

Possibly it is allowing some 302s

What is your use case for this ? You initially asked

How can I disable the cache?

Are you just specifically asking about when using developer tools. Or is this a more general question. I am not sure the relevance of your comment

So, I thought you might be right and since I'm not willing to give up my password manager, I just abandoned firefox.

You can use a private browsing Window, but I note even on that I still get a 302 on the secure.gravitar My knowledge is not good enough to say categorically whether a 302 is always a cache item. I do note

302 Found This is an example of industry practice contradicting the standard. The HTTP/1.0 specification (RFC 1945) required the client to perform a temporary redirect (the original describing phrase was "Moved Temporarily"),[24] but popular browsers implemented 302 with the functionality of a 303 See Other. Therefore, HTTP/1.1 added status codes 303 and 307 to distinguish between the two behaviours.[25] However, some Web applications and frameworks use the 302 status code as if it were the 303.[26] [{https://en.wikipedia.org/wiki/List_of_HTTP_status_codes)]
more options

I'm trying to use firefox as a development browser. I am trying to do my day job on firefox instead of chrome but having to manually clear the cache whenever I make a change absolutely kills the productivity.

more options

Chosen Solution

If you use as Private Browsing Window you will not need to clear the cache. If you do need to overide the cache for an individual site reload with Keyboard Shortcut Ctrl+F5