Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove nested quotes, either automatically, or manually without breaking formatting

  • 11 replies
  • 1 has this problem
  • 58 views
  • Last reply by Matt

more options

When I reply to an HTML email the original message is quoted with colorful bars on the left. This includes multiple levels of bars if the original message was always quoting the previous message. I prefer to reply inline to several messages (I place my response within the quoted text, not above it). This is where the trouble starts.

I remove the embedded quote simply by highlighting it and pressing delete. The problem is this reformats the rest of the quoted message removing all paragraph breaks. I'm left with one long unformatted paragraph.

This feels like a defect. But maybe there's cleanup/remove embedded option I'm not seeing. I'd love to just have the embedded quotes removed by default (all the addons for this appear to work only for text, not HTML).

All Replies (11)

more options

I just hit return to generate a new empty line for my inline reply.

more options

If I go to where I'd like to type first and press enter it works. I however tend to delete the embedded quote first, since it comes first (perhaps force of habit as well).

more options

I think this add-on:

https://freeshell.de/~kaosmos/quoteandcomposemanager-en.html

can remove the coloured bars altogether. I'm not sure how this leaves the reader with respect to telling who wrote what…

more options

Removing the bars altogether isn't really helpful (I tried it). And there is no other option in there to just remove the embedded bars.

more options

stop deleting stuff is probably the real answer. go where you want to reply and press enter get a new line and have at replying.

If you do insist on snipping, remove only whole paragraphs.

more options

I do only delete whole paragraphs. That still results in the rest of the reply being reformatted.

I'm also not going to leave in all the quoted text, that would result in emails that are many levels embedded after just a few replies.

more options

mortoray said

I do only delete whole paragraphs. That still results in the rest of the reply being reformatted. I'm also not going to leave in all the quoted text, that would result in emails that are many levels embedded after just a few replies.

Then get used to having difficulties. That nested quoting is exceedingly complex HTML. Obviously deleting bits of it cause problems. That is what brings you here. Your best bet is hold shift when you hit reply to force plain text. That at least is not nearly as complex.

more options

This confirms that is a defect then. I'll go file an issue for it. Surely the reformatting is not an intended behavior of deleting some text.

more options

It is likely the whole of the quoted section is formatted and so removing a small section and then retyping your response will use the preset formatting.

Try this: Suggest you press enter to get new line and then select 'Preformat' from the first drop down on 'Formatting Bar'. Select whatever colour, font etc you require and type your response.

I find it is just as easy to go to a new line and type the text, then highlight it and select whatever font etc you wish to set.

Modified by Toad-Hall

more options

mortoray said

This confirms that is a defect then. I'll go file an issue for it. Surely the reformatting is not an intended behavior of deleting some text.


I suggest you actually have a look at the HTML involved and the nested blockquotes. I see no simple way to implement what you see as a very simple change