Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I just upgraded to the most recent version of Firefox and am now unable to zoom in and out at all. Has this feature been disabled? How do I get it back?

more options

I just upgraded to the most recent version of Firefox and am now unable to zoom in and out at all. Has this feature been disabled? How do I get it back? I'm using a Mac desktop, running OS X 10.7.5 (Lion, I believe). The Firefox version is 47.0. The zoom buttons still show up but do nothing when I click on them. I've also tried the key commands. Has anyone run into this yet? Any known fixes?

Chosen solution

Do you have any zoom-related extensions installed? You can check on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. Some common ones are (names from memory, I didn't verify them exactly):

  • Default FullZoom Level
  • NoSquint
  • Theme and Font Size Changer
  • Zoom Page

Any of those might modify how the buttons work (and break when Firefox updates...)

Read this answer in context 👍 4

All Replies (11)

more options

NoSquint doesn’t work with Firefox v47 Please try NoSquint Plus Manage site-specific zoom levels and color settings

more options

Or is the problem with Firefox's built-in zoom buttons? Those usually appear on the graphical menu in a format similar to this (if the center button is not 100%, clicking it resets the zoom level to 100%):

- | 100% | +

Modified by jscher2000

more options

Yes, it is with the built-in zoom buttons like you're showing. Mine were set at 90% (I think) before the upgrade. Once I upgraded, they defaulted to 100% and they do nothing when I click on the - (or +).

more options

Chosen Solution

Do you have any zoom-related extensions installed? You can check on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. Some common ones are (names from memory, I didn't verify them exactly):

  • Default FullZoom Level
  • NoSquint
  • Theme and Font Size Changer
  • Zoom Page

Any of those might modify how the buttons work (and break when Firefox updates...)

more options

Apparently, I had NoSquint installed. I don't remember adding that, but I must have ages ago. I disabled it, restarted Firefox, and I am now able to zoom again. All is well again. Thank you soooooo much!!!!! I was dreading having to have everything look huge all the time. You saved me A LOT of frustration!

more options

The NoSquint extension had not been maintained by the author for over three years now. It was luck that it worked as long as it did.

NoSquint Plus is a more up to date version. https://addons.mozilla.org/firefox/addon/nosquint-plus/

There is also the Zoom Page extension you could try. https://addons.mozilla.org/firefox/addon/zoom-page/

more options

NoSquint was installed, but I hadn't used it at all so I can't guarantee that it worked. I didn't even remember that it was there. Once I disabled it and restarted, I looked back up at the response from FredMcD about it. I installed NoSquint Plus, but ended up disabling it, as well. I don't know if the Plus was causing the problem or if it'll still happen again when I navigate around a bit more, but when I'd hop from one screen to another - for example, from an individual email to the inbox once I'd deleted that email - the size wouldn't hold. As of right now, with Plus disabled the size seems to be holding. I'll check out Zoom Page and see if it seems to behave better. Thanks for the help! All three of you! Much appreciated!

more options

The old NoSquint extension (Version 2.1.9.1 and older) has been recently added to the blocklist for Firefox 47.0 and newer users. https://addons.mozilla.org/firefox/blocked/i1232

more options

Good to know. If only that had been done 12 hours ago or so. lol.

more options

orangenbluepuck said

I'll check out Zoom Page and see if it seems to behave better.

You don't need an add-on for zoom unless you want these features:

(1) Set a higher or lower default zoom level for all sites since otherwise you need to zoom them all manually; or (2) Set a default zoom level of fit-to-width

more options

A ha! Now I know why I had NoSquint in the first place! I keep everything at 90% and it's killing me right now that every new tab I open is opening at 100%. I must've had NoSquint set to a 90% default. I guess that I WAS using it... every single day! I'm not sure about a zoom level for the fit-to-width. My facebook home page is not looking right in that regard so I might've adjusted that single page. I haven't noticed any other pages looking "off" width-wise, though. I hadn't started to fiddle with the facebook page settings yet. I wasn't making it a high priority. The overall zoom was a major priority for me. I couldn't function!

I thought that I'd added NoSquint to use for individual pages that wouldn't let me zoom for one reason or another. That was why I was going to look at Zoom Page - to have in case I ran into a page like that. Now, I guess that I actually need it, or something similar. Thanks for explaining that.