Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is there a setting for blocking Location requests?

  • 13 replies
  • 6 have this problem
  • 1407 views
  • Last reply by metapunk

more options

I've checked every box short of private browsing and when I visit a franchise store website they all ask for my location. I have to block it manually. Is there a way to block it automatically while not using private browsing? I also block third party tracking and use a variety of ad blockers and nothing seems to stop it.

Chosen solution

Does it happen so often that choosing Never on a site-by-site basis (see attached screen shot) is impractical?

Sites usually geolocate you quietly in the background based on your IP address. If you give permission for Firefox to provide your location, Firefox can use Google APIs to provide a location based on wi-fi hotspots detected nearby. On a mobile device with GPS, I assume Firefox can get GPS coordinates from the system, which would be the most precise method.

While you can completely turn off location, we've seen reports of at least one site that doesn't render content correctly in that case (Weather Channel). To do it anyway:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste geo. and pause while the list is filtered

(3) Double-click the geo.enabled preference to switch it from true to false

Read this answer in context 👍 8

All Replies (13)

more options

You can use an addons called Location Guard. Addons link here

more options

Is there any way to disable the window that pops up to ask for my location?

more options

Hi, to do it for all sites, type about:permissions into the address bar and press Enter, then change Share Location to Block.

To do it on a per site basis, see under 'Permissions' in Firefox Page Info window

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

more options

The address isn't valid

The URL is not valid and cannot be loaded.

   Web addresses are usually written like http://www.example.com/
   Make sure that you're using forward slashes (i.e. /).
more options

Are you saying that about:permissions doesn't take you to the Permissions Manager? It isn't a web address, but should take you to the Firefox Permissions Manager. Please copy and paste it from this reply and see if it works.

More: Permissions Manager - Give certain websites the ability to store passwords, set cookies and more

Modified by Scribe

more options

Isn't the addons working...?

more options

I copied last time too. Same thing:

The address isn't valid

The URL is not valid and cannot be loaded.

   Web addresses are usually written like http://www.example.com/
   Make sure that you're using forward slashes (i.e. /).
more options

The addon still does not stop the Location Dialog box from coming up, and the one time I tried it, it gave up my location, pretty accurately in fact. I set it to high with a fixed location.

Modified by metapunk

more options

Chosen Solution

Does it happen so often that choosing Never on a site-by-site basis (see attached screen shot) is impractical?

Sites usually geolocate you quietly in the background based on your IP address. If you give permission for Firefox to provide your location, Firefox can use Google APIs to provide a location based on wi-fi hotspots detected nearby. On a mobile device with GPS, I assume Firefox can get GPS coordinates from the system, which would be the most precise method.

While you can completely turn off location, we've seen reports of at least one site that doesn't render content correctly in that case (Weather Channel). To do it anyway:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste geo. and pause while the list is filtered

(3) Double-click the geo.enabled preference to switch it from true to false

more options

That worked perfectly. Thank You.

about:config

more options

Note that support for about:permissions has been removed in Firefox 45+ versions, so you can no longer use this page to inspect the permissions for all websites.

more options

Now they have figured out a way to bypass this function and I'm being tracked again. Any other options for disabling automatic geolocation?

more options

I have to basically block everything from mail.com for this to work so I did.