Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Shows odd script when accessing Facebook

  • 5 replies
  • 1 has this problem
  • 18 views
  • Last reply by Slate

more options

My mothers ASUS laptop with Windows 10 recently started to show a script like page when access facebook on firefox. This always happens the first time the page is accessed after firefox is launched and again sometimes randomly. This does not appear to affect any other browser. So far I have tried to remove firefox and reinstall. Delete all cookies and saved information. Ran a virus scan with Kaspersky Ran a Malware Scan with Malwarebytes. Neither scan came up with any virus/malware.

Any suggestions.

Chosen solution

Users toward the end of the Kaspersky forum thread indicated that Kaspersky has patched this problem and if you (A) update Kaspersky and (B) clear cache (see: How to clear the Firefox cache), then it should work again. Success?


If you still need a workaround and you want to keep Kaspersksy's intercept-and-filter feature running, you can set Firefox NOT to tell sites it can read Brotli encoding. I suspect this won't slow your browsing down very much. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste enco and pause while the list is filtered

(3) Double-click the network.http.accept-encoding.secure preference and edit as follows: delete the , br from the end so it just reads gzip, deflate like the preference above it in the list, and then click OK

Reference for this preference change working for another Kaspersky user: https://twitter.com/lildingus/status/730493386461982720

Read this answer in context 👍 3

All Replies (5)

more options

Here's an image

more options

Firefox 44+ accepts a new kind of encoding (compression) called Brotli (br) for secure connections and Facebook turned on Brotli encoding recently.

Kapsersky doesn't know about this encoding and strips it from the HTTP response headers if you have "Inject script" checked in Kapsersky Settings -> Additional -> Network -> Traffic Processing

https://forum.kaspersky.com/index.php?s=bbdfcf797a91bc90230472c52c4b103e&showtopic=351027

more options

Hi

I recommend you follow this article which will help you to fix this.

I hope this helps but if not, please come back here and we can look into a different solution for you.

more options

Chosen Solution

Users toward the end of the Kaspersky forum thread indicated that Kaspersky has patched this problem and if you (A) update Kaspersky and (B) clear cache (see: How to clear the Firefox cache), then it should work again. Success?


If you still need a workaround and you want to keep Kaspersksy's intercept-and-filter feature running, you can set Firefox NOT to tell sites it can read Brotli encoding. I suspect this won't slow your browsing down very much. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste enco and pause while the list is filtered

(3) Double-click the network.http.accept-encoding.secure preference and edit as follows: delete the , br from the end so it just reads gzip, deflate like the preference above it in the list, and then click OK

Reference for this preference change working for another Kaspersky user: https://twitter.com/lildingus/status/730493386461982720

more options

jscher2000 said

Users toward the end of the Kaspersky forum thread indicated that Kaspersky has patched this problem and if you (A) update Kaspersky and (B) clear cache (see: How to clear the Firefox cache), then it should work again. Success?

Success! The update must have been very recent as I requested an update last night and none were found! I'm glad this didn't end and some odd work arounds like others posted. Thank you!

Modified by Slate