Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox asks me to reconnect to sync every time I start firefox on Fedora 23

  • 4 replies
  • 10 have this problem
  • 1147 views
  • Last reply by rathm

more options

I use Firefox on several devices. On Windows 7 and 10 Sync works well. On Fedora 23 I need to reconnect to Sync every time I start Firefox See attached screenshots

Attached screenshots

Chosen solution

Do you see the chrome://FirefoxAccounts entry in the Password Manager?

Without this authentication data is it impossible to reconnect to Sync automatically.

Read this answer in context 👍 2

All Replies (4)

more options

The Sync version used in Firefox 34+ releases uses the password manager to store the authentication data that is used to connect to the Sync server. When Firefox is started you need to enter the master password to be able to connect to Sync. The chrome://FirefoxAccounts entry in the password manager stores the authentication data (kA and kB) in JSON format. The signedInUser.json file in the profile folder stores the sessionToken that is used once you have logged on successfully. If this data is lost or gets corrupted then you will have to reconnect to Sync.

more options

Thanks cor-el for your prompt response. I do not save passwords on Firefox so do not have a master password set up. Sync works fine on Windows 7 and 10 using the same Sync account. I already cleaned files you mentioned and re-installed Firefox on Fedora. Problem occurs again.

Any idea why this happens on Linux and on Windows?

more options

Chosen Solution

Do you see the chrome://FirefoxAccounts entry in the Password Manager?

Without this authentication data is it impossible to reconnect to Sync automatically.

more options

Thanks for the details.

There was no chrome://FirefoxAccounts entry in the Password Manager. I disconnected my Sync account, refreshed Firefox and the entry appeared.

Any idea why the entry went missing? I Know from experience that refreshing or re-installing Firefox solves the problem, but would prefer to solve the root cause.