X
Tap here to go to the mobile version of the site.

Support Forum

Created a signature with an image. See it when I compose but recipient can't.

Posted

Followed the instructions to create a signature that has both text and a picture inserted. When I compose the message, I can see both the text and the picture. However, the recipient can only see the text. Attached is a screenshot of my settings.

Followed the instructions to create a signature that has both text and a picture inserted. When I compose the message, I can see both the text and the picture. However, the recipient can only see the text. Attached is a screenshot of my settings.
Attached screenshots

Chosen solution

Received second email showing outlined boxes where images should be. The source code shows you are now sending in Plain Text and HTML, so that is now correct. It also shows you have selected to use an image you have stored in your 'downloads' folder and that is ok except I'm not sure how you organise images stored on your computer, but the location is ok providing you are aware that you cannot move it about or delete it without having the signature file fail. I have created a special folder called 'Signatures' (in 'Documents - not Thunderbird) and it contains any images I use in signatures and also the saved html files, which I use as actual signatures in thunderbird. So I have everything together and I keep the Downloads folder for anything downloaded but not necessarilly organised or that is the best location.

However, getting back to the matter in hand.... the source code shows no actual images were selected to be included in the signature only the file location, so you need to have a look at the following as I believe you have not selected to attach the image. Notice I have highlighted this line in the instructions below: Select: 'Attach this image to the message', you must select that option. In this situation, it is not attaching an attachment eg: a document, but attaching the actual image as well as the source info to the signature file. Usually, it is auto enabled, so maybe you have deselected it misunderstanding it's purpose.

As this webpage could be seen by anyone needing help, I have added the fuller instructions, even though you probably know most already.

How to create signature with image.

  • click on 'Write' to open new write message
  • Select all formatting even if already auto selected by default settings.
  • Type signature eg: Regards and name
  • 'Insert' > 'Image'
  • Select: 'Attach this image to the message'
  • click on 'Choose file' button
  • locate an image you created that has been saved in a folder on my computer eg: Documents\Signature Folder - not saved in any Thunderbird folder.
  • Click on 'Open' - Image should be shown in the small 'Image preview' box.
  • Select: 'Don't use alternate text' or type in 'alternate text'

Options to Adjust the dimensions of image to suit

  • Click on 'Dimensions' tab
  • Select: 'Custom size' and 'Constrain'
  • Change width to eg: 200 pixels - Height is auto adjusted

Option to Set image to be a clickable link:

  • Click on 'OK' to insert the image.


Save file to a folder on computer. You will need to select "HTML Files" in the "Save as type" list box. It must be saved as HTML file. Close the Write window.

Attach the HTML signture file:

  • Tools > Account Settings of mail account
  • Select ; 'Attach the signature from a file instead'
  • Clickon 'Choose' button
  • locate the html signature file and click on 'Open'
  • Click on 'OK'
Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

More Information

Zenos 2265 solutions 12258 answers

You haven't shown us the signature text.

Where is the image file located? Is the signature declaration set to include the image file into the signature?

If you're sending a link to the picture, and the picture file is located on your own computer then yes, you will see it but your correspondents won't. You need to host it where they can get to it, on an internet-connected server, or make sure the file is included with the signature. If you compose your signature as advised by creating it using Thunderbird as the text editor, then when you insert the image, you'll see an option to attach the image file.

You haven't shown us the signature text. Where is the image file located? Is the signature declaration set to include the image file into the signature? If you're sending a link to the picture, and the picture file is located on your own computer then yes, you will see it but your correspondents won't. You need to host it where they can get to it, on an internet-connected server, or make sure the file is included with the signature. If you compose your signature as advised by creating it using Thunderbird as the text editor, then when you insert the image, you'll see an option to attach the image file.

Question owner

I opened up a new email and inserted text and two images and then saved it as an html file according to directions on Mozilla's site for creating an image signature file. So it is saved to my hard drive. It said as long as it was saved in the manner they described, the recipient should be able to receive it even without being online. Here is the article I used to create it: https://support.mozilla.org/en-US/kb/signatures

I opened up a new email and inserted text and two images and then saved it as an html file according to directions on Mozilla's site for creating an image signature file. So it is saved to my hard drive. It said as long as it was saved in the manner they described, the recipient should be able to receive it even without being online. Here is the article I used to create it: https://support.mozilla.org/en-US/kb/signatures
Toad-Hall
  • Top 10 Contributor
1763 solutions 11859 answers

Helpful Reply

Please send me an email using your signature to:

  • mail at anje dot co dot uk

I do not use the email address as correspondence, but in your case it may assist in looking at what the code is generating. I will post any findings back in this forum question.

Please send me an email using your signature to: * '''mail at anje dot co dot uk''' I do not use the email address as correspondence, but in your case it may assist in looking at what the code is generating. I will post any findings back in this forum question.
Toad-Hall
  • Top 10 Contributor
1763 solutions 11859 answers

Thanks for email.

the first thing I can tell is you are not sending in HTML, you appear to be only sending in Plain Text.

So check these settings and then resend another email to me.

'Tools' > 'Options' > 'Composition' > 'General' tab OR 'Menu icon' > Options' > 'Options' > 'Composition' > 'General' tab

click on 'Send Options' button Text format Select 'Send messages as plain text if possible' From drop down - Select: 'Send the message in both plain text and HTML' click on all OK's

Did you have those settings? Did you need to modify the settings?

Confirm you are writing in HTML format. Right click on mail account name in Folder Pane and select: 'Settings' click on 'Composition & Addressing' for that account Select: 'Compose messages in HTML' click on OK

Thanks for email. the first thing I can tell is you are not sending in HTML, you appear to be only sending in Plain Text. So check these settings and then resend another email to me. 'Tools' > 'Options' > 'Composition' > 'General' tab OR 'Menu icon' > Options' > 'Options' > 'Composition' > 'General' tab click on 'Send Options' button Text format Select 'Send messages as plain text if possible' From drop down - Select: 'Send the message in both plain text and HTML' click on all OK's Did you have those settings? Did you need to modify the settings? Confirm you are writing in HTML format. Right click on mail account name in Folder Pane and select: 'Settings' click on 'Composition & Addressing' for that account Select: 'Compose messages in HTML' click on OK
Toad-Hall
  • Top 10 Contributor
1763 solutions 11859 answers

Chosen Solution

Received second email showing outlined boxes where images should be. The source code shows you are now sending in Plain Text and HTML, so that is now correct. It also shows you have selected to use an image you have stored in your 'downloads' folder and that is ok except I'm not sure how you organise images stored on your computer, but the location is ok providing you are aware that you cannot move it about or delete it without having the signature file fail. I have created a special folder called 'Signatures' (in 'Documents - not Thunderbird) and it contains any images I use in signatures and also the saved html files, which I use as actual signatures in thunderbird. So I have everything together and I keep the Downloads folder for anything downloaded but not necessarilly organised or that is the best location.

However, getting back to the matter in hand.... the source code shows no actual images were selected to be included in the signature only the file location, so you need to have a look at the following as I believe you have not selected to attach the image. Notice I have highlighted this line in the instructions below: Select: 'Attach this image to the message', you must select that option. In this situation, it is not attaching an attachment eg: a document, but attaching the actual image as well as the source info to the signature file. Usually, it is auto enabled, so maybe you have deselected it misunderstanding it's purpose.

As this webpage could be seen by anyone needing help, I have added the fuller instructions, even though you probably know most already.

How to create signature with image.

  • click on 'Write' to open new write message
  • Select all formatting even if already auto selected by default settings.
  • Type signature eg: Regards and name
  • 'Insert' > 'Image'
  • Select: 'Attach this image to the message'
  • click on 'Choose file' button
  • locate an image you created that has been saved in a folder on my computer eg: Documents\Signature Folder - not saved in any Thunderbird folder.
  • Click on 'Open' - Image should be shown in the small 'Image preview' box.
  • Select: 'Don't use alternate text' or type in 'alternate text'

Options to Adjust the dimensions of image to suit

  • Click on 'Dimensions' tab
  • Select: 'Custom size' and 'Constrain'
  • Change width to eg: 200 pixels - Height is auto adjusted

Option to Set image to be a clickable link:

  • Click on 'OK' to insert the image.


Save file to a folder on computer. You will need to select "HTML Files" in the "Save as type" list box. It must be saved as HTML file. Close the Write window.

Attach the HTML signture file:

  • Tools > Account Settings of mail account
  • Select ; 'Attach the signature from a file instead'
  • Clickon 'Choose' button
  • locate the html signature file and click on 'Open'
  • Click on 'OK'
Received second email showing outlined boxes where images should be. The source code shows you are now sending in Plain Text and HTML, so that is now correct. It also shows you have selected to use an image you have stored in your 'downloads' folder and that is ok except I'm not sure how you organise images stored on your computer, but the location is ok providing you are aware that you cannot move it about or delete it without having the signature file fail. I have created a special folder called 'Signatures' (in 'Documents - not Thunderbird) and it contains any images I use in signatures and also the saved html files, which I use as actual signatures in thunderbird. So I have everything together and I keep the Downloads folder for anything downloaded but not necessarilly organised or that is the best location. However, getting back to the matter in hand.... the source code shows no actual images were selected to be included in the signature only the file location, so you need to have a look at the following as I believe you have not selected to attach the image. Notice I have highlighted this line in the instructions below: ''Select: 'Attach this image to the message','' you must select that option. In this situation, it is not attaching an attachment eg: a document, but attaching the actual image as well as the source info to the signature file. Usually, it is auto enabled, so maybe you have deselected it misunderstanding it's purpose. As this webpage could be seen by anyone needing help, I have added the fuller instructions, even though you probably know most already. '''How to create signature with image.''' * click on 'Write' to open new write message * Select all formatting even if already auto selected by default settings. * Type signature eg: Regards and name * 'Insert' > 'Image' * '''Select: 'Attach this image to the message'''' * click on 'Choose file' button * locate an image you created that has been saved in a folder on my computer eg: Documents\Signature Folder - not saved in any Thunderbird folder. * Click on 'Open' - Image should be shown in the small 'Image preview' box. * Select: 'Don't use alternate text' or type in 'alternate text' '''Options to Adjust the dimensions of image to suit''' * Click on 'Dimensions' tab * Select: 'Custom size' and 'Constrain' * Change width to eg: 200 pixels - Height is auto adjusted '''Option to Set image to be a clickable link:''' * Click on 'Link' tab * Enter url: eg: http://www.anje.co.uk * Click on 'OK' to insert the image. Save file to a folder on computer. You will need to select "HTML Files" in the "Save as type" list box. It must be saved as HTML file. Close the Write window. '''Attach the HTML signture file:''' * Tools > Account Settings of mail account * Select ; 'Attach the signature from a file instead' * Clickon 'Choose' button * locate the html signature file and click on 'Open' * Click on 'OK'

Modified by Toad-Hall

Question owner

That worked!!! I somehow missed one or two steps the first time around. These instructions were great! Thank you so much!

That worked!!! I somehow missed one or two steps the first time around. These instructions were great! Thank you so much!
Toad-Hall
  • Top 10 Contributor
1763 solutions 11859 answers

Received third email and can confirm that all is now working as expected. Images are clearly visible.

Good to hear all is now working correctly.

Received third email and can confirm that all is now working as expected. Images are clearly visible. Good to hear all is now working correctly.