Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable the Firefox 45.0.1 "insecure connection" popup warning.

  • 4 replies
  • 47 have this problem
  • 7984 views
  • Last reply by marknarayn

more options

I have started to get a popup warning. First it was when I visited secure pages, but now it happens whenever I open a new tab! The warning is: "The information you have entered on this page will be sent over an insecure connection and could be read by a third party". How can I turn this off? I'm using Firefox 45.0.1 on a Mac with Yosemite 10.10.5. Thanks in advance!

Chosen solution

I don't have an account on Wikispaces but I looked at the Sign In on the home page and it seems okay from a brief inspection. Are you going in directly through the home page or though a particular part of the site?

Read this answer in context 👍 2

All Replies (4)

more options

That message should only display in a very specific situation:

  • You are on a secure page (https address)
  • You are submitting a form
  • The URL the form is submitting to is on an insecure page (http address)

Most sites are properly designed to go from secure to secure; this message should be very rare. However, if you are "forcing" HTTPS using an add-on such as HTTP Everywhere, it's possible that the form submit address was not also switched and that is causing the site to behave this way.

Does that seem like a possibility? Do you want to give the URLs of a couple sites that give you this error?

(Several users reported a problem with Microsoft's MSDN site, that if you were logged into your Microsoft account, you would get an error like this all the time due to the way MSDN authenticated you. I don't know if that is still an issue on that site.)

Regarding the new tab page, it's a little odd to get that particular message because you normally are not submitting a form when you open that page. Maybe it's this: if Firefox was unable to capture a thumbnail image of the page on your last visit, it may try to get the image by loading it in the background while displaying the new tab page. If you zoom out to show all of the 15 tiles Firefox tries to generate for the page (Cmd- or using the menu), do you see any blank ones that you don't want or need on the page? "X" those off to block them from the new tab page and hopefully that will resolve the issue there.

more options

The first url it started on was: http://www.pageone.co.uk/services/janet-txt which seemed odd as it's not a secure address. Logging in there also produced it. I also got the message on three other sites, including when logging into Wikispaces.

It was after this that I started getting the warning popping up whenever I opened a new tab, so your thought that it might be one of the thumbnails sounded pretty likely.

To test it, I cleared the cache then did as you suggested, and got rid of several thumbnails and that seems to have solved the new tab problem - thanks!

I still get it when logging into Wikispaces, but the pageone site is now OK (not sure why!) It seemed odd that it suddenly started happening on a site I've been using for ages. But it seems to now just be on wikispaces, which is far more manageable. Thank you very much for your help.

more options

Chosen Solution

I don't have an account on Wikispaces but I looked at the Sign In on the home page and it seems okay from a brief inspection. Are you going in directly through the home page or though a particular part of the site?

more options

I was going through an invitation link which took me to the secure URL for logging in. I've gone to several other secure pages I usually use, and all seem OK now. So it's just that one link, which is: http://tepwikisk2.wikispaces.com/space/join?hash=5WlYotQRMZ735IuSzHLjpv I don't need to use it anymore, so it's not a problem.

What I don't understand is why the PageOne link: http://www.pageone.co.uk/services/janet-txt would have suddenly caused this problem. Just curiosity now, as the problem was solved by deleting the thumbnails, as you suggested.

Thanks again for your help!