X
Tap here to go to the mobile version of the site.

Support Forum

Firefox won't open Google

Posted

Following a recent update, Firefox will no longer access Google (or any web page via Google.) I get the following error message:

Your connection is not secure

The owner of www.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Learn more…

www.google.com uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported.

Error code: SEC_ERROR_UNKNOWN_ISSUER

My computer has a Windows 7 OS installed, and I have not previously had any problems like this. I tried to add an exception and the result I got is shown in the screenshot below.

Following a recent update, Firefox will no longer access Google (or any web page via Google.) I get the following error message: Your connection is not secure The owner of www.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate. Learn more… www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. Error code: SEC_ERROR_UNKNOWN_ISSUER My computer has a Windows 7 OS installed, and I have not previously had any problems like this. I tried to add an exception and the result I got is shown in the screenshot below.

Chosen solution

Usually that is caused by the program BrowserSafe or Browser Safeguard, which you should uninstall for your security. Can you track that down?

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.10
  • ArchiCAD 16.0.0 (3006) INT Component
  • Citrix Receiver Plugin (Win32)
  • GEPlugin
  • Version 5.41.3.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • 5.1.40728.0
  • Windows Activation Technologies Plugin for Mozilla
  • iTunes Detector Plug-in

Application

  • Firefox 45.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0.1/WINNT/en-US/

Extensions

  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce GT 555M
  • adapterDeviceID: 0x0126
  • adapterDeviceID2: 0x124d
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 3072
  • adapterSubsysID: 05711028
  • adapterSubsysID2: 05711028
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 7-19-2011
  • driverDate2: 12-19-2013
  • driverVersion: 8.15.10.2455
  • driverVersion2: 9.18.13.3221
  • info: {u'AzureContentBackend': u'direct2d 1.1', u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23378 answers

Hi roramc, please see if the steps described in How to troubleshoot security error codes on secure websites can help you solve this issue.

Hi roramc, please see if the steps described in [[How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites]] can help you solve this issue.

Helpful Reply

I tried that, with no luck. Any other ideas?

I tried that, with no luck. Any other ideas?
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23378 answers

So which security tool are you using on your device?

So which security tool are you using on your device?

Question owner

Just the Windows security.

Just the Windows security.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

You can try using this internal page to test Google to see whether you can gather more information on the problem.

Paste the following into the address bar and press Enter to load it:

chrome://pippki/content/exceptionDialog.xul

Then enter https://www.google.com/ and click Get Certificate. If possible, then click View. Anything unusual in the "Issued By" area? I have attached what I see for comparison.

If Firefox doesn't allow checking the certificate, try another browser. Usually clicking the padlock icon in the address bar will show a link to view the certificate. On Chrome, you first need to click Connection on the drop-down.

You can try using this internal page to test Google to see whether you can gather more information on the problem. Paste the following into the address bar and press Enter to load it: chrome://pippki/content/exceptionDialog.xul Then enter https://www.google.com/ and click Get Certificate. If possible, then click View. Anything unusual in the "Issued By" area? I have attached what I see for comparison. If Firefox doesn't allow checking the certificate, try another browser. Usually clicking the padlock icon in the address bar will show a link to view the certificate. On Chrome, you first need to click Connection on the drop-down.

Question owner

This is what I get when I do that:

This is what I get when I do that:
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Chosen Solution

Usually that is caused by the program BrowserSafe or Browser Safeguard, which you should uninstall for your security. Can you track that down?

Usually that is caused by the program BrowserSafe or Browser Safeguard, which you should uninstall for your security. Can you track that down?

Question owner

Hooray! That fixed it! Thank you so much for your help!!

Hooray! That fixed it! Thank you so much for your help!!