Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pdf files uploaded with Firefox 45 marked as unknown in Google Drive

  • 2 replies
  • 41 have this problem
  • 46 views
  • Last reply by Markuus

more options

Hello, I have a problem uploading a pdf file in either Google Drive or a web form using Firefox 45.0 Mozilla Firefox for Linux Mint mint-1.0 . My SO is Mint 17.3. Google Drive mark as "unknow" the file pdf uploaded and it's not possible to open it. Web forms where I try to upload files pdf shows error message "this is not a pdf file".

In the screenshot attached to this support you can clearly see file "test 2 firefox 45.pdf" reported as unknown file.

Files "test2" and "test 2 mint" are pdf created in Mint, uploaded via Firefox 38 with SO Debian.

The same files uploaded via Firefox 45 in OneDrive works perfectly.

Any suggestions are welcome.

Thank you.

Attached screenshots

Chosen solution

Sometimes Firefox will send websites the wrong content-type for an upload if this settings file has become corrupted: mimeTypes.rdf

Could you try this:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit / Quit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old.

Start Firefox back up again. Does the Google Drive upload work any better?


References:

Read this answer in context 👍 21

All Replies (2)

more options

Chosen Solution

Sometimes Firefox will send websites the wrong content-type for an upload if this settings file has become corrupted: mimeTypes.rdf

Could you try this:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit / Quit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old.

Start Firefox back up again. Does the Google Drive upload work any better?


References:

Modified by jscher2000 - Support Volunteer

more options

Thanks jscher2000 Your solution helped a lot.

In Firefox 45 you can find Open Directory under Application Basic -> Profile Directory -> Open Directory

But, in my MINT 17, when you click the tab it open Package Installer and show gdebi-gtk message " Could not open 'mwad0hks.default' The package might be corrupted or you are not allowed to open the file. Check the permission of the file.

Well, no problem. For Linux users there is a easy way.

Clean Firefox history and close Firefox, - then go in your Home Folder, - show hidden files ( ctrl + h or click View tab -> Show Hidden Files ) - find and open folders .Mozilla -> Firefox -> mwad0hks.default.

You can find mimeTypes.rdf and rename to mimeTypes.old

This worked for my problem.

Thanks again.

Modified by Markuus