X
Tap here to go to the mobile version of the site.

Support Forum

Get rid of this please. It's a pain in the ass. Everytime i go to YAHOO i get it -- "The information you have entered on this page will be sent over an insecu

Posted

Security warning: The information you have entered on this page will be sent over an insecure connection and could be read by a third party. Please get rid of this. It's a real pain in the ass. It's HTTPS!!!!!

Security warning: The information you have entered on this page will be sent over an insecure connection and could be read by a third party. Please get rid of this. It's a real pain in the ass. It's HTTPS!!!!!

Modified by cor-el

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Citrix Online App Detector Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.73.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • McAfee Virtual Technician plugin
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • VLC media player Web Plugin
  • WildTangent Games App V2 Presence Detector
  • thinkorswim loader
  • thinkDesktop configuration loader

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

jscher2000
  • Top 10 Contributor
8214 solutions 67167 answers

Actually, Firefox would not give that particular message if the form was submitting from HTTPS to HTTPS. There must be a detour through HTTP somewhere.

Could you spell out in more detail the steps to generate that message? For starters which of these pages are you using:

https://www.yahoo.com/ https://search.yahoo.com/ https://my.yahoo.com/ (some other Yahoo page)

And then, are you just using the search box normally?


When you have a problem with one particular site that previously worked fine, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Actually, Firefox would not give that particular message if the form was submitting from HTTPS to HTTPS. There must be a detour through HTTP somewhere. Could you spell out in more detail the steps to generate that message? For starters which of these pages are you using: https://www.yahoo.com/ https://search.yahoo.com/ https://my.yahoo.com/ (some other Yahoo page) And then, are you just using the search box normally? ---- When you have a problem with one particular site that previously worked fine, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click a blank area of the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or globe icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?

Question owner

Step by Step:

  1. 1-In address bar, type: Yahoo finance earnings.

This will take you to a page that says "Yahoo Finance earnings calendar".

  1. 2-In the "Get Quotes" box type a stock symbol, i.e, ADBE
  2. 3- When you type a stock symbol and hit enter here is the message:

SECURITY WARNING The information you have entered on this page will be sent over an insecure connection and could be read by a third party.

Are you sure you want to send this information?

If you use this page 30X a day, this message is a nuisance. Every page is HTTPS and there is no OPTION that says "Don't show this message again".

I have this problem on other websites as well.

Just cleared cache - did NOTHING. Still have the problem

Step by Step: #1-In address bar, type: Yahoo finance earnings. This will take you to a page that says "Yahoo Finance earnings calendar". #2-In the "Get Quotes" box type a stock symbol, i.e, ADBE #3- When you type a stock symbol and hit enter here is the message: SECURITY WARNING The information you have entered on this page will be sent over an insecure connection and could be read by a third party. Are you sure you want to send this information? If you use this page 30X a day, this message is a nuisance. Every page is HTTPS and there is no OPTION that says "Don't show this message again". I have this problem on other websites as well. Just cleared cache - did NOTHING. Still have the problem

Modified by abcdefg123456

jscher2000
  • Top 10 Contributor
8214 solutions 67167 answers

I'm not sure why Yahoo is doing this, but the form on this page:

https://biz.yahoo.com/research/earncal/today.html

does submit to this page:

http://finance.yahoo.com/q

Secure to insecure.

It does work to submit to:

https://finance.yahoo.com/q

So one possible workaround would be to hack the form from http to https using an add-on. Or inject a script that creates a link for the new page next to the submit button, since Firefox doesn't give a secure-to-insecure warning for links. Those would be site-specific approaches rather than a general solution, but it's all that comes to mind at the moment.

Can't build that right now but I'll look into it this evening.

Would it be useful to direct the form results/link to a new tab instead of the same tab? Less going "back"?

I'm not sure why Yahoo is doing this, but the form on this page: https://biz.yahoo.com/research/earncal/today.html does submit to this page: http://finance.yahoo.com/q Secure to insecure. It does work to submit to: https://finance.yahoo.com/q So one possible workaround would be to hack the form from http to https using an add-on. Or inject a script that creates a link for the new page next to the submit button, since Firefox doesn't give a secure-to-insecure warning for links. Those would be site-specific approaches rather than a general solution, but it's all that comes to mind at the moment. Can't build that right now but I'll look into it this evening. Would it be useful to direct the form results/link to a new tab instead of the same tab? Less going "back"?

Modified by jscher2000

jscher2000
  • Top 10 Contributor
8214 solutions 67167 answers

This user script will fix the form on each visit to the page: https://greasyfork.org/en/scripts/18122-yahoo-finance-https-to-https-form-submit

To use that, you first need to install the Greasemonkey extension: https://addons.mozilla.org/firefox/addon/greasemonkey/

This user script will fix the form on each visit to the page: https://greasyfork.org/en/scripts/18122-yahoo-finance-https-to-https-form-submit To use that, you first need to install the Greasemonkey extension: https://addons.mozilla.org/firefox/addon/greasemonkey/

Question owner

It works! Excellent! Thanks!

EDIT: (20 minutes later) Oh noooooo! I just went to another website I use and now THAT website is messed up. EVERY TIME I hit the back button, here's the message I get:

"Confirm" "To display this page, Firefox must send information that will repeat any action (such as a search or order confirmation) that was performed earlier." Resend or Cancel"

SAME problem! If I use this (other) website 30X/day and have to hit the back arrow, I'm gonna get this message 30X/day. And again, there is no choice that says, "Don't show this message again". The choices are only "Resend" or "Cancel". So, now, if I hit the back arrow 30X, I'll have to hit "Resend" 30X.

It works! Excellent! Thanks! EDIT: (20 minutes later) Oh noooooo! I just went to another website I use and now THAT website is messed up. EVERY TIME I hit the back button, here's the message I get: "Confirm" "To display this page, Firefox must send information that will repeat any action (such as a search or order confirmation) that was performed earlier." Resend or Cancel" SAME problem! If I use this (other) website 30X/day and have to hit the back arrow, I'm gonna get this message 30X/day. And again, there is no choice that says, "Don't show this message again". The choices are only "Resend" or "Cancel". So, now, if I hit the back arrow 30X, I'll have to hit "Resend" 30X.

Modified by abcdefg123456

jscher2000
  • Top 10 Contributor
8214 solutions 67167 answers

What's the other site -- can you give a link?

Firefox normally caches web pages even when sites instruct Firefox not to store them, so you can go back quickly without a reload. However, there are a few cases where Firefox will not cache the page, and you get that informative (?!) message when you try to go back to it.

I don't know of a way to bypass that message, but the most common workaround would be to Ctrl+click or middle-click links to launch them in a new tab so that you do not need to use the Back button. There might be other workarounds depending on the site.

What's the other site -- can you give a link? Firefox normally caches web pages even when sites instruct Firefox not to store them, so you can go back quickly without a reload. However, there are a few cases where Firefox will not cache the page, and you get that informative (?!) message when you try to go back to it. I don't know of a way to bypass that message, but the most common workaround would be to Ctrl+click or middle-click links to launch them in a new tab so that you do not need to use the Back button. There might be other workarounds depending on the site.