Search Support

How to type ipv6-address and port number in URL bar?

  • 2 replies
  • 10 have this problem
  • 58795 views
  • Last reply by mmorbitzer

more options

I have a Tomcat server which I would like to visit via it's IPv6 address.

In IPv4, I would simply type http://<ipv4-address>:8080 in the URL bar.

In IPv6, I can't seem to find out what I have to type in the URL bar - every request I make sends me to my default search engine.

Among others, I tried the following:

http://[<ipv6-address>]:8080

http://[<ipv6-address>%eth0]:8080

To my understanding of RFC 5952, this should do the job.

However, also skipping the destination port doesn't seem to send me to the server on port 80 or 443:

http://<ipv6-address>

https://<ipv6-address>

I've even tried to add the host in my /etc/hosts, with any of those lines:

<ipv6-address>%eth0 foo

<ipv6-address> bar

Still, requests such as

http://[foo]:8080

http://foo:8080

http://[bar]:8080

http://bar:8080

also don't seem to work.

Firefox version in use is 44.0.2

Thanks for your help!

Modified by mmorbitzer

Chosen solution

Yes, IPv6 is enabled.

Unfortunately, http://[<ipv6-address>]:8080 does not work. I tried to restart firefox without plugins to make sure that things like FoxyProxy don't come in the way, but that also didn't solve the problem.

I checked in wireshark, and I don't see a connection attempt from firefox to the webserver.

I also tried to switch on HTTP logging. When I look for the ipv6 address in the logfile, I see those messages:


-1825077376[7f4391f38580]: AltSvcCache::GetAltServiceMapping 7f4377528108 key=http:fe80::20c:29ff:fee2:1de:8080:. existing=0 validated=0 running=0 ttl=0
-1825077376[7f4391f38580]:   Host: [fe80::20c:29ff:fee2:1de]:8080
-1825077376[7f4391f38580]: host=fe80::20c:29ff:fee2:1de port=8080
-1825077376[7f4391f38580]:   Host is IP Literal [fe80::20c:29ff:fee2:1de].
-1825077376[7f4391f38580]: nsHttpAuthCache::GetAuthEntryForPath [key=http://fe80::20c:29ff:fee2:1de:8080 path=/]
-1825077376[7f4391f38580]: nsHttpConnectionMgr::SpeculativeConnect [ci=......fe80::20c:29ff:fee2:1de:8080]
-1825077376[7f4391f38580]: nsHttpConnectionMgr::SpeculativeConnect skipping RFC1918 address [fe80::20c:29ff:fee2:1de]
-1825077376[7f4391f38580]: Resolving host [fe80::20c:29ff:fee2:1de].
-1825077376[7f4391f38580]: uri=http://[fe80::20c:29ff:fee2:1de]:8080/
-2133858560[7f4391f38c40]: Creating nsHalfOpenSocket [this=7f436181c600 trans=7f436a6a6c00 ent=fe80::20c:29ff:fee2:1de key=......fe80::20c:29ff:fee2:1de:8080]
-2133858560[7f4391f38c40]: nsHalfOpenSocket::OnOutputStreamReady [this=7f436181c600 ent=fe80::20c:29ff:fee2:1de primary]
-2133858560[7f4391f38c40]: nsHalfOpenSocket::SetupPrimaryStream [this=7f436181c600 ent=fe80::20c:29ff:fee2:1de rv=0]
-2133858560[7f4391f38c40]: nsHalfOpenSocket::SetupStreams [this=7f436181c600 ent=......fe80::20c:29ff:fee2:1de:8080] setup routed transport to origin fe80::20c:29ff:fee2:1de:8080 via :443
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::AtActiveConnectionLimit [ci=......fe80::20c:29ff:fee2:1de:8080 caps=21]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::DispatchAbstractTransaction [ci=......fe80::20c:29ff:fee2:1de:8080 trans=7f436a6a6c00 caps=21 conn=7f436187a920]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::DispatchTransaction [ent-ci=......fe80::20c:29ff:fee2:1de:8080 7f435f208c10 trans=7f436a6a6c00 caps=21 conn=7f436187a920 priority=-10]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::OnMsgProcessPendingQ [ci=......fe80::20c:29ff:fee2:1de:8080]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::ProcessPendingQ [ci=......fe80::20c:29ff:fee2:1de:8080]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::ProcessPendingQForEntry [ci=......fe80::20c:29ff:fee2:1de:8080 ent=7f435f208c10 active=0 idle=0 queued=0]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::TimeoutTickCB() this=7f4377528100 host=fe80::20c:29ff:fee2:1de idle=0 active=0 half-len=0 pending=0
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::TryDispatchTransaction without conn [trans=7f436a6a6c00 ci=7f43673a47d0 ci=......fe80::20c:29ff:fee2:1de:8080 caps=21 tunnelprovider=0 onlyreused=0 active=0 idle=0]
-2133858560[7f4391f38c40]: nsSocketTransport::Init [this=7f436a6ad800 host=fe80::20c:29ff:fee2:1de:8080 origin=fe80::20c:29ff:fee2:1de:8080 proxy=:0]
-2133858560[7f4391f38c40]: nsSocketTransport::ResolveHost [this=7f436a6ad800 fe80::20c:29ff:fee2:1de:8080]
-2133858560[7f4391f38c40]: Resolving host [fe80::20c:29ff:fee2:1de].
-2133858560[7f4391f38c40]:   trying address: fe80::20c:29ff:fee2:1de
-2133858560[7f4391f38c40]:   Using cached address for IP Literal [fe80::20c:29ff:fee2:1de].

So the problem might be that it's a link-local IPv6 address, and firefox doesn't know with which interface to resolve it.

After looking around for this specific issue, i found this: https://bugzilla.mozilla.org/show_bug.cgi?id=700999

So, it seems like you are not able to visit a link-local IPv6 address with firefox...

EDIT: By using burp proxy, I am able to connect to my server via http://[<link-local ipv6 address>]:8080 It's not a solution, but at least a workaround until firefox will support link-local ipv6 addresses.

Read this answer in context 👍 1

All Replies (2)

more options

Is IPv6 enabled?

  • network.dns.disableIPv6 = false

I think that this should work:

  • http://[<ipv6-address>]:8080

See also:

more options

Chosen Solution

Yes, IPv6 is enabled.

Unfortunately, http://[<ipv6-address>]:8080 does not work. I tried to restart firefox without plugins to make sure that things like FoxyProxy don't come in the way, but that also didn't solve the problem.

I checked in wireshark, and I don't see a connection attempt from firefox to the webserver.

I also tried to switch on HTTP logging. When I look for the ipv6 address in the logfile, I see those messages:


-1825077376[7f4391f38580]: AltSvcCache::GetAltServiceMapping 7f4377528108 key=http:fe80::20c:29ff:fee2:1de:8080:. existing=0 validated=0 running=0 ttl=0
-1825077376[7f4391f38580]:   Host: [fe80::20c:29ff:fee2:1de]:8080
-1825077376[7f4391f38580]: host=fe80::20c:29ff:fee2:1de port=8080
-1825077376[7f4391f38580]:   Host is IP Literal [fe80::20c:29ff:fee2:1de].
-1825077376[7f4391f38580]: nsHttpAuthCache::GetAuthEntryForPath [key=http://fe80::20c:29ff:fee2:1de:8080 path=/]
-1825077376[7f4391f38580]: nsHttpConnectionMgr::SpeculativeConnect [ci=......fe80::20c:29ff:fee2:1de:8080]
-1825077376[7f4391f38580]: nsHttpConnectionMgr::SpeculativeConnect skipping RFC1918 address [fe80::20c:29ff:fee2:1de]
-1825077376[7f4391f38580]: Resolving host [fe80::20c:29ff:fee2:1de].
-1825077376[7f4391f38580]: uri=http://[fe80::20c:29ff:fee2:1de]:8080/
-2133858560[7f4391f38c40]: Creating nsHalfOpenSocket [this=7f436181c600 trans=7f436a6a6c00 ent=fe80::20c:29ff:fee2:1de key=......fe80::20c:29ff:fee2:1de:8080]
-2133858560[7f4391f38c40]: nsHalfOpenSocket::OnOutputStreamReady [this=7f436181c600 ent=fe80::20c:29ff:fee2:1de primary]
-2133858560[7f4391f38c40]: nsHalfOpenSocket::SetupPrimaryStream [this=7f436181c600 ent=fe80::20c:29ff:fee2:1de rv=0]
-2133858560[7f4391f38c40]: nsHalfOpenSocket::SetupStreams [this=7f436181c600 ent=......fe80::20c:29ff:fee2:1de:8080] setup routed transport to origin fe80::20c:29ff:fee2:1de:8080 via :443
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::AtActiveConnectionLimit [ci=......fe80::20c:29ff:fee2:1de:8080 caps=21]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::DispatchAbstractTransaction [ci=......fe80::20c:29ff:fee2:1de:8080 trans=7f436a6a6c00 caps=21 conn=7f436187a920]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::DispatchTransaction [ent-ci=......fe80::20c:29ff:fee2:1de:8080 7f435f208c10 trans=7f436a6a6c00 caps=21 conn=7f436187a920 priority=-10]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::OnMsgProcessPendingQ [ci=......fe80::20c:29ff:fee2:1de:8080]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::ProcessPendingQ [ci=......fe80::20c:29ff:fee2:1de:8080]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::ProcessPendingQForEntry [ci=......fe80::20c:29ff:fee2:1de:8080 ent=7f435f208c10 active=0 idle=0 queued=0]
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::TimeoutTickCB() this=7f4377528100 host=fe80::20c:29ff:fee2:1de idle=0 active=0 half-len=0 pending=0
-2133858560[7f4391f38c40]: nsHttpConnectionMgr::TryDispatchTransaction without conn [trans=7f436a6a6c00 ci=7f43673a47d0 ci=......fe80::20c:29ff:fee2:1de:8080 caps=21 tunnelprovider=0 onlyreused=0 active=0 idle=0]
-2133858560[7f4391f38c40]: nsSocketTransport::Init [this=7f436a6ad800 host=fe80::20c:29ff:fee2:1de:8080 origin=fe80::20c:29ff:fee2:1de:8080 proxy=:0]
-2133858560[7f4391f38c40]: nsSocketTransport::ResolveHost [this=7f436a6ad800 fe80::20c:29ff:fee2:1de:8080]
-2133858560[7f4391f38c40]: Resolving host [fe80::20c:29ff:fee2:1de].
-2133858560[7f4391f38c40]:   trying address: fe80::20c:29ff:fee2:1de
-2133858560[7f4391f38c40]:   Using cached address for IP Literal [fe80::20c:29ff:fee2:1de].

So the problem might be that it's a link-local IPv6 address, and firefox doesn't know with which interface to resolve it.

After looking around for this specific issue, i found this: https://bugzilla.mozilla.org/show_bug.cgi?id=700999

So, it seems like you are not able to visit a link-local IPv6 address with firefox...

EDIT: By using burp proxy, I am able to connect to my server via http://[<link-local ipv6 address>]:8080 It's not a solution, but at least a workaround until firefox will support link-local ipv6 addresses.

Modified by mmorbitzer